This forum has been moved here:
Helicon Tech Community Forum

  Active TopicsActive Topics  Display List of Forum MembersMemberlist  HelpHelp   RegisterRegister  LoginLogin
LinkFreeze (Forum Locked Forum Locked)
 Helicon Tech : LinkFreeze
Subject Topic: Transform Link on Pages not working (Topic Closed Topic Closed)
Author
Message |
Thunderhawk2008
Newbie


Joined: 16 April 2008
Posts: 8
Posted: 16 April 2008 at 7:51am  

Hi there,

we used LinkFreeze now for some time - today we bought the
Server Lizenz and updated our LinkFreeze Installation.

Now the links are not transformed within our pages.

You can see that on www.samtec.de

We want to see within the pages all links not with index.php?id=xxx but with the transformed form index~id~xxx.htm.

Thanks for soon reply.

Back to Top
 
Yaroslav
Admin Group


Joined: 15 August 2002
Posts: 6520
Posted: 17 April 2008 at 6:38am  

Please show your current LinkFreeze configuration. Better copy entire configuration text file.

__________________
Yaroslav Govorunov,
Helicon Tech
Back to Top Visit Yaroslav's Homepage
 
Thunderhawk2008
Newbie


Joined: 16 April 2008
Posts: 8
Posted: 17 April 2008 at 6:42am  

Here is the content of the INI configuration file:

BEGIN -----------------------
#################################################
# LinkFreeze Configuration file
# Version 2, 2, 0, 80


LogRewrite=True
NotifyOrder=MEDIUM


/        ~~~    .php        [MoveExt,AbsLinks,Redirect,Lowercase]

END ------------------------------

Hope this would give you any idea
what went wrong.

Thx for reply


Back to Top
 
Yaroslav
Admin Group


Joined: 15 August 2002
Posts: 6520
Posted: 18 April 2008 at 5:17am  

Please make sure LinkFreeze ISAPI filter is up and running under your web site properties. Please check Application and System logs for possible error messages. Make sure registration code is entered correctly and no permission issues preventing filer from being load to your web site.

__________________
Yaroslav Govorunov,
Helicon Tech
Back to Top Visit Yaroslav's Homepage
 
Thunderhawk2008
Newbie


Joined: 16 April 2008
Posts: 8
Posted: 18 April 2008 at 5:41am  

Oh - come on - its nice to inform me to check that, but didn't you opened our homepage to see that the isapi filter is running? The transformation within the URL Line is korrekt. So what should be not running within the IIS? The problem is the transformation within the pages isn't available. I can show you some images from IIS configuration pages if you need. I am a networkadmin and as far as i can tell the configuration hasn't changed since it was working korrekt before the update to the new version. License is also korrekt shown. Thats not the problem.

Please help
Thx
Back to Top
 
Thunderhawk2008
Newbie


Joined: 16 April 2008
Posts: 8
Posted: 18 April 2008 at 6:09am  

I have made some screenshots of the config.

Only to be sure that it is correct configured.

Just look at:

http://www.samtec.de/index~id~259.htm

Thx
Back to Top
 
Yaroslav
Admin Group


Joined: 15 August 2002
Posts: 6520
Posted: 18 April 2008 at 7:13am  

It seems like you didn't showed all the configuration file, at least according to the screenshots. Please show your complete configuration file.

__________________
Yaroslav Govorunov,
Helicon Tech
Back to Top Visit Yaroslav's Homepage
 
Thunderhawk2008
Newbie


Joined: 16 April 2008
Posts: 8
Posted: 18 April 2008 at 8:16am  

You mean i have to show these 2 lines which are necessary for /SUpport or /FogBugz? I don't think so, because these are only Virtual Directories which should not have LinkFreeze transformation. So I give these directories only to transform ? to ? and = to = and & to &.

What for should I post this information - If I could I would changed this in the screenshots - but i wouldn't make this effort. Have no time for that.

Just give me a brake - only need help for directory /  !!!!

Please
Back to Top
 
Yaroslav
Admin Group


Joined: 15 August 2002
Posts: 6520
Posted: 21 April 2008 at 4:34am  

We have copied response of your server and tried with build 80 locally - everything was working fine. For now I can only suggest you to downgrade to the version you was previously using, if it worked for you.

__________________
Yaroslav Govorunov,
Helicon Tech
Back to Top Visit Yaroslav's Homepage
 
Thunderhawk2008
Newbie


Joined: 16 April 2008
Posts: 8
Posted: 21 April 2008 at 5:06am  

Hi there,

sorry - but for what was the copy of our iis response? There are links in there which are not transformed - Did you see that? What have you done with the copied page? Just save as htm and open with your IIS locally? For what should that be useful? We have a CMS system here and are using LinkFreeze since this CMS system was installed (around 3 Years). I don't know what for we have to shift back to the old version which was not capabale of using virtual directories and more than one webside? Is it really so difficult to get the new version do what the old version has done? Please - need help - is there any information about the config files? How is it formated? What different entries are possible? For what can we use the text-field under advanced section? Can we put in some information there so tell LinkFreeze what it has to do with Links internal in a page?

Thx for soon reply
V.S
Back to Top
 
Yaroslav
Admin Group


Joined: 15 August 2002
Posts: 6520
Posted: 22 April 2008 at 5:45am  

LinkFreeze don't work with CMSes, etc, it operates on IIS output stream. Partial link change on pages is a usual issue of incorrectly formatted HTML code. Since LinkFreeze analizes HTML response and substitutes links inline it is sensitive for various coding and HTML syntax deviations. So the only possible way for us to check it is to copy response stream of your web site and pass it through LinkFreeze locally.
There also could be a problem with encoding or chunked responses (but your response is unchunked).

__________________
Yaroslav Govorunov,
Helicon Tech
Back to Top Visit Yaroslav's Homepage
 

Sorry, you can NOT post a reply.
This forum has been locked by a forum administrator.

Printable version Printable version
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot delete your posts in this forum
You cannot edit your posts in this forum
You cannot create polls in this forum
You cannot vote in polls in this forum