This forum has been moved here:
Helicon Tech Community Forum

  Active TopicsActive Topics  Display List of Forum MembersMemberlist  HelpHelp   RegisterRegister  LoginLogin
Common Questions (Forum Locked Forum Locked)
 Helicon Tech : Common Questions
Subject Topic: My rule works in Apache but not in IIS (Topic Closed Topic Closed)
Author
Message |
gripe
Newbie


Joined: 25 March 2008
Posts: 1
Posted: 25 March 2008 at 3:23am  

My rule

RewriteRule ^([a-z]{2})/stuff/.+_([0-9]+)/?$ /search.php?lang=$1&MyID=$2 [QSA]

My URL minus the domain

/en/stuff/Michael_%25E5%25A4%25A2_%25E5%25AF%25A7%25E5%25BB%25A3_Johnson_5574/

Problem is that when running this in IIS using IsapiRewriter, I keep getting "The system cannot find the file specified." error.

I ran the same things in Apache and it worked just fine. Can someone please help me make it work in both environments?

Both environments work if I remove all the "%" symbols. But I am not allowed to remove them. They are URLEncoded chinese characters.

I have also used RXTest and it managed to get the values correctly.

Back to Top
 
Yaroslav
Admin Group


Joined: 15 August 2002
Posts: 6520
Posted: 26 March 2008 at 10:09am  

What version of ISAPI_Rewrite you are using? Please try to upgrade to the latest build available. Also please enable logging using RewriteLogLevel 9 and read resulting log file.

__________________
Yaroslav Govorunov,
Helicon Tech
Back to Top Visit Yaroslav's Homepage
 

Sorry, you can NOT post a reply.
This forum has been locked by a forum administrator.

Printable version Printable version
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot delete your posts in this forum
You cannot edit your posts in this forum
You cannot create polls in this forum
You cannot vote in polls in this forum