This forum has been moved here:
Helicon Tech Community Forum

  Active TopicsActive Topics  Display List of Forum MembersMemberlist  HelpHelp   RegisterRegister  LoginLogin
LinkFreeze (Forum Locked Forum Locked)
 Helicon Tech : LinkFreeze
Subject Topic: url too long 400 "bad request" error (Topic Closed Topic Closed)
Author
Message |
josephdickhoene
Newbie


Joined: 07 March 2008
Location: United States
Posts: 8
Posted: 07 March 2008 at 11:00am  

I'm getting a 400 error when my url is longer then 300 chars. long

It doesn't make a difference if I change the length of individual queries in the url.  As long as the whole query is over 300 char I get error.

I've already attempted the below:

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\HTTP\Parameters]
"UrlSegmentMaxLength"=dword:00000000

.....but not working still.

any ideas???

Back to Top
 
Yaroslav
Admin Group


Joined: 15 August 2002
Posts: 6520
Posted: 11 March 2008 at 7:16am  

Another probablility is that you have URLScan installed that limits URL length.

__________________
Yaroslav Govorunov,
Helicon Tech
Back to Top Visit Yaroslav's Homepage
 
josephdickhoene
Newbie


Joined: 07 March 2008
Location: United States
Posts: 8
Posted: 11 March 2008 at 8:10am  

I asked my admin and he said that urlscan wasn't installed

Back to Top
 
Yaroslav
Admin Group


Joined: 15 August 2002
Posts: 6520
Posted: 12 March 2008 at 9:17am  

What is your OS version? Do you have any other IIS add-ons installed?

__________________
Yaroslav Govorunov,
Helicon Tech
Back to Top Visit Yaroslav's Homepage
 
josephdickhoene
Newbie


Joined: 07 March 2008
Location: United States
Posts: 8
Posted: 12 March 2008 at 11:17am  

We have Your isapi rewrite and your linkfreeze.  We also have tealeaf cookie installed but this problem was pre tealeaf cookie.

The OS is windows 2003 server web edition

Back to Top
 
Yaroslav
Admin Group


Joined: 15 August 2002
Posts: 6520
Posted: 13 March 2008 at 6:10am  

And I guess you are using "-" character as replacement? This is definitely UrlSegmentMaxLength problem. Please recheck registry again and make sure there is no typos anywhere.

__________________
Yaroslav Govorunov,
Helicon Tech
Back to Top Visit Yaroslav's Homepage
 
josephdickhoene
Newbie


Joined: 07 March 2008
Location: United States
Posts: 8
Posted: 13 March 2008 at 8:09am  

we have UrlSegmentMaxLength

type is:  REG_DWORD

data is:  0x00000000(0)

Back to Top
 
josephdickhoene
Newbie


Joined: 07 March 2008
Location: United States
Posts: 8
Posted: 14 March 2008 at 10:37am  

I can use a url that is like:

birthdayinabox.com?fff=jjjjjjjjjj

where the jjjjjjj is I put j in 350 chars. long, and the page works

but when I use

birthdayinabox.com-fff-jjjjjjjjjj

and I have jjjj 350 chars long I get: "400 bad request"

Back to Top
 
josephdickhoene
Newbie


Joined: 07 March 2008
Location: United States
Posts: 8
Posted: 14 March 2008 at 12:12pm  

our linkfreeze version is 1.1.0.32

and our isapi rewrite version is 2.11.0069

could this be the issue?

Back to Top
 
Sergey
Admin Group


Joined: 11 March 2005
Posts: 750
Posted: 17 March 2008 at 5:42am  

Changes that are made to the registry will not take effect until you restart the HTTP service. Additionally, you may have to restart any related IIS services.
Back to Top
 
josephdickhoene
Newbie


Joined: 07 March 2008
Location: United States
Posts: 8
Posted: 17 March 2008 at 8:19am  

we restarted everything and still nothing...
Back to Top
 

Sorry, you can NOT post a reply.
This forum has been locked by a forum administrator.

Printable version Printable version
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot delete your posts in this forum
You cannot edit your posts in this forum
You cannot create polls in this forum
You cannot vote in polls in this forum