This forum has been moved here:
Helicon Tech Community Forum

  Active TopicsActive Topics  Display List of Forum MembersMemberlist  HelpHelp   RegisterRegister  LoginLogin
Common Questions (Forum Locked Forum Locked)
 Helicon Tech : Common Questions
Subject Topic: forcing the use use of https (Topic Closed Topic Closed)
Author
Message |
dnagel
Newbie


Joined: 22 April 2007
Location: United States
Posts: 8
Posted: 08 November 2007 at 10:31am  

Can to show me how to force the use of https with select urls?


I want to force https with


http://mysite.com/secure


But not on


http://mysite.com/content


A�


Thanks




Edited by Lexey - 08 November 2007 at 3:54pm
Back to Top Visit dnagel's Homepage
 
Lexey
Moderator Group


Joined: 15 August 2002
Location: Russian Federation
Posts: 8119
Posted: 08 November 2007 at 3:54pm  

What version of the ISAPI_Rewrite are you going to use?
Back to Top
 
dnagel
Newbie


Joined: 22 April 2007
Location: United States
Posts: 8
Posted: 08 November 2007 at 3:56pm  

How do I tell what version I have?

__________________
Dan
Back to Top Visit dnagel's Homepage
 
Lexey
Moderator Group


Joined: 15 August 2002
Location: Russian Federation
Posts: 8119
Posted: 08 November 2007 at 4:18pm  

What is the installation package name that you have used to install the ISAPI_Rewrite?
Back to Top
 
dnagel
Newbie


Joined: 22 April 2007
Location: United States
Posts: 8
Posted: 08 November 2007 at 8:38pm  

The file name is: isapi_rwf_x86_0067.msi

__________________
Dan
Back to Top Visit dnagel's Homepage
 
Lexey
Moderator Group


Joined: 15 August 2002
Location: Russian Federation
Posts: 8119
Posted: 09 November 2007 at 12:53pm  

So, you have ISAPI_Rewrite 2.

Here are the rules:

RewriteCond %HTTPS (?!on).*
RewriteRule /secure(/.*)? https\://mysite.com/secure$1 [I,RP]

RewriteCond %HTTPS on
RewriteRule /content(/.*)? http\://mysite.com/content$1 [I,RP]
Back to Top
 
dnagel
Newbie


Joined: 22 April 2007
Location: United States
Posts: 8
Posted: 09 November 2007 at 1:10pm  

Thanks Lexey

__________________
Dan
Back to Top Visit dnagel's Homepage
 
dnagel
Newbie


Joined: 22 April 2007
Location: United States
Posts: 8
Posted: 09 November 2007 at 2:10pm  

Hi Lexey


I am still having trouble with this. here is my test httpd.ini file.


ISAPI_Rewrite]


#fix URLs without trailing slashes RewriteCond %HTTPS (on).* RewriteCond Host: (.*) RewriteRule ([^.?]+[^.?/]) http(?1s)\://$2$3/ [I,R]


#Force SSL onRewriteCond %HTTPS (?!on).* RewriteRule /secure(/.*)? https\://localhost/secure$1 [I,RP]


#Force SSL offRewriteCond %HTTPS on RewriteRule /content(/.*)? http\://localhost/content$1 [I,RP]


I get the error:


localhost has sent an incorrect or unexpected message. Error Code: -12263


If I comment out the top section, the secure section works but I get the error on the content section.


with nothing commented out I get the error on the secure section.


I can't seem to go from https to http (although I don't really need to do this)


A�


Thanks




Edited by Lexey - 09 November 2007 at 3:37pm
Back to Top Visit dnagel's Homepage
 
Lexey
Moderator Group


Joined: 15 August 2002
Location: Russian Federation
Posts: 8119
Posted: 09 November 2007 at 3:40pm  

I guess the following note should help:

http://www.isapirewrite.com/docs/#prb
Back to Top
 

Sorry, you can NOT post a reply.
This forum has been locked by a forum administrator.

Printable version Printable version
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot delete your posts in this forum
You cannot edit your posts in this forum
You cannot create polls in this forum
You cannot vote in polls in this forum