This forum has been moved here:
Helicon Tech Community Forum

  Active TopicsActive Topics  Display List of Forum MembersMemberlist  HelpHelp   RegisterRegister  LoginLogin
LinkFreeze (Forum Locked Forum Locked)
 Helicon Tech : LinkFreeze
Subject Topic: 404 on new install (Topic Closed Topic Closed)
Author
Message |
joeqca
Newbie


Joined: 25 June 2007
Posts: 4
Posted: 25 June 2007 at 11:00pm  

Hello I have had to upgrade the version of Link Freeze from 0028 to 0072.  Not sure if this is the correct version but these are the numbers at the end of the install files.  The reason for the upgrade is link freeze would not let us in the properties of our websites.(IIS 6/win2003 SBS)  once uninstalled all was good other than the URLS.  We use "+" as the substitute, here is our example:

http://www.tooldesk.com/products/productDetail.aspx?id=1109

with

http://www.tooldesk.com/products/productDetail.aspx+id+1109

This is not working as it generates a 404.

Here is our config file:

#################################################
# LinkFreeze Configuration file
# Version 2, 2, 0, 72


LogRewrite=False
NotifyOrder=MEDIUM


/  +++  

 

Please help.

Thanks,
JoeQ

Back to Top
 
Yaroslav
Admin Group


Joined: 15 August 2002
Posts: 6520
Posted: 26 June 2007 at 7:03am  

Please try to restart IIS on your server now, after editing configuration.
Please make sure LinkFreeze is up and running under your web servers ISAPI filters list and there are no error messages in Application and System log.

__________________
Yaroslav Govorunov,
Helicon Tech
Back to Top Visit Yaroslav's Homepage
 
joeqca
Newbie


Joined: 25 June 2007
Posts: 4
Posted: 26 June 2007 at 8:03am  

Yaoslave,

Under the website properties in IIS the ISAP filter is the only one listed and has a green arrow pointing up. The priority is listed as: *Unkown*. I have restarted IIS and have checked the event log for any errors but no luck.

Here is my config again, you mention after editing it to restart the server but was I suposed to change it?

 

#################################################
# LinkFreeze Configuration file
# Version 2, 2, 0, 72


RegistrationName=tooldesk.com
RegistrationCode=xxxx-xxxx-xxxx-xxxx
LogRewrite=False
NotifyOrder=MEDIUM


/  +++  

Back to Top
 
Yaroslav
Admin Group


Joined: 15 August 2002
Posts: 6520
Posted: 26 June 2007 at 8:44am  

What is logged in IIS log file when you get 404 error?
Are these links was changed by LinkFreeze or you have changed it manually?

__________________
Yaroslav Govorunov,
Helicon Tech
Back to Top Visit Yaroslav's Homepage
 
Yaroslav
Admin Group


Joined: 15 August 2002
Posts: 6520
Posted: 26 June 2007 at 8:54am  

Confirming the problem with a '+' char on a Windows 2003 systems. Fixed build will be available within one day.
I suggest you to consider using some another substitution character.

__________________
Yaroslav Govorunov,
Helicon Tech
Back to Top Visit Yaroslav's Homepage
 
joeqca
Newbie


Joined: 25 June 2007
Posts: 4
Posted: 26 June 2007 at 8:56am  

Here is the IIS Log entry:

2007-06-26 13:35:26 66.179.121.188 GET /products/productDetail.aspx+id+140 - 80 - 66.179.121.131 Mozilla/4.0+(compatible;+MSIE+7.0;+Windows+NT+5.1;+.NET+CLR+1.1.4322;+.NET+CLR+2.0.50727;+InfoPath.1;+.NET+CLR+3.0.04506.30) 404 0 2

Yes these links are changed via link freeze, you can hit tooldesk.com and see all the links are changed(automatically)

Back to Top
 
Yaroslav
Admin Group


Joined: 15 August 2002
Posts: 6520
Posted: 26 June 2007 at 9:27am  

Please download build 73, it addresses this issue.

__________________
Yaroslav Govorunov,
Helicon Tech
Back to Top Visit Yaroslav's Homepage
 
joeqca
Newbie


Joined: 25 June 2007
Posts: 4
Posted: 26 June 2007 at 12:12pm  

Yaroslav you the man! The latest build has fixed the issue.

Hurray!

Back to Top
 

Sorry, you can NOT post a reply.
This forum has been locked by a forum administrator.

Printable version Printable version
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot delete your posts in this forum
You cannot edit your posts in this forum
You cannot create polls in this forum
You cannot vote in polls in this forum