This forum has been moved here:
Helicon Tech Community Forum

  Active TopicsActive Topics  Display List of Forum MembersMemberlist  HelpHelp   RegisterRegister  LoginLogin
LinkFreeze (Forum Locked Forum Locked)
 Helicon Tech : LinkFreeze
Subject Topic: IE7 not decoding pipe | properly (Topic Closed Topic Closed)
Author
Message |
mcbrown
Newbie


Joined: 22 March 2007
Posts: 10
Posted: 23 March 2007 at 3:06pm  

In link freeze I have the ?&= set to convert to pipe |

In Firefox and IE6 my links are coming across properly but in IE7 the pipe sysmbol keeps showing as %7C in the url.

In FireFox is comes across fine as:
/category|categoryID|42679|categoryname|Advertising%20Agencies.htm

But in IE7 the url comes across as:
/category%7CcategoryID%7C42679%7Ccategoryname%7CAdvertising%20Agencies.htm

Any ideas?

Thanks

Back to Top
 
Yaroslav
Admin Group


Joined: 15 August 2002
Posts: 6520
Posted: 24 March 2007 at 11:24am  

One solution is not to use pipe character as a substitution char. Use for example - or / characters.
Another solution is to install ISAPI_Rewrite Lite and decode all characters before LinkFreeze (but this solution may have some other compatibility issues). Here is a rule example:

RewriteRule ([^?]+) $1 [O]

__________________
Yaroslav Govorunov,
Helicon Tech
Back to Top Visit Yaroslav's Homepage
 
mcbrown
Newbie


Joined: 22 March 2007
Posts: 10
Posted: 25 March 2007 at 6:24am  

so is this an issue with ie7?  are others experiencing this as well?

Back to Top
 
Yaroslav
Admin Group


Joined: 15 August 2002
Posts: 6520
Posted: 26 March 2007 at 11:31am  

This is an issue with IE 7 because it encodes | character in the links on a client side before the link gets to the server. LinkFreeze is configured not to decode such links to leave the ability of using substitution characters in a normal file names with a minimum probability of conflicts. Unfortunately IE7 has announced this issue. I think we will have to change this behavoir in the future versions of LinkFreeze meanwhile I suggest you to use another substitution character, like '-'.

__________________
Yaroslav Govorunov,
Helicon Tech
Back to Top Visit Yaroslav's Homepage
 
mcbrown
Newbie


Joined: 22 March 2007
Posts: 10
Posted: 26 March 2007 at 12:09pm  

Any idea when this next version that addresses this will be available?

Thanks

Back to Top
 
Yaroslav
Admin Group


Joined: 15 August 2002
Posts: 6520
Posted: 27 March 2007 at 5:37am  

It will be released in a week.

__________________
Yaroslav Govorunov,
Helicon Tech
Back to Top Visit Yaroslav's Homepage
 
mcbrown
Newbie


Joined: 22 March 2007
Posts: 10
Posted: 27 March 2007 at 9:18am  

perfect..thanks!!
Back to Top
 
mcbrown
Newbie


Joined: 22 March 2007
Posts: 10
Posted: 05 April 2007 at 7:23am  

I wanted to check to see if there was any word on a new version to correct this issue?

Thanks
Micah...

Back to Top
 
Yaroslav
Admin Group


Joined: 15 August 2002
Posts: 6520
Posted: 09 April 2007 at 4:31am  

Sorry, I forgot to inform you. Yes, the latest available build of LinkFreeze (68 I guess) should fix this problem.

__________________
Yaroslav Govorunov,
Helicon Tech
Back to Top Visit Yaroslav's Homepage
 
mcbrown
Newbie


Joined: 22 March 2007
Posts: 10
Posted: 09 April 2007 at 9:55am  

No this still doesnt fix this issue.  We're getting ready to go live soon and I need to known when this will be resolved.  Or if I use ISAPI rewrite what exactly will I do to decode:

%7C    to a    |

before it gets to LinkFreeze?

 

Thanks

Back to Top
 
Yaroslav
Admin Group


Joined: 15 August 2002
Posts: 6520
Posted: 10 April 2007 at 5:44am  

Can you please show me your web site online somehow?
New build will not make links in IE7 looks without %7C because it is not possible since these characters are transformed by IE7 on client side. But with new build all links with shuch characters will work correctly as expected. Link look in IE7 should not be a problem because search engines will actually see '|' instead it.
Another solution again I suggest you to use dash '-' instead of '|' if you want your link to look more beautifully.

__________________
Yaroslav Govorunov,
Helicon Tech
Back to Top Visit Yaroslav's Homepage
 
mcbrown
Newbie


Joined: 22 March 2007
Posts: 10
Posted: 10 April 2007 at 2:38pm  

Unfortunatly this is an internal site andyou wont be able to view it.

I guess I cant do the hyphen then.

Thanks

Back to Top
 

Sorry, you can NOT post a reply.
This forum has been locked by a forum administrator.

Printable version Printable version
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot delete your posts in this forum
You cannot edit your posts in this forum
You cannot create polls in this forum
You cannot vote in polls in this forum