This forum has been moved here:
Helicon Tech Community Forum

  Active TopicsActive Topics  Display List of Forum MembersMemberlist  HelpHelp   RegisterRegister  LoginLogin
LinkFreeze (Forum Locked Forum Locked)
 Helicon Tech : LinkFreeze
Subject Topic: Filtering HTTPS (Topic Closed Topic Closed)
Author
Message |
boxedAUS
Newbie


Joined: 12 January 2007
Posts: 7
Posted: 12 January 2007 at 7:47pm  

Hi there,

I'm trying to restrict LinkFreeze from translating HTTPS pages. I'm a complete noob to RegExp...sorry...but I think I need something along the lines of:

@!https     ...but what comes next, and is this even right?

HELP!

Thank you.

Back to Top
 
boxedAUS
Newbie


Joined: 12 January 2007
Posts: 7
Posted: 12 January 2007 at 11:44pm  

PS I have also tried wildcard HTML filter (rather than regexp) as follows:

http://*

...and that didn't work, either.

Back to Top
 
Yaroslav
Admin Group


Joined: 15 August 2002
Posts: 6520
Posted: 13 January 2007 at 7:39am  

Try the following:

@(?!https\:).*

__________________
Yaroslav Govorunov,
Helicon Tech
Back to Top Visit Yaroslav's Homepage
 
boxedAUS
Newbie


Joined: 12 January 2007
Posts: 7
Posted: 13 January 2007 at 5:47pm  

Thanks Yaroslav, but it's not working. The first link into HTTPS doesn't translate, but once you're within HTTPS, the links are translated again.
Back to Top
 
boxedAUS
Newbie


Joined: 12 January 2007
Posts: 7
Posted: 13 January 2007 at 5:57pm  

Also, I've unchecked 'transform absolute links and it's still translating, even with the filter in place and a full URL given.

Config file:

#################################################
# LinkFreeze Configuration file
# Version 2, 1, 0, 61


LogRewrite=False
NotifyOrder=MEDIUM


/  ~~/ .asp @(?!https\:).* [MoveExt,Redirect]

Back to Top
 
Yaroslav
Admin Group


Joined: 15 August 2002
Posts: 6520
Posted: 16 January 2007 at 5:57am  

This is probably because links within a https web site are actually relative and does not include https:// in front. Then I don't even know what to suggest. To filter LinkFreeze need to have some marks in the links, it cannot deside whether to rewrite links on a fact of http or httos connection itself.

__________________
Yaroslav Govorunov,
Helicon Tech
Back to Top Visit Yaroslav's Homepage
 
boxedAUS
Newbie


Joined: 12 January 2007
Posts: 7
Posted: 16 January 2007 at 4:00pm  

Hi Yaroslav,

The checkout process is as follows:

basket.asp - HTTP
correct form 'action' to...

https://www...checkout_step1.asp
working form 'action' with absolute https URL to...

https://www...checkout_step1_save.asp
VBScript redirect (Response.Redirect) to...

https://www...checkout_step2.asp
BUT...this is where it breaks down - the link is definitely to https://*.asp, but the URL is automatically translated to https://*.htm

I've tried with a response.redirect and a manual <a href> and the same thing happens.

Any ideas? This is the last thing I need to fix before rolling out the site and it's very frustrating...

Other than this, LinkFreeze works perfectly and your support is absolutely first-class, thank you!

Back to Top
 
boxedAUS
Newbie


Joined: 12 January 2007
Posts: 7
Posted: 16 January 2007 at 4:19pm  

Sorry, in the above post the basket URL should have read basket.htm as this is working correctly.
Back to Top
 
Yaroslav
Admin Group


Joined: 15 August 2002
Posts: 6520
Posted: 17 January 2007 at 9:28am  

Do you have "Transform absolute links" enabled in your LinkFreeze setup? If yes, then disable it and change problematic link to absolute format. LinkFreeze will not touch links in absolute format.

__________________
Yaroslav Govorunov,
Helicon Tech
Back to Top Visit Yaroslav's Homepage
 
boxedAUS
Newbie


Joined: 12 January 2007
Posts: 7
Posted: 17 January 2007 at 4:11pm  

No, transform absolute is not checked.
Back to Top
 
Yaroslav
Admin Group


Joined: 15 August 2002
Posts: 6520
Posted: 18 January 2007 at 4:02am  

Then edit problematic links into the absolute format and LinkFreeze will not touch it. And you don't need HTML filter after that.
And please show me your web site and page with the problematic links.

__________________
Yaroslav Govorunov,
Helicon Tech
Back to Top Visit Yaroslav's Homepage
 

Sorry, you can NOT post a reply.
This forum has been locked by a forum administrator.

Printable version Printable version
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot delete your posts in this forum
You cannot edit your posts in this forum
You cannot create polls in this forum
You cannot vote in polls in this forum