This forum has been moved here:
Helicon Tech Community Forum

  Active TopicsActive Topics  Display List of Forum MembersMemberlist  HelpHelp   RegisterRegister  LoginLogin
HotlinkBlocker (Forum Locked Forum Locked)
 Helicon Tech : HotlinkBlocker
Subject Topic: Protecting WMV files (Topic Closed Topic Closed)
Author
Message |
finallynaked
Groupie


Joined: 02 April 2006
Location: Denmark
Posts: 61
Posted: 27 July 2006 at 12:58pm  

I did this

Enable Link protection and added the signatur to my links.
The signing of the links works but if you remove the signing part and past the path into a html page there is no problem leeching the wmv files.
So what am I doing wrong here ?

Back to Top
 
Sergey
Admin Group


Joined: 11 March 2005
Posts: 750
Posted: 28 July 2006 at 4:13am  

Please show your configuration file.
Back to Top
 
finallynaked
Groupie


Joined: 02 April 2006
Location: Denmark
Posts: 61
Posted: 28 July 2006 at 4:35am  

#################################################
# HotlinkBlocker Configuration file


Signature=34af2251-7881-4d7e-ad57-df38744f3491
LinkExpires=1800
NotifyOrder=MEDIUM


[Protect]
LINK  \media\wmv 


[ReferersBlackList]
[ReferersWhiteList]
*lazykiller*
[UserAgentsBlackList]
[UserAgentsWhiteList]

Back to Top
 
Sergey
Admin Group


Joined: 11 March 2005
Posts: 750
Posted: 28 July 2006 at 4:56am  

[Protect]
LINK /media/wmv
Back to Top
 
finallynaked
Groupie


Joined: 02 April 2006
Location: Denmark
Posts: 61
Posted: 28 July 2006 at 5:21am  

#################################################
# HotlinkBlocker Configuration file


Signature=34af2251-7881-4d7e-ad57-df38744f3491
LinkExpires=1800
NotifyOrder=MEDIUM


[Protect]
LINK  /media/wmv 


[ReferersBlackList]
[ReferersWhiteList]
*lazykiller*
[UserAgentsBlackList]
[UserAgentsWhiteList]

 

Still the same problem, do I need to set any permissions on any of the files inside install dir ?

Back to Top
 
Yaroslav
Admin Group


Joined: 15 August 2002
Posts: 6520
Posted: 28 July 2006 at 5:31am  

Please show us some examples - your site link and hot link form other site.

__________________
Yaroslav Govorunov,
Helicon Tech
Back to Top Visit Yaroslav's Homepage
 
Sergey
Admin Group


Joined: 11 March 2005
Posts: 750
Posted: 28 July 2006 at 5:32am  

Can I see your site online?
Back to Top
 
finallynaked
Groupie


Joined: 02 April 2006
Location: Denmark
Posts: 61
Posted: 28 July 2006 at 6:39am  

Ill set it up and post back

 

Back to Top
 
finallynaked
Groupie


Joined: 02 April 2006
Location: Denmark
Posts: 61
Posted: 07 August 2006 at 6:30am  

Sorry it took some time:
http://64.72.127.232/test.asp

It's a bit strange as now nothing is written in the request variable:
Here is the code:

<html><body topmargin=0 leftmargin=0 rightmargin=0 bottommargin=0>

her: <%=Request.ServerVariables("HTTP_X_HOTLINKBLOCKER_SIGNATU RE")%><br>

<embed src="media/wmv/<%=Request.ServerVariables("HTTP_X_HOTLINK BLOCKER_SIGNATURE")%>/Accidents_of_sport060410.wmv" width=445 height=400 autoplay="true" controller="true" loop="false" volume="-20" showstatusbar="-1"></embed>
</body>
</html>

Back to Top
 
finallynaked
Groupie


Joined: 02 April 2006
Location: Denmark
Posts: 61
Posted: 07 August 2006 at 6:41am  

here is where i leech the file
http://www.finallynaked.com/leech.html
Back to Top
 
Yaroslav
Admin Group


Joined: 15 August 2002
Posts: 6520
Posted: 07 August 2006 at 9:13am  

Then either LINK protection is turned offor HotlinkBlocker ISAPI filter is turned off. Please check ISAPI filters tab and make sure HtolinkBlocker ISAPI filter is up and running. Check System and Application log for possible error messages.

__________________
Yaroslav Govorunov,
Helicon Tech
Back to Top Visit Yaroslav's Homepage
 
finallynaked
Groupie


Joined: 02 April 2006
Location: Denmark
Posts: 61
Posted: 07 August 2006 at 2:45pm  

this error showed up in event log

Initialization failed. Please check configuration.

Back to Top
 
Yaroslav
Admin Group


Joined: 15 August 2002
Posts: 6520
Posted: 07 August 2006 at 3:16pm  

Is this HotlinkBlocker related message? If so then please try to download instalation package and install again. And don't forget to login as Administrator when installing it.

__________________
Yaroslav Govorunov,
Helicon Tech
Back to Top Visit Yaroslav's Homepage
 
finallynaked
Groupie


Joined: 02 April 2006
Location: Denmark
Posts: 61
Posted: 08 August 2006 at 3:48am  

That did the trick it works now
Back to Top
 

Sorry, you can NOT post a reply.
This forum has been locked by a forum administrator.

Printable version Printable version
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot delete your posts in this forum
You cannot edit your posts in this forum
You cannot create polls in this forum
You cannot vote in polls in this forum