This forum has been moved here:
Helicon Tech Community Forum

  Active TopicsActive Topics  Display List of Forum MembersMemberlist  HelpHelp   RegisterRegister  LoginLogin
HotlinkBlocker (Forum Locked Forum Locked)
 Helicon Tech : HotlinkBlocker
Subject Topic: Images Are Blocked On Main Site Also! (Topic Closed Topic Closed)
Author
Message |
FlirtCatalog
Newbie


Joined: 01 June 2006
Location: United States
Posts: 2
Posted: 01 June 2006 at 2:07pm  

Installed just fine.
Tried to block /store/assets/* directory and subdirectories
Block works fine from other sites
BUT...
It is also blocking from our main site???
I tried to add our site to the white list but still blocking all images..

A little help please!!

Platform: Win2k Running SiteServer 3.0 Commerce Edition

INI File:

#################################################
# HotlinkBlocker Configuration file


Signature=59741520-7d05-4aa1-aceb-13f032bccfe8
LinkExpires=1800
NotifyOrder=MEDIUM


[Protect]
REDIRECT /store/assets/* http://www.flirtcatalog.com/flirtlogo_blocked.jpg


[ReferersBlackList]
[ReferersWhiteList]
http://www.flirtcatalog.com
http://flirtcatalog.com
http://www.flirtcatalog.com/store
http://flirtcatalog.com/store
http://www.flirtcatalog.com/*
[UserAgentsBlackList]
[UserAgentsWhiteList]

Back to Top Visit FlirtCatalog's Homepage
 
Yaroslav
Admin Group


Joined: 15 August 2002
Posts: 6520
Posted: 02 June 2006 at 2:05pm  

Can you pelase show me an example page with the broken images?

__________________
Yaroslav Govorunov,
Helicon Tech
Back to Top Visit Yaroslav's Homepage
 
Yaroslav
Admin Group


Joined: 15 August 2002
Posts: 6520
Posted: 02 June 2006 at 2:06pm  

And don't use REDIRECT protection for images, use REFERER or LINK instead.

__________________
Yaroslav Govorunov,
Helicon Tech
Back to Top Visit Yaroslav's Homepage
 
FlirtCatalog
Newbie


Joined: 01 June 2006
Location: United States
Posts: 2
Posted: 05 June 2006 at 12:15pm  

Ok my bad.... I changed to Referer and works fine now EXCEPT...

I have image popups on the product page that were not working until i added the following to the white list ( @^$ )

 

What is this Not Blocking with that in the white list?

Is there a better way to get the popups to work?

 

Dan

Back to Top Visit FlirtCatalog's Homepage
 
Yaroslav
Admin Group


Joined: 15 August 2002
Posts: 6520
Posted: 06 June 2006 at 5:57am  

The better way if to use LINK protection. I guess the pop-up didn't work because it does not send referrer header, so you enabled empty referrers and it strat working.

__________________
Yaroslav Govorunov,
Helicon Tech
Back to Top Visit Yaroslav's Homepage
 

Sorry, you can NOT post a reply.
This forum has been locked by a forum administrator.

Printable version Printable version
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot delete your posts in this forum
You cannot edit your posts in this forum
You cannot create polls in this forum
You cannot vote in polls in this forum