This forum has been moved here:
Helicon Tech Community Forum

  Active TopicsActive Topics  Display List of Forum MembersMemberlist  HelpHelp   RegisterRegister  LoginLogin
HotlinkBlocker (Forum Locked Forum Locked)
 Helicon Tech : HotlinkBlocker
Subject Topic: HotlinkBlocker 1.3 (72) and IIS delays (Topic Closed Topic Closed)
Author
Message |
s2001
Newbie


Joined: 21 November 2002
Posts: 27
Posted: 31 May 2006 at 3:48pm  

Hello,

I use Win2003 SP1, ASP (.net installed but not used), SQL2005 SP1, HotlinkBlocker 1.3 (72)
When I enabled HotlinkBlocker (LINK or REFERRER, *users* template) for single site with ASP (webwizforums, http://www.webwizguide.com/) using, I got big delays with ASP responce - at least 1-3 times per day. In the same time CPU utilization is low and other sites (non ASP) work properly
Only iisreset may help me :(

Could you please help me? Are there way to troubleshoot/log issue?
Thanks

Sergey
Back to Top
 
Yaroslav
Admin Group


Joined: 15 August 2002
Posts: 6520
Posted: 01 June 2006 at 8:29am  

There is no log for HotlinkBlocker because it does nto do anything as complex to log this. There is a debug build but first I need to make sure you really need it. First of all there is no 72 build of HotlinkBlocker, latest available build is 47. Next can you please show me the HotlinkBlocker configuration (text file) and site where it si configured?

__________________
Yaroslav Govorunov,
Helicon Tech
Back to Top Visit Yaroslav's Homepage
 
s2001
Newbie


Joined: 21 November 2002
Posts: 27
Posted: 04 June 2006 at 11:48pm  

Thank you
After many delays I deinstalled blocker and problem was solved instantly
I don't use special configuration - just installed blocker, set LINK protection. Could you please check issue on your side? I can't slow down live site...
Thank you!
Back to Top
 
Yaroslav
Admin Group


Joined: 15 August 2002
Posts: 6520
Posted: 05 June 2006 at 4:45am  

There is no delays from our side, and we have tested HotlinkBlocker under a really high load.
I need to know how you have installed HotlinkBlocker, what areas of your site you are trying to protect and how? What other modifications you made to your site? The delays may be triggered by a HotlinkBlocker (or other modifications you made) in some other applications.

__________________
Yaroslav Govorunov,
Helicon Tech
Back to Top Visit Yaroslav's Homepage
 
s2001
Newbie


Joined: 21 November 2002
Posts: 27
Posted: 05 June 2006 at 8:52am  

I installed it with msi file, enabled for one site only (not virtual dir) with string *users* and LINK protection
And I got huge delays after 0,5-2 days.
CPU still low, other sites (non ASP) work fine
And delays may be fixed with iisreset

PS This site configured with separate application pool
PPS I protecting simple html files under subfolders like /test/users/test2/page.htm
Back to Top
 
Yaroslav
Admin Group


Joined: 15 August 2002
Posts: 6520
Posted: 05 June 2006 at 9:42am  

First of all directory string should be /test/users
Next, LINK protection will not work if you just "enable" HotlinkBlocker because it requires modification to your site links. Actually protection will work making your files unaccessible for all users including yours.

__________________
Yaroslav Govorunov,
Helicon Tech
Back to Top Visit Yaroslav's Homepage
 
s2001
Newbie


Joined: 21 November 2002
Posts: 27
Posted: 05 June 2006 at 3:37pm  

Yaroslav, I see... So, it's not possible protect all folders like /test/users/test1 & /test/monday/users/pics etc? And we have to set individual paths?

About LINK - sorry, I used REDIRECT protection

I also have ISAPIRewrite lite 2.8 configured for another domain (which also used ASP). Here is ini file:

[ISAPI_Rewrite]
# Defend your computer from some worm attacks
RewriteRule .*(?:global.asa|default\.ida|root\.exe|\.\.).* . [F,I,O]
RewriteCond Host: test\.ru
RewriteRule (.*) http\://www.test.ru$1 [I,R]

May it cause the issue/incompatibility?
Back to Top
 
Yaroslav
Admin Group


Joined: 15 August 2002
Posts: 6520
Posted: 06 June 2006 at 6:06am  

There is a way to protect these folders, but you didn't mention that you need it. Yes, for multiple folder protection the directory pattern better would be as: @[^?.]*users.*
Please note that HotlinkBlocker itself cannot hang, and even if it happens entire server will be locked, not the only ASP pages. So I assume the problem comes from other application, but probably triggered by a HotlinkBlocker configuration.

__________________
Yaroslav Govorunov,
Helicon Tech
Back to Top Visit Yaroslav's Homepage
 
s2001
Newbie


Joined: 21 November 2002
Posts: 27
Posted: 06 June 2006 at 9:50am  

Thank you! I will try new pattern
Back to Top
 

Sorry, you can NOT post a reply.
This forum has been locked by a forum administrator.

Printable version Printable version
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot delete your posts in this forum
You cannot edit your posts in this forum
You cannot create polls in this forum
You cannot vote in polls in this forum