This forum has been moved here:
Helicon Tech Community Forum

  Active TopicsActive Topics  Display List of Forum MembersMemberlist  HelpHelp   RegisterRegister  LoginLogin
HotlinkBlocker (Forum Locked Forum Locked)
 Helicon Tech : HotlinkBlocker
Subject Topic: Problem with Link Protection (Topic Closed Topic Closed)
Author
Message |
Afterimage
Newbie


Joined: 10 May 2006
Posts: 2
Posted: 10 May 2006 at 4:11pm  

Hello. I am having a problem setting up Link protection with HotlinkBlocker.

I have a test page at http://www.wcd.net/test.htm
This contains a link to a server that has HotlinkBlocker installed, the config file is as follows:

#################################################
# HotlinkBlocker Configuration file


Signature=dfgrthdjty6enfjt
LinkExpires=1800
NotifyOrder=MEDIUM


[Protect]
LINK        /streaming   


[ReferersBlackList]
[ReferersWhiteList]
[UserAgentsBlackList]
[UserAgentsWhiteList]

As you can see, the /streaming directory is protected. Here is a link to a file in that directory:

http://streaming.legalcontent.com:8080/streaming/dfgrthdjty6 enfjt_test.wmv

Note that the webserver is running on port 8080, but I don't think this will pose a problem.

I keep getting a 404 error, even though the link is formatted correctly.

Any ideas?

Thanks.
Back to Top
 
Yaroslav
Admin Group


Joined: 15 August 2002
Posts: 6520
Posted: 11 May 2006 at 2:20pm  

I guess you are trying to access by a link signed on another server? In this case HotlinkBlocker should be installed on both servers. And on www.wcd.net you will need to enable LINK protection for some (possibly fake) directory to start signing the links. Also you will need to copy Signature value form one HotlinkBlocker installation into another. Here it is explained in documentation: http://www.helicontech.com/hotlinkblocker/doc/sharing.htm

__________________
Yaroslav Govorunov,
Helicon Tech
Back to Top Visit Yaroslav's Homepage
 
Afterimage
Newbie


Joined: 10 May 2006
Posts: 2
Posted: 11 May 2006 at 4:15pm  

Thanks for the reply. I must of missed that part.
Back to Top
 

Sorry, you can NOT post a reply.
This forum has been locked by a forum administrator.

Printable version Printable version
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot delete your posts in this forum
You cannot edit your posts in this forum
You cannot create polls in this forum
You cannot vote in polls in this forum