This forum has been moved here:
Helicon Tech Community Forum

  Active TopicsActive Topics  Display List of Forum MembersMemberlist  HelpHelp   RegisterRegister  LoginLogin
HotlinkBlocker (Forum Locked Forum Locked)
 Helicon Tech : HotlinkBlocker
Subject Topic: Initialization problem (Topic Closed Topic Closed)
Author
Message |
nfjeld
Newbie


Joined: 17 March 2006
Location: United States
Posts: 3
Posted: 17 March 2006 at 4:53pm  

Hi,
We downloaded the trial version and we are testing it out on our dev server.  We followed the directions in the help files for install and set up.  Everything went smoothly.

When we attempt to access a protected file we get an event log error.  Any suggestions on what may be the problem?

Initialization failed. Please check configuration.

Thanks

Nathan Fjeld

Back to Top
 
Lexey
Moderator Group


Joined: 15 August 2002
Location: Russian Federation
Posts: 8119
Posted: 17 March 2006 at 5:11pm  

If you have got this message then something really strange is happening with your system. It could occur if the proxy was unable to create I/O completion port or semaphore. May be you have changed some proxy setting to very high values?
Back to Top
 
nfjeld
Newbie


Joined: 17 March 2006
Location: United States
Posts: 3
Posted: 17 March 2006 at 5:37pm  

I'm afraid I don't know what you mean by this.  If we are not running proxies on our webservers, where should we be looking for this configuration?

The software appears to be "turned on" when we access it in IIS, and the filter shows up as active, but there is no content blocking and we get the "initialization failure" message.

Back to Top
 
Lexey
Moderator Group


Joined: 15 August 2002
Location: Russian Federation
Posts: 8119
Posted: 17 March 2006 at 6:08pm  

Ops, sorry. I have not noticed that you are talking about HotlinkBlocker. I have though that it is about ISAPI_Rewrite. Please, ignore my previous message and wait for Yaroslav's answer.
Back to Top
 
Yaroslav
Admin Group


Joined: 15 August 2002
Posts: 6520
Posted: 20 March 2006 at 6:14am  

Most likely this error is happening due to insuffient permissions to read configuration file. To confirm it set Everyone read access to the Filters directory under HotlinkBlocker installation folder.

__________________
Yaroslav Govorunov,
Helicon Tech
Back to Top Visit Yaroslav's Homepage
 
nfjeld
Newbie


Joined: 17 March 2006
Location: United States
Posts: 3
Posted: 20 March 2006 at 8:59am  

Thank you, we did finally figure that out this weekend.  We are running into another issue.  Now that we have it installed and running, users can no longer right click and save the files in IE.  They can still right click and save in firefox.  Is there a way to get around this?  We are currently using the referer method.  Can it be done without moving to LINK?
Nathan Fjeld
Back to Top
 
Yaroslav
Admin Group


Joined: 15 August 2002
Posts: 6520
Posted: 20 March 2006 at 9:21am  

Without LINK protection - no. IE does not send referrer HTTP header when user click Save As, so any protection based on referrer will not work. You can enable empty referrers by putting following expression in whitelist: @^$ but this will also enable hotlinkers to access files using Save As method.

__________________
Yaroslav Govorunov,
Helicon Tech
Back to Top Visit Yaroslav's Homepage
 

Sorry, you can NOT post a reply.
This forum has been locked by a forum administrator.

Printable version Printable version
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot delete your posts in this forum
You cannot edit your posts in this forum
You cannot create polls in this forum
You cannot vote in polls in this forum