This forum has been moved here:
Helicon Tech Community Forum

  Active TopicsActive Topics  Display List of Forum MembersMemberlist  HelpHelp   RegisterRegister  LoginLogin
HotlinkBlocker (Forum Locked Forum Locked)
 Helicon Tech : HotlinkBlocker
Subject Topic: BUG!!!!!!!!! DAM (Topic Closed Topic Closed)
Author
Message |
taranonline
Newbie


Joined: 26 December 2005
Posts: 6
Posted: 26 December 2005 at 11:09am  

when i click on link genrated by hotlink blocker using link protection w3wp.exe process goes to 100% usage. IIS hangs whole server hangs.. Whats it.

I am hving over 20000 files in folder where I am using it.
Back to Top
 
Yaroslav
Admin Group


Joined: 15 August 2002
Posts: 6520
Posted: 26 December 2005 at 12:40pm  

What version of HotlinkBlocker you are using? And show us your configuration file.

__________________
Yaroslav Govorunov,
Helicon Tech
Back to Top Visit Yaroslav's Homepage
 
Yaroslav
Admin Group


Joined: 15 August 2002
Posts: 6520
Posted: 26 December 2005 at 12:41pm  

And what is your OS version and other configuration details.

__________________
Yaroslav Govorunov,
Helicon Tech
Back to Top Visit Yaroslav's Homepage
 
Yaroslav
Admin Group


Joined: 15 August 2002
Posts: 6520
Posted: 26 December 2005 at 1:40pm  

PS: I have one assumption. Maybe you have added / folder to the protection list? Then you may get infinite redirect loop since all requests to your site are treated as hotlinks.

__________________
Yaroslav Govorunov,
Helicon Tech
Back to Top Visit Yaroslav's Homepage
 
taranonline
Newbie


Joined: 26 December 2005
Posts: 6
Posted: 26 December 2005 at 1:52pm  

Quote: Originally posted by Yaroslav on 26 December 2005
What version of HotlinkBlocker you are using? And show us your configuration file.



I downloaded your software few hours ago. and where is the configration file?
Back to Top
 
taranonline
Newbie


Joined: 26 December 2005
Posts: 6
Posted: 26 December 2005 at 1:55pm  

Quote: Originally posted by Yaroslav on 26 December 2005
And what is your OS version and other configuration details.



OS is windows 2003 std. and its 1 gb ram with amd 64bit 3000+ . 600 GB HDD. Actually it is a mp3 server having over 20,000 files in one folder c:\inetpub\wwwroot\albums\folders and folders\.
Back to Top
 
taranonline
Newbie


Joined: 26 December 2005
Posts: 6
Posted: 26 December 2005 at 1:56pm  

Quote: Originally posted by Yaroslav on 26 December 2005
PS: I have one assumption. Maybe you have added / folder to the protection list? Then you may get infinite redirect loop since all requests to your site are treated as hotlinks.



so whats the solution to it.
Back to Top
 
Yaroslav
Admin Group


Joined: 15 August 2002
Posts: 6520
Posted: 26 December 2005 at 2:26pm  

So you did add '/' to the directories list? Then rmove it, it shouldn't be there. You need to specify some folders where the protected content is stored, like /mp3. Unless your site is entirely dedicated to store protected files but then you will need some more configuration steps.
Can you explain desired protection scenario here?

__________________
Yaroslav Govorunov,
Helicon Tech
Back to Top Visit Yaroslav's Homepage
 
taranonline
Newbie


Joined: 26 December 2005
Posts: 6
Posted: 26 December 2005 at 2:33pm  

Quote: Originally posted by Yaroslav on 26 December 2005
So you did add '/' to the directories list? Then rmove it, it shouldn't be there. You need to specify some folders where the protected content is stored, like /mp3. Unless your site is entirely dedicated to store protected files but then you will need some more configuration steps.
Can you explain desired protection scenario here?



here is what I did.

c:\inetpub\wwwroot\albums\genre(1-13)\albumid(1-1600)\(here comes the anti leech)albumid-songno.mp3

what should I do?
wasnt it at the right place?

please email me if you can tarano[email protected] I cant discuss everything publically.
Back to Top
 
Yaroslav
Admin Group


Joined: 15 August 2002
Posts: 6520
Posted: 26 December 2005 at 2:44pm  

Go to the HotlinkBLocker installation folder, form the Filters subfolder and send to the [email protected]ontech.com all *.ini files - this is what I call configuration file.

__________________
Yaroslav Govorunov,
Helicon Tech
Back to Top Visit Yaroslav's Homepage
 
taranonline
Newbie


Joined: 26 December 2005
Posts: 6
Posted: 26 December 2005 at 3:01pm  

whats next?
Back to Top
 
Yaroslav
Admin Group


Joined: 15 August 2002
Posts: 6520
Posted: 29 December 2005 at 6:32am  

Please download HotlinkBlocker build 42, it should fix your problem.

__________________
Yaroslav Govorunov,
Helicon Tech
Back to Top Visit Yaroslav's Homepage
 

Sorry, you can NOT post a reply.
This forum has been locked by a forum administrator.

Printable version Printable version
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot delete your posts in this forum
You cannot edit your posts in this forum
You cannot create polls in this forum
You cannot vote in polls in this forum