This forum has been moved here:
Helicon Tech Community Forum

  Active TopicsActive Topics  Display List of Forum MembersMemberlist  HelpHelp   RegisterRegister  LoginLogin
Common Questions (Forum Locked Forum Locked)
 Helicon Tech : Common Questions
Subject Topic: Problem wit long URI (Topic Closed Topic Closed)
Author
Message |
vbrook
Newbie


Joined: 04 October 2005
Location: United States
Posts: 12
Posted: 04 October 2005 at 1:21pm  

For long urls like

http://xxx.yyyyyyyy.com/IndividualProduct~ProductID~77037~from~7~PID~95040~sel_255~0~selUnit_256~250~txtFrom_256~1~txtTo_256~100~selUnit_257~250~txtFrom_257~1~txtTo_257~100~selUnit_258~250~txtFrom_258~1~txtTo_258~100~selUnit_259~216~txtFrom_259~1~txtTo_259~100.html

I getting HTTP 400 - Bad Request.

Vlad Brook

Back to Top
 
Yaroslav
Admin Group


Joined: 15 August 2002
Posts: 6520
Posted: 05 October 2005 at 3:18am  

I guess it is because you have exceeded possible RUL path length in IIS. Anyway there is no any reason of removing question marks form that long URLs, it will not be crawled anyway. Just disable LinkFreeze for that page containing such links.

__________________
Yaroslav Govorunov,
Helicon Tech
Back to Top Visit Yaroslav's Homepage
 
vbrook
Newbie


Joined: 04 October 2005
Location: United States
Posts: 12
Posted: 05 October 2005 at 3:28pm  

Yaroslav,

It looks like in IIS 6.0 default settings for UrlSegmentMaxLength is 260.

I can increase it, but you are saying that it will not be crawled anyway.

Can you elaborate why?

Spacibo.

Vlad

Back to Top
 
vbrook
Newbie


Joined: 04 October 2005
Location: United States
Posts: 12
Posted: 05 October 2005 at 9:18pm  

Also if I'll restore "freezed" link to original form or with LinkFreeze disabled the very same link works without any problem so length should not be an issue. I've set UrlSegmentMaxLength to 1024, but it did not help so far.

SEO is a different story. This link most of the time is short, one or two params, but sometimes it became ugly long and I have no problem if it will be ignored by crawlers, but it fails for clients who have generated this long URL. It's rare, but happens. Is it possible to set some flags or else in URL to make Link Freeze to leave it as it is? Kind of inline disable for Link Freeze.

Spacibo.

Vlad

Back to Top
 
Yaroslav
Admin Group


Joined: 15 August 2002
Posts: 6520
Posted: 06 October 2005 at 7:13am  

Can I see the page with that link online?

__________________
Yaroslav Govorunov,
Helicon Tech
Back to Top Visit Yaroslav's Homepage
 
vbrook
Newbie


Joined: 04 October 2005
Location: United States
Posts: 12
Posted: 06 October 2005 at 10:07am  

I had to disable LinkFreeze on online pages in error. Without it works and it looks like:

http://tst.reedlink.com/IndividualProduct.aspx?ProductID=18820&KSPCProductId=18939&from=7&PID=77344&selUnit_261=687&txtFrom_261=1&txtTo_261=1000&txtFrom_260=1&txtTo_260=1000&selUnit_262=18&txtFrom_262=&txtTo_262=1000&selUnit_264=250&txtFrom_264=1&txtTo_264=10000&selUnit_265=250&txtFrom_265=1&txtTo_265=10000&

on dev site with LinkFreeze enabled it does not work(HTTP 400 - Bad Request) and looks like:

http://dev.reedlink.com/IndividualProduct~ProductID~18820~KSPCProductId~18939~from~7~PID~145128~selUnit_261~687~txtFrom_261~1~txtTo_261~1000~txtFrom_260~1~txtTo_260~1000~selUnit_262~18~txtFrom_262~~txtTo_262~~selUnit_264~250~txtFrom_264~1~txtTo_264~10000~selUnit_265~250~txtFrom_265~1~txtTo_265~10000~.html

if I'll remove some parameters from the same query, making it shorter it works:

http://dev.reedlink.com/IndividualProduct~ProductID~18820~from~7~PID~77225~selUnit_261~687~txtFrom_261~1~txtTo_261~1000~txtFrom_260~1~txtTo_260~1000~selUnit_262~18~txtFrom_262~~txtTo_262~1000~selUnit_264~250~txtTo_264~10000~selUnit_265~250~txtFrom_265~1~txtTo_265~10000~.html

Spacibo

Vlad

Back to Top
 
Yaroslav
Admin Group


Joined: 15 August 2002
Posts: 6520
Posted: 07 October 2005 at 3:18am  

Try to remove trailing & from the original URL.

__________________
Yaroslav Govorunov,
Helicon Tech
Back to Top Visit Yaroslav's Homepage
 
vbrook
Newbie


Joined: 04 October 2005
Location: United States
Posts: 12
Posted: 07 October 2005 at 8:37am  

Sure I've tryed that already, but it did not help. Also shorter URL with terminating & works fine. 

Is it possible to exclude some links on the page from beeing converted by LinkFreeze? say some attribute like <a linkfreeze="dissabled" href= "wery long URL not intended for SEO" >Foo</a>

Spacibo

Vlad

 

Back to Top
 
Yaroslav
Admin Group


Joined: 15 August 2002
Posts: 6520
Posted: 08 October 2005 at 6:22am  

Unfortunately current version of LinkFreeze could be disabled only on a page level.
You can try to use absolute link:
<a href= "http://dev.reedlink.com..."> this may stop LinkFreeze from changing link if your IIS is not setup to use dev.reedlink.com for backreferences.

__________________
Yaroslav Govorunov,
Helicon Tech
Back to Top Visit Yaroslav's Homepage
 
vbrook
Newbie


Joined: 04 October 2005
Location: United States
Posts: 12
Posted: 08 October 2005 at 2:59pm  

So, I'm back to original question: why long "Frozen" URL, see above, fails with Http 400?  Is there anybody else using LinkFreeze with a URL longer then 256 chars that does not have my problem?  May be not length, but number of parameters? Can you affirm that LinkFreeze" can handle href with length up to 512 and/or 32 parameters on IIS 6.0?

Also I was surprised to discover that LinkFreeze modifies action attribute of the form the same way as it does for href and POST fails with the same HTTP-400. I have 50 licenses for LinkFreeze and must to find some workaround.

Is it possible to use ReWrite to enable/disable links and/or action attribute?

Vlad

Back to Top
 
Yaroslav
Admin Group


Joined: 15 August 2002
Posts: 6520
Posted: 10 October 2005 at 4:39am  

Please show me the page on your site where the error link uppears, not the link itself. We will try to investigate it here.

__________________
Yaroslav Govorunov,
Helicon Tech
Back to Top Visit Yaroslav's Homepage
 
Yaroslav
Admin Group


Joined: 15 August 2002
Posts: 6520
Posted: 10 October 2005 at 4:59am  

BTW, I was unable to connect to your dev site to see the error in action? Can you do something to help me to see the error?

__________________
Yaroslav Govorunov,
Helicon Tech
Back to Top Visit Yaroslav's Homepage
 
Yaroslav
Admin Group


Joined: 15 August 2002
Posts: 6520
Posted: 10 October 2005 at 6:38am  

We found a solution. This is actually IIS6 limitation. It will not accept that long filenames. Set the following registry key to owercome this limitation:[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\HTTP\Parameters]
"UrlSegmentMaxLength"=dword:00000000


__________________
Yaroslav Govorunov,
Helicon Tech
Back to Top Visit Yaroslav's Homepage
 
vbrook
Newbie


Joined: 04 October 2005
Location: United States
Posts: 12
Posted: 17 October 2005 at 5:34pm  

Hmm.  I tried already to add that Key with (default) value REG_SZ set to 0, restarted IIS , the same error

Do  you mean "UrlSegmentMaxLength" Key or value= dword:00000000  under the \Parameters key?

Spasibo.

Vlad

 

 

 

I also tried that before and no help either.

 

Back to Top
 
Yaroslav
Admin Group


Joined: 15 August 2002
Posts: 6520
Posted: 18 October 2005 at 7:30am  

I mean "UrlSegmentMaxLength" key with a value dword:00000000

__________________
Yaroslav Govorunov,
Helicon Tech
Back to Top Visit Yaroslav's Homepage
 
vbrook
Newbie


Joined: 04 October 2005
Location: United States
Posts: 12
Posted: 18 October 2005 at 10:48am  

I exported registry entry to .reg file to be sure that its what you recommend.

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\HTTP\Parameters\UrlSegmentMaxLength]
@=dword:00000000

does not help so far

Vlad

 

 

Back to Top
 
Yaroslav
Admin Group


Joined: 15 August 2002
Posts: 6520
Posted: 18 October 2005 at 10:53am  

And you need to completely reboot your server.

__________________
Yaroslav Govorunov,
Helicon Tech
Back to Top Visit Yaroslav's Homepage
 
vbrook
Newbie


Joined: 04 October 2005
Location: United States
Posts: 12
Posted: 18 October 2005 at 5:10pm  

I got it.  It's not a key "UrlSegmentMaxLength", but a value with this name under Parameters key. I set it to 512 and it works now for my ugly long URL.

Registry entry looks like that:

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\HTTP\Parameters]
"DisableServerHeader"=dword:00000001
"UrlSegmentMaxLength"=dword:00000200

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\HTTP\Parameters\SslBindingInfo]

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\HTTP\Parameters\UrlAclInfo]

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\HTTP\Parameters\Synchronize]

Spasibo.

Vlad

Back to Top
 
jmathieu1
Newbie


Joined: 13 August 2009
Posts: 5
Posted: 13 August 2009 at 4:26am  

hello,

I have exactly the same problem. My url looks like :

http://www.domain.tld/uoQ76Kb2QL5hzaVOSAKWeX0W9LfDLqphmRXpsfHN8tgF5lCsfTxlOVWY8vFwzhsRzoNYKhUIOTc5TnUlT0vpdQflPyk2nh7vurXOj60cDnkG3nsrXMhFCsPjhcZAic2jKpF9F9TYRYQwJo81IMi6gY01RK3ZcNl8WGfqcvoZ702UIdetvR7kiaqo1czwSJCMjRFdG6EgMzgXrwE8DYMz4fWqoa1F1c1qwTCBk3yOcmGTbxsPSJK5QRyNea9IFLrBTjfE7ZlN2vZiI7adcDYJef.htm

I precise that there isn't any error logued in the httpderr log file.

I tried to change some values in the registry but it dosn't work.

Here are the key values :

< http-equiv="Content-" content="text/; charset=utf-8">< name="ProgId" content="Word.">< name="Generator" content="Microsoft Word 12">< name="Originator" content="Microsoft Word 12"><link rel="File-List" href="file:///C:%5CDOCUME%7E1%5Cjobard%5CLOCALS%7E1%5CTemp%5Cmsohtmlclip1%5C01%5Cclip_filelist.xml" target="_blank"><link rel="themeData" href="file:///C:%5CDOCUME%7E1%5Cjobard%5CLOCALS%7E1%5CTemp%5Cmsohtmlclip1%5C01%5Cclip_themedata.thmx" target="_blank"><link rel="colorSchemeMapping" href="file:///C:%5CDOCUME%7E1%5Cjobard%5CLOCALS%7E1%5CTemp%5Cmsohtmlclip1%5C01%5Cclip_colorschememapping.xml" target="_blank">< style> [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\HTTP\Parameters]
"MaxFieldLength"=dword:0000fffe
"MaxRequestBytes"=dword:01000000
"UrlSegmentMaxLength"=dword:00000200
"UrlSegmentMaxCount"=dword:00000000
"AllowRestrictedChars"=dword:00000001
"EnableNonUTF8"=dword:00000001
"MaxBytesPerSend"=dword:000fffff
"UriMaxUriBytes"=dword:01000000
"DisableServerHeader"=dword:00000001

Is there any way to fix the problem?

Thanks

Back to Top
 
Anton
Admin Group


Joined: 30 January 2007
Location: Ukraine
Posts: 10519
Posted: 13 August 2009 at 7:50am  

Could you please repost you question in the new topic.
And try to set the value of UrlSegmentMaxLength to 0.

__________________
Regards,
Anton
Back to Top
 

Sorry, you can NOT post a reply.
This forum has been locked by a forum administrator.

Printable version Printable version
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot delete your posts in this forum
You cannot edit your posts in this forum
You cannot create polls in this forum
You cannot vote in polls in this forum