This forum has been moved here:
Helicon Tech Community Forum

  Active TopicsActive Topics  Display List of Forum MembersMemberlist  HelpHelp   RegisterRegister  LoginLogin
Common Questions (Forum Locked Forum Locked)
 Helicon Tech : Common Questions
Subject Topic: intsallation - manual step taken? (Topic Closed Topic Closed)
Author
Message |
elnino
Newbie


Joined: 26 August 2005
Location: United States
Posts: 6
Posted: 26 August 2005 at 10:52am  

Hi. I'm installing the Lite version. Windows 2000 Server

My intallation went as follows:
I installed the msi, and things went fine. however, all my sites were stopped, and the webservice would not restart. So I rebooted, and my sites came up. I looked into the properties on the site I wish to use your dll on, and didn't see it anywhere, so I manually added the isapii filter for the site.

So my first question is. is this typicall? In your documentation, it says that no manual steps are needed, nor did it say anything about rebooting.

Second question: Now I'm trying to use the isapii filter. Currently, my site (support.mysite.com) is being redirected to: www.mysite.com/support/ via IIS settings.

I choose to use your filter so that any url parameters that are used ALSO get redirected to the site. SO. How do I get your filter to redirect the entire site and it's url parameters to another subdomain? Do I remove the IIS redirect? (didn't work) Do I do the combination of IIS and the filter? Help!
Back to Top
 
elnino
Newbie


Joined: 26 August 2005
Location: United States
Posts: 6
Posted: 26 August 2005 at 2:55pm  

ok. based on another topic I stumbled upon, I removed the isapi filter from my site, as it was already installed in the global properties in IIS.

Back to Top
 
Lexey
Moderator Group


Joined: 15 August 2002
Location: Russian Federation
Posts: 8119
Posted: 30 August 2005 at 5:04am  

>So my first question is. is this typicall?
 
No, installation should restarted IIS after filter addition. Restart failure probably means that there are some problems with your server.
 
>Second question: Now I'm trying to use the isapii filter. Currently, my site (support.mysite.com) is being redirected to: www.mysite.com/support/ via IIS settings.
You should remove this redirect. It will not allow ISAPI_Rewrite to work.
 
>I choose to use your filter so that any url parameters that are used ALSO get redirected to the site. SO. How do I get your filter to redirect the entire site and it's url parameters to another subdomain?
 
RewriteCond Host: support\.mysite\.com
RewriteRule (.*) http\://www.mysite.com/support$1 [I,R]
 


__________________
With best wishes,
Alex Ostapenko,
Helicon Tech.
Back to Top
 

Sorry, you can NOT post a reply.
This forum has been locked by a forum administrator.

Printable version Printable version
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot delete your posts in this forum
You cannot edit your posts in this forum
You cannot create polls in this forum
You cannot vote in polls in this forum