This forum has been moved here:
Helicon Tech Community Forum

ISAPI_Rewrite 3.0 (Forum Locked Forum Locked)
 Helicon Tech : ISAPI_Rewrite 3.0
Subject Topic: Need some help getting a site running
Author
Message |
dwavell
Newbie


Joined: 29 February 2012
Posts: 1
Posted: 29 February 2012 at 4:59pm

Ok, so I'm not usually a user of isapi rewrite, but I have been in the past and had no problem getting things working with it...but right now I'm completely stuck.

We've inherited a php site which has the following rewrite rules:

Options +FollowSymlinks
RewriteEngine On
RewriteRule ^([^/]*)/([^/]*)\/$ /content.php?page=$1&pagelinks=$2 [L]
RewriteRule ^pages/([^/]*)\.php$ /listpages.php?page=$1 [L]
RewriteRule ^summary/([^/]*)\.php$ /summary.php?page=$1 [L]
#RewriteRule . - [F]

ErrorDocument 404 /404.php

AddType application/x-httpd-php  xml

Firstly - am I right in thinking these rules are for isapi rewrite and not for Ape?

Secondly - are there issues with installing on server 2008, iis 7.5 or 64bit operating systems?  Just that these are the things that have changed for this server compared to the one that I used to happily use isape rewrite on.

Any ideas greatfully received as I really could do with getting this site up and running to show a client tomorrow morning!

Cheers,

Dan

Back to Top
 
Guests
Guest


Joined: 01 October 2003
Online Status: Online
Posts: -160
Posted: 01 March 2012 at 7:49am

Hello,

Firstly, these rules are for HeliconApe. At least the followi9ng lines will be of a little use in Ape:
Code:
ErrorDocument 404 /404.php
AddType application/x-httpd-php xml


Other rewrite rules are supposed to work as expected.
Secondly, no issues with installing ISAPI_Rewrite 3 on 2008, IIS7, 64-bit are known. Though we always suggest switching to Ape as it is a product
specifically designed for IIS7+.

Regards
Andrew
Back to Top
 

Sorry, you can NOT post a reply.
This forum has been locked by a forum administrator.

Printable version Printable version