This forum has been moved here:
Helicon Tech Community Forum

Helicon Ape (Forum Locked Forum Locked)
 Helicon Tech : Helicon Ape
Subject Topic: Reverse Proxy not working in IIS7.5
Author
Message |
JoelG
Newbie


Joined: 13 February 2012
Location: United States
Posts: 3
Posted: 13 February 2012 at 2:08pm

We are trying to put together a proxy for a /blog/ folder
on a .NET application to pull in the content from a
Wordpress blog running on a LAMP box. It seems that the
proxy should be working but it's not. Here is my
configuration from the httpd.conf:

Code:
<VirtualHost www.myserver.com>
ProxyPass /blog/ http://blog.myserver.com/
ProxyPassReverse /blog/ http://blog.myserver.com/
</VirutalHost>

When I turn on error logging with a log level of 9 I get
this in the error.log file.

Code:
[2/13/2012 11:11:18 AM] [LicenseManager] Site with
id=1 is working with free license
[2/13/2012 11:11:18 AM] [LicenseManager] Trial days left
43. SiteId: 1
[2/13/2012 11:11:18 AM] [proxy] (8) [/blog/] request to
http://blog.glasweld.com/
[2/13/2012 11:11:18 AM] [mod_core_context] (8) [/blog/]
ConfigFactory.LoadHtaccess:


I've also tried this with the RewriteProxy syntax and the
RewriteRule syntax using the

flag, but nothing seems
to work. Instead it just pulls up the ASP.NET page that
is there as a place holder.

Any help would be greatly appreciated!

Back to Top
 
JoelG
Newbie


Joined: 13 February 2012
Location: United States
Posts: 3
Posted: 13 February 2012 at 4:22pm

I should have mentioned some specifics of the setup:

  • Windows Server 2008 R2 x64

  • IIS 7.5

  • App Pool is .NET 4, Integrated Pipeline

  • APE Version 3.0.0.76



Thanks,
-Joel

Edited by JoelG - 13 February 2012 at 4:23pm
Back to Top
 
Anton
Admin Group


Joined: 30 January 2007
Location: Ukraine
Posts: 10519
Posted: 14 February 2012 at 2:44am

Hello, Joel

Is it just a misprint that you have http://blog.glasweld.com/ in the log and http://blog.myserver.com/ in the config?
Also can you show more lines from the error.log and also show rewrite.log.
Also, please tell if other rules (e.g. simple rewriting) work for you.

__________________
Regards,
Anton
Back to Top
 
JoelG
Newbie


Joined: 13 February 2012
Location: United States
Posts: 3
Posted: 14 February 2012 at 9:41am

Hi Anton, thanks for the reply. I found out last night
that the ASP.NET application had some code removed. We are
doing a lot with HttpHandlers and had code at one point to
specifically ignore any request with .apehander in the path
but it had apparently been munged by a code merge.

The short of it is that it's working again. :-)
Back to Top
 

Sorry, you can NOT post a reply.
This forum has been locked by a forum administrator.

Printable version Printable version