This forum has been moved here:
Helicon Tech Community Forum

ISAPI_Rewrite 3.0 (Forum Locked Forum Locked)
 Helicon Tech : ISAPI_Rewrite 3.0
Subject Topic: Different results on different servers
Author
Message |
RikComery
Groupie


Joined: 09 June 2005
Location: United Kingdom
Posts: 42
Posted: 25 January 2012 at 8:35am

Hi. I am not even sure if this is an IsapiRewrite issue, but in the absence of any other solution, I figured I have nothing to lose asking.

We have two servers, one inside our firewall for development and one outside for public consumption. I have been assured they are configured
identically. I have IsapiRewrite running on both, each with identical configuration.

Within that configuration, I have the following rule which I use to redirect for mobile devices.

Code:
RewriteCond %{HTTP_HOST} ^(?:www\.)?domain\.com$ [NC]
RewriteCond %{HTTP_USER_AGENT} (?:AU-MIC|AUDIOVOX|Alcatel|BlackBerry|Blazer|Danger|hiptop|DoCoMo/|Ericsson|Googlebot-
Mobile|MSN\sMobile\sProxy|Handheld|iPhone|iPod|Klondike|LG-|LGE-|\sLGE\s|MOT-|NetFront|Nokia|Opera\sMini|PalmOS|PalmSource|Panasonic-|SAGEM-
|SAMSUNG|SGH-|SHARP-|SIE-|Samsung-|Smartphone|Sony|Symbian\sOS|Windows\sCE|nokia|portalmmm|Profile/MIDP-|UP\.Link|UP\.Browser)
RewriteCond %{QUERY_STRING} ^IdcService=SS_GET_PAGE&siteId=((?!(?:ucm|intranet))[^&]+)&siteRelativeUrl=([^&]+)&ssUrlType=2$ [NC]
RewriteRule .* http\://m.domain.com/%1%2? [NC,R=301,L,NE]


On our internal server, when viewing our site via a mobile, the address changes to m.domain.com and we get our mobile site. However, on our production
server, the address does not change - it remains www.domain.com - but oddly, we still get our mobile site.

Although we are still getting the desired effect, I need the address to change in the address bar for other purposes. Is there anything that can be
done in
IsapiRewrite to fix that?

Many thanks.

Edited by RikComery - 25 January 2012 at 8:37am
Back to Top Visit RikComery's Homepage
 
Guests
Guest


Joined: 01 October 2003
Online Status: Online
Posts: -160
Posted: 26 January 2012 at 4:54am

Hello,

Would you please, provide, rewrite.log for the testing request(for incorrect behavior)?
Logging issues described in FAQ

Regards
Andrew
Back to Top
 

Sorry, you can NOT post a reply.
This forum has been locked by a forum administrator.

Printable version Printable version