This forum has been moved here:
Helicon Tech Community Forum

Helicon Ape (Forum Locked Forum Locked)
 Helicon Tech : Helicon Ape
Subject Topic: After formatting,ape doesn’t work anymore
Author
Message |
Mr. Eagle
Newbie


Joined: 19 December 2011
Location: Germany
Posts: 6
Posted: 19 December 2011 at 5:21pm

Hello dear Community!

before formatting my server everything works fine with Ape.
But after formatting, my mod_rewrite script don't work anymore:

RewriteEngine On
RewriteCond %{HTTP_HOST} ^domain\.de$ [NC]
RewriteRule ^(.*)$ http://www.domain.de/$1 [R=301,L]

I don't know where the problem is. Maybe misconfiguration?
I have Windows Server 2008 R2 Datacenter OS and IIS 7.5.

Thank you for your help!
Mr. Eagle
Back to Top Visit Mr. Eagle's Homepage
 
Mr. Eagle
Newbie


Joined: 19 December 2011
Location: Germany
Posts: 6
Posted: 20 December 2011 at 4:01am

The error.log tells me:

[ConfigWatcher] Can't watch by C:\Program Files (x86)\Helicon\Ape\ directory Der Verzeichnisname C:\Program Files (x86)\Helicon\Ape\ ist ungültig.;


regards
Mr. Eagle
Back to Top Visit Mr. Eagle's Homepage
 
Anton
Admin Group


Joined: 30 January 2007
Location: Ukraine
Posts: 10519
Posted: 20 December 2011 at 4:38am

It look like a permissions issue.
Please make sure the user that is running the application pool for the site has proper permissions including List Folder Content.

__________________
Regards,
Anton
Back to Top
 
Mr. Eagle
Newbie


Joined: 19 December 2011
Location: Germany
Posts: 6
Posted: 20 December 2011 at 5:04am

Hi,

Thank you for your answer.
But where can i change the permissions?

Regards,
Mr. Eagle
Back to Top Visit Mr. Eagle's Homepage
 
Anton
Admin Group


Joined: 30 January 2007
Location: Ukraine
Posts: 10519
Posted: 20 December 2011 at 6:01am

Permissions can be changed in Windows Explorer by right-clicking on the folder, going to Properties -> Security.

__________________
Regards,
Anton
Back to Top
 
Mr. Eagle
Newbie


Joined: 19 December 2011
Location: Germany
Posts: 6
Posted: 20 December 2011 at 6:19am

The error disappeared!
([ConfigWatcher] Can't watch by C:\Program Files (x86)\Helicon\Ape\ directory Der Verzeichnisname C:\Program Files (x86)\Helicon\Ape\ ist ungültig.;)

But the script is still not working..
I believe that IIS is guilty.
Any ideas?

regards
Mr. Eagle
Back to Top Visit Mr. Eagle's Homepage
 
Mr. Eagle
Newbie


Joined: 19 December 2011
Location: Germany
Posts: 6
Posted: 20 December 2011 at 8:37am

Hi, i have some news:
I have enabled:

Loglevel debug
ErrorLog error.log
and
RewriteLog rewrite.log
RewriteLogLevel 9

Now the errorlog throws:

[20.12.2011 14:44:52] [mod_core_context] (8) [/news/] ConfigFactory.LoadHtaccess: c:\inetpub\vhosts\domain\httpdocs\.htaccess

[20.12.2011 14:44:52] [mod_core_context] (8) [/news/] ConfigFactory.LoadHtaccess:
[20.12.2011 14:50:55] [mod_core_context] (8) [/forum/] ConfigFactory.LoadHtaccess:
[20.12.2011 15:04:44] [mod_core_context] (8) [/glossar/] ConfigFactory.LoadHtaccess:

the rewrite log file remains empty.

EDIT:
ASAPI_Rewrite 3 works for me.

Best Regards
Mr. Eagle


Edited by Mr. Eagle - 20 December 2011 at 9:32am
Back to Top Visit Mr. Eagle's Homepage
 
Anton
Admin Group


Joined: 30 January 2007
Location: Ukraine
Posts: 10519
Posted: 21 December 2011 at 7:32am

Hello,

Don't you have ISAPI_Rewrite 3 and Ape installed on the same machine?
Please make sure you don't have ISAPI filters for both tools registered.


__________________
Regards,
Anton
Back to Top
 
Mr. Eagle
Newbie


Joined: 19 December 2011
Location: Germany
Posts: 6
Posted: 21 December 2011 at 8:35am

Hello,

ape --> deinstall
Rewrite 3 --> install

now my script works perfectly.

Regards,
Mr. Eagle
Back to Top Visit Mr. Eagle's Homepage
 

Sorry, you can NOT post a reply.
This forum has been locked by a forum administrator.

Printable version Printable version