This forum has been moved here:
Helicon Tech Community Forum

Helicon Ape (Forum Locked Forum Locked)
 Helicon Tech : Helicon Ape
Subject Topic: APE and Websitepanel
Author
Message |
gbdg
Groupie


Joined: 11 April 2008
Posts: 54
Posted: 03 October 2011 at 10:13pm

I have licensed and installed APE on a Win 2008 server
running the current version of Websitepanel.

After securing one folder in each of two sites, I get a
500 error in one, and a 401 error on the other.

To begin debugging, I have these lines near the top of
httpd.conf:

RewriteLogLevel 9
Loglevel debug
ErrorLog error.log

I get this error:

[10/3/2011 7:24:02 PM] [ConfigLoader] C:\Program Files
(x86)\Helicon\Ape\httpd.conf(16): Invalid command
'RewriteLogLevel 9' on line 16, perhaps misspelled or
defined by a module not included in the server
configuration

Notes:
- I find no instance of .htaccess in either site. (I was
looking for that in order to check permissions.) Where
is this file supposed to be? In the root?

- In the site that gets the 500 error, I see these files:
.htfolders
.htgroup
.htpasswd

- in the site that gets the 401 error, I see no such
files are are listed above

- in both sites, when I try to delete the references to
the user and/or folder that is to be secured, WSP throws
a generic error message. I can disable APE but I cannot
remove either an authorized user or the secured folders.

What else can I tell you that would help resolve this?
Back to Top
 
Anton
Admin Group


Joined: 30 January 2007
Location: Ukraine
Posts: 10519
Posted: 04 October 2011 at 4:17am

I've answered you on email.

__________________
Regards,
Anton
Back to Top
 
limone919
Newbie


Joined: 04 January 2012
Location: Japan
Posts: 3
Posted: 04 January 2012 at 1:40am

Anton wrote:
I've answered you on email.


Hi Anton,

> - in both sites, when I try to delete the references to
> the user and/or folder that is to be secured, WSP throws
> a generic error message. I can disable APE but I cannot
> remove either an authorized user or the secured folders.

I have a problem with the same problem. Please give me a solution.

WebsitePanel Error

Sorry, an error occurred while processing your request.


Even if I try how many times, it cannot delete by the above error. Please help me.



Back to Top
 
Anton
Admin Group


Joined: 30 January 2007
Location: Ukraine
Posts: 10519
Posted: 04 January 2012 at 5:23am

@limone919:

- Websitepanel module Secure Folders is incompatible with Ape, so you should switch it off
- you should create .htaccess file in the root of your site(s)
- as for the log directives, you've probably put them above the Include directives which enable Ape modules that's why they are not recognized.
- Also please show what directives you use to make authentication working

__________________
Regards,
Anton
Back to Top
 
limone919
Newbie


Joined: 04 January 2012
Location: Japan
Posts: 3
Posted: 04 January 2012 at 8:45pm

Hi Anton,

Thank you for your reply.

> - Websitepanel module Secure Folders is incompatible with Ape, so you should switch it off

Yes, I have switch it off.

> - you should create .htaccess file in the root of your site(s)

Does a user need to create .htaccess of a site route?


The error is reproduced by the following procedure.







The contents of this file only.

 # Helicon Ape
 Deny From All

The result is the same what is written there. Why is this?
Back to Top
 
limone919
Newbie


Joined: 04 January 2012
Location: Japan
Posts: 3
Posted: 04 January 2012 at 10:19pm

Hi Anton,

Can I get E-Mail Support for Ape? I purchased the licenses of Ape recently.
Back to Top
 
Anton
Admin Group


Joined: 30 January 2007
Location: Ukraine
Posts: 10519
Posted: 05 January 2012 at 5:12am

@limone919:

please write an email to [email protected] with all the details.
And please show what you get in rewrite.log and error.log

__________________
Regards,
Anton
Back to Top
 

Sorry, you can NOT post a reply.
This forum has been locked by a forum administrator.

Printable version Printable version