This forum has been moved here:
Helicon Tech Community Forum

ISAPI_Rewrite 3.0 (Forum Locked Forum Locked)
 Helicon Tech : ISAPI_Rewrite 3.0
Subject Topic: ISAPI Rewrite 3.0 Not Working With Joomla
Author
Message |
mohknight
Newbie


Joined: 05 September 2011
Posts: 8
Posted: 05 September 2011 at 6:56pm

I have a Joomla 1.5.22 site on a Windows 2003 server running IIS 6. I installed ISAPI Rewrite 3.0 (full version - will pay once everything is running well) today on the server and followed all the instructions for getting SEF URLs to work both here and here.

My Joomla site is located at the root URL i.e. http://www.mysite.org.my/ and is resident in the folder c:/inetpub/vhosts/mysite.org.my/httpdocs. I'm using Plesk 10 for remote server management.

The problem is that after I set all three SEO settings to "Yes" in the Global Configuration for my Joomla site, SEF URLs work but I would no longer be able to access the site by the URL alone i.e. http://www.mysite.org.my/ shows a 404 error. I have to type in http://www.mysite.org.my/index.php or http://www.mysite.org.my/home.html to get to the home page.

This is the content of my .htaccess file - where am I going wrong?

# Helicon ISAPI_Rewrite configuration file
# Version 3.1.0.86

##
# @version $Id: htaccess.txt 14401 2010-01-26 14:10:00Z louis $
# @package Joomla
# @copyright Copyright (C) 2005 - 2010 Open Source Matters. All rights reserved.
# @license http://www.gnu.org/copyleft/gpl.html GNU/GPL
# Joomla! is Free Software
##


#####################################################
#  READ THIS COMPLETELY IF YOU CHOOSE TO USE THIS FILE
#
# The line just below this section: 'Options +FollowSymLinks' may cause problems
# with some server configurations.  It is required for use of mod_rewrite, but may already
# be set by your server administrator in a way that dissallows changing it in
# your .htaccess file.  If using it causes your server to error out, comment it out (add # to
# beginning of line), reload your site in your browser and test your sef url's.  If they work,
# it has been set by your server administrator and you do not need it set here.
#
#####################################################

##  Can be commented out if causes errors, see notes above.
#Options +FollowSymLinks

#
#  mod_rewrite in use

RewriteEngine On

########## Begin - Rewrite rules to block out some common exploits
## If you experience problems on your site block out the operations listed below
## This attempts to block the most common type of exploit `attempts` to Joomla!
#
## Deny access to extension xml files (uncomment out to activate)
#<Files ~ "\.xml$">
#Order allow,deny
#Deny from all
#Satisfy all
#</Files>
## End of deny access to extension xml files
RewriteCond %{QUERY_STRING} mosConfig_[a-zA-Z_]{1,21}(=|\%3D) [OR]
# Block out any script trying to base64_encode crap to send via URL
RewriteCond %{QUERY_STRING} base64_encode.*\(.*\) [OR]
# Block out any script that includes a <script> tag in URL
RewriteCond %{QUERY_STRING} (\<|%3C).*script.*(\>|%3E) [NC,OR]
# Block out any script trying to set a PHP GLOBALS variable via URL
RewriteCond %{QUERY_STRING} GLOBALS(=|\[|\%[0-9A-Z]{0,2}) [OR]
# Block out any script trying to modify a _REQUEST variable via URL
RewriteCond %{QUERY_STRING} _REQUEST(=|\[|\%[0-9A-Z]{0,2})
# Send all blocked request to homepage with 403 Forbidden error!
RewriteRule ^(.*)$ index.php [F,L]
#
########## End - Rewrite rules to block out some common exploits

#  Uncomment following line if your webserver's URL
#  is not directly related to physical file paths.
#  Update Your Joomla! Directory (just / for root)

#RewriteBase /


########## Begin - Joomla! core SEF Section
#
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteCond %{REQUEST_URI} !^/index.php
RewriteCond %{REQUEST_URI} (/|\.php|\.html|\.htm|\.feed|\.pdf|\.raw|/[^.]*)$ [NC]
RewriteRule (.*) index.php
# RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization},L]
#
########## End - Joomla! core SEF Section


This is the content of my configuration.php

<?php
class JConfig {
    var $offline = '0';
    var $editor = 'jce';
    var $list_limit = '20';
    var $helpurl = 'http://help.joomla.org';
    var $debug = '0';
    var $debug_lang = '0';
    var $sef = '0';
    var $sef_rewrite = '0';
    var $sef_suffix = '0';
    var $feed_limit = '10';
    var $feed_email = 'author';
    var $secret = 'Gshhsta4562vs';
    var $gzip = '0';
    var $error_reporting = '-1';
    var $xmlrpc_server = '1';
    var $log_path = 'c:/inetpub/vhosts/mysite.org.my/httpdocs/logs';
    var $tmp_path = 'c:/inetpub/vhosts/mysite.org.my/httpdocs/tmp';
    var $live_site = 'http://www.mysite.org.my';
    var $force_ssl = '0';
    var $offset = '0';
    var $caching = '0';
    var $cachetime = '15';
    var $cache_handler = 'file';
    var $memcache_settings = array();
    var $ftp_enable = '0';
    var $ftp_host = '';
    var $ftp_port = '0';
    var $ftp_user = '';
    var $ftp_pass = '';
    var $ftp_root = '';
    var $dbtype = 'mysql';
    var $host = 'localhost';
    var $user = 'admin';
    var $db = 'mysitedb';
    var $dbprefix = 'my_';
    var $mailer = 'mail';
    var $mailfrom = '';
    var $fromname = '';
    var $sendmail = '';
    var $smtpauth = '0';
    var $smtpsecure = 'none';
    var $smtpport = '25';
    var $smtpuser = '';
    var $smtppass = '';
    var $smtphost = 'localhost';
    var $MetaAuthor = '1';
    var $MetaTitle = '1';
    var $lifetime = '9999';
    var $session_handler = 'database';
    var $password = 'titanium#890';
    var $sitename = 'My Site';
    var $MetaDesc = 'Joomla! - the dynamic portal engine and content management system';
    var $MetaKeys = 'joomla, Joomla';
    var $offline_message = 'This site is down for maintenance. Please check back again soon.';
}
?>

Can anyone help me get this sorted out?
Thanks!


Edited by mohknight - 05 September 2011 at 7:17pm
Back to Top
 
Guests
Guest


Joined: 01 October 2003
Online Status: Online
Posts: -160
Posted: 06 September 2011 at 7:19am

If everything works fine, why don't we simply use additional rule to rewrite root of the site to index.php?
Simply insert the following rule on the top in addition to the existing.

RewriteRule ^/?$ /index.php [NC,L]
Back to Top
 
mohknight
Newbie


Joined: 05 September 2011
Posts: 8
Posted: 06 September 2011 at 12:46pm

Thanks so much for the reply - I was about to give up hope!  I added the suggested rule to the .htaccess file but the same problem still comes up. I have to type in http://www.mysite.org.my/index.php or http://www.mysite.org.my/home.html to get to the home page. Once there though, SEF URLs work.

However, I noticed something else;
I have some flash animations in the banner of my site. With SEF, the pages from the first level menu items show the animations with no problem, the pages from second level menu items don't, i.e.;
http://www.mysite.org.my/index.php - shows flash
http://www.mysite.org.my/home.html - shows flash
http://www.mysite.org.my/aboutus.html - shows flash.
http://www.mysite.org.my/aboutus/michael.html - no flash.

I'm beginning to think this may be a permissions issue or maybe an error with the installation of ISAPI Rewrite 3 i.e. httpd.conf in C:\Program Files\Helicon\ISAPI_Rewrite3 is empty and so is rewrite.log - both are at 0K size. Furthermore, this is basically the content of error.log (over and over again);

[9/6/2011 16:43:25] ISAPI Filter loaded. Version 3.1.0.86. Windows 5.2 (Build 3790 ServicePack:2) ProductType SERVER. CPU type INTEL  NumberOfProcessors 6.
[9/6/2011 16:49:49] ISAPI Filter loaded. Version 3.1.0.86. Windows 5.2 (Build 3790 ServicePack:2) ProductType SERVER. CPU type INTEL  NumberOfProcessors 6.
[9/6/2011 17:00:55] ISAPI Filter loaded. Version 3.1.0.86. Windows 5.2 (Build 3790 ServicePack:2) ProductType SERVER. CPU type INTEL  NumberOfProcessors 6.
[9/6/2011 17:12:01] ISAPI Filter loaded. Version 3.1.0.86. Windows 5.2 (Build 3790 ServicePack:2) ProductType SERVER. CPU type INTEL  NumberOfProcessors 6.
[9/6/2011 17:28:24] ISAPI Filter loaded. Version 3.1.0.86. Windows 5.2 (Build 3790 ServicePack:2) ProductType SERVER. CPU type INTEL  NumberOfProcessors 6.

Thank you very much once again. Please help!
Back to Top
 
mohknight
Newbie


Joined: 05 September 2011
Posts: 8
Posted: 07 September 2011 at 12:12pm

I think I'll have ISAPI Rewrite uninstalled and try it again.
If it don't work, I might have to give up and try something else.

Thanks

Edited by mohknight - 07 September 2011 at 12:43pm
Back to Top
 
Guests
Guest


Joined: 01 October 2003
Online Status: Online
Posts: -160
Posted: 08 September 2011 at 4:19am

a) you need to put the following into httpd.conf:
Code:
#enabling rewrite.log
RewriteLogLevel 9
#enabling error.log
LogLevel debug

This will enable logging. Both error.log(more detailed) and rewrite.log

b) your flash links in the code of the page must be root-relative, then everything will work. now there're probably simply relative and that is the reason.

Regards
Andrew
Back to Top
 
mohknight
Newbie


Joined: 05 September 2011
Posts: 8
Posted: 13 September 2011 at 9:10am

Hello Andrew.

Is there any way I can get you to look at what's going on with my server and why it is the only Window 2003 server in the world that cannot work with your application?

I'm willing to pay if necessary - within reason   of course.

Thanks.
Back to Top
 
Guests
Guest


Joined: 01 October 2003
Online Status: Online
Posts: -160
Posted: 13 September 2011 at 9:25am

You can consider purchasing Premium Support Plan and having one of the Helicon support specialist to figure out
everything for you. He will still need the logs, but he may use RDP for online meeting and do all the job for you.

Regards
Andrew
Back to Top
 
mohknight
Newbie


Joined: 05 September 2011
Posts: 8
Posted: 13 September 2011 at 11:33am

Hi Andrew,

Thanks to your help, I was able to get the error.log and rewrite.log working. This is the information in the error log (repeated over and over again);

[9/13/2011 14:02:38] C:\Program Files\Helicon\ISAPI_Rewrite3\httpd.conf - Loaded successfully
[9/13/2011 14:02:38] Begin watch directory changes failed (c:\program files\helicon\isapi_rewrite3\): Insufficient permissions. (Access is denied.)

I thought it was obvious where the problem is coming from but I've checked the permissions as specified here and everything seems okay. Is there some other folder or application that needs to be given permissions over the installation folder?

NOTE: I have Plesk installed.
Back to Top
 
Guests
Guest


Joined: 01 October 2003
Online Status: Online
Posts: -160
Posted: 14 September 2011 at 4:57am

The following advice will save you $150 for Premium Support:

Go to Helicon installation folder --> Properties --> Security tab and edit the permissions in the following way:
- delete 2 users, specified by PLESK.
Quote:
psaadm    ---   Used by Parallels Plesk Panel to log on to the system and
                         access files and folders.
psacln   ----    All users created by Parallels Plesk Panel are members of this
                           group


They have some restrictive functions that conflict with permissions for ISAPI_Rewrite to Read/List Folder Content, etc
Double check everything, to make sure that isapirewrite.dll and httpd.conf are free from these restrictions.

The same must be done to .htaccess of the site you're aimed to work with.

Regards
Andrew
Back to Top
 
mohknight
Newbie


Joined: 05 September 2011
Posts: 8
Posted: 15 September 2011 at 10:22am

Hello Andrew,

Thanks for your help again.

I eliminated psaadm and psacln as users (all were set to Deny) from the C:\Program Files\Helicon folder and went in to ensure that no file inside had the pssadm and psacln. I did the same for .htaccess in the site root i.e. C:\inetpub\vhosts\mysite.org.my\httpdocs folder.

Made absolutely no difference.

If I activate SEF URLs, www.mysite.org.my still shows up as a 404 error unless I write it out in full i.e. www.mysite.org.my/home.html or www.mysite.org.my/index.php in the address bar.

Should I uninstall ISAPI Rewriter and re-install it elsewhere? Would that work? I'm guessing the problem could be that psaadm and psacln are users of C:\Program Files\

Back to Top
 
Guests
Guest


Joined: 01 October 2003
Online Status: Online
Posts: -160
Posted: 19 September 2011 at 4:13am

You did the right thing. Everything goes as it should.
Now we need to test the ISAPI_Rewrite. Please, see FAQ to find out about the testing rule. If
testing rules doesn't work, please, turn on logging(also described in FAQ) and see error.log. It will have entries about insufficient permissions.

Regards
Andrew
Back to Top
 
mohknight
Newbie


Joined: 05 September 2011
Posts: 8
Posted: 19 September 2011 at 7:35am

Hello Andrew,

No. Absolutely nothing has worked. Everyone has all the permissions but ISAPI Rewrite insists on serving File Not Found errors to all requests.

Annoying to say the least.

Oh well.
Back to Top
 
Guests
Guest


Joined: 01 October 2003
Online Status: Online
Posts: -160
Posted: 20 September 2011 at 8:05pm

There must be something left. Did you use it in httpd.conf or .htaccess?

Regards
Andrew
Back to Top
 
mohknight
Newbie


Joined: 05 September 2011
Posts: 8
Posted: 20 September 2011 at 8:26pm

Rules are all in .htaccess.
error.log and rewrite.log enabled in httpd.conf

I uninstalled ISAPI Rewrite 3 and reinstalled in a folder I named C:\ISAPI_Rewrite and first deleted psaadm and psacln from the folder and then from .htaccess in the site directory. Didn't work.

So I added psaadm and psacln back and set everything to "Allow." Still didn't work.

PS: Tried the testing rule and got the 403 error.

Back to Top
 
Guests
Guest


Joined: 01 October 2003
Online Status: Online
Posts: -160
Posted: 20 September 2011 at 8:37pm

No you do not need to add them back.
Are the logs being written?
Back to Top
 

Sorry, you can NOT post a reply.
This forum has been locked by a forum administrator.

Printable version Printable version