This forum has been moved here:
Helicon Tech Community Forum

Helicon Ape (Forum Locked Forum Locked)
 Helicon Tech : Helicon Ape
Subject Topic: 404 failure since ape
Author
Message |
matthias
Newbie


Joined: 02 September 2011
Posts: 3
Posted: 02 September 2011 at 4:36am

Hi all,

we moved with our website to the Windows Webserver 2008 and changed from isapi rewrite to ape (3.0.065)
at the beginning, everything was fine, but from time to time we find out, that we sometimes have a 404 failure "404- File or directory not found". we only had the possibility to re-start the side or re-start the IIE service and then the webside worked again for a while.
Due to the fact that this happens very often, it is very urgent to solve the problem!

thanks for any help.

Regards
Matthias

Back to Top
 
Vyacheslav
Admin Group


Joined: 02 July 2008
Location: Ukraine
Posts: 1542
Posted: 02 September 2011 at 4:59am

Hello.
Please make sure all NTFS permissions are correct according to this: http://www.helicontech.com/ape/doc/security.htm
Thank you.

__________________
Slavik Shynkarenko,
Helicon Tech.
Back to Top Visit Vyacheslav's Homepage
 
matthias
Newbie


Joined: 02 September 2011
Posts: 3
Posted: 02 September 2011 at 6:44am

Hi Vyacheslav,

thanks for your reply.

i have a simple question regarding the following part in your Link (because Im a newbie):

"To ensure flawless Helicon Ape operation, <MACHINE>\IIS_IUSRS usergroup must be granted Read permission for .htaccess configuration file(s)."

When i go to the IIS and click the Website and go to IIS Manager it appears the following Alert: "The server is configured to accept connections only from accounts wiht Windows credentials"
After this, i clicked the Website in the Security-tab to check the Windows credentials. i see no "IIS-User", but only Users. They have Read-Permissions. Is it the right User, or i do i have to add an another User because i can not ad an "IIS-User".

Thanks in Advance!

 



Edited by matthias - 02 September 2011 at 7:12am
Back to Top
 
Guests
Guest


Joined: 01 October 2003
Online Status: Online
Posts: -160
Posted: 02 September 2011 at 7:12am

Hello,

You do not need those options. You simple go to your explorer, hit 'properties' of the helicon installation folder and go to "security" tab. There you
provide the permissions. The same for the folder, which contains the web-site and .htaccess file (make sure "List Folder Content" is granted).

Also, you may try to find any error messages in application log or in error.log of Ape.

Regards
Andrew
Back to Top
 
matthias
Newbie


Joined: 02 September 2011
Posts: 3
Posted: 02 September 2011 at 7:24am

Thanks for reply.

but "Users" have read permissions. I try to find any error in the application log.

Regards
Matthias



Edited by matthias - 02 September 2011 at 7:25am
Back to Top
 
Guests
Guest


Joined: 01 October 2003
Online Status: Online
Posts: -160
Posted: 05 September 2011 at 6:39am

Please, provide error.log and rewrite.log for the testing request.
You may enable logging by uncommenting 2 lines in httpd.conf:

Code:
Loglevel debug
ErrorLog error.log


Regards
Andrew
Back to Top
 

Sorry, you can NOT post a reply.
This forum has been locked by a forum administrator.

Printable version Printable version