This forum has been moved here:
Helicon Tech Community Forum

  Active TopicsActive Topics  Display List of Forum MembersMemberlist  HelpHelp   RegisterRegister  LoginLogin
ISAPI_Rewrite 2.x (Forum Locked Forum Locked)
 Helicon Tech : ISAPI_Rewrite 2.x
Subject Topic: ISAPI_rewrite 2.x and Joomla 1.5
Author
Message |
tina
Newbie


Joined: 29 August 2011
Location: South Africa
Posts: 7
Posted: 29 August 2011 at 7:29am

Hi, I saw this article:

http://www.helicontech.com/cms_articles/joomla.htm

and was wondering whether there is a version of this article for ISAPI 2?

Having endless trouble and absolutely no success with getting ISAPI working
with Joomla 1.5

Thank,
Tina
Back to Top
 
Anton
Admin Group


Joined: 30 January 2007
Location: Ukraine
Posts: 10519
Posted: 29 August 2011 at 7:42am

This article should also be true for v2. Doesn't it work for you the way it's suggested there?

__________________
Regards,
Anton
Back to Top
 
tina
Newbie


Joined: 29 August 2011
Location: South Africa
Posts: 7
Posted: 29 August 2011 at 8:39am

Wow, Thanx for the quick reponse Anton.

The site is running on a Windows server. (And I'm stuck on Windows.)

I tried all the settings exactly like the article, but it didn't work.

I currently have all the SEO setting in the Joomla checked. I've inserted
this code in index.php (after opening <php):

if (isset($_SERVER['HTTP_X_REWRITE_URL']))
{
    $_SERVER['REQUEST_URI'] = $_SERVER['HTTP_X_REWRITE_URL'];
}

and my httpd.ini file in the rootfolder of my site:

[ISAPI_Rewrite]

RewriteRule
/(?:misc|administrator|cache|components|editor|tagcal|help|images|inclu
des|language|mambots|media|modules|templates|test|blog)/(.*) $0 [I,L]
RewriteRule (.*/sitemap.*) $1 [I,L]
RewriteRule (.*/googlee098782753e988e3.*) $1 [I,L]
RewriteRule (.*/robots.*) $1 [I,L]
RewriteCond %{URL} ^(/component/option,com) [NC,OR]
RewriteCond %{URL} (/|\.htm|\.php|\.html|/[^.]*)$ [NC]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule /(.*) /index.php [L,U]

Homepage loads fine, but all other pages result in a 404 error.

Any advice will be much appreciated.

Thank you,
Tina
Back to Top
 
Anton
Admin Group


Joined: 30 January 2007
Location: Ukraine
Posts: 10519
Posted: 29 August 2011 at 9:27am

The problem can be that you use

RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d

directives which are not supported in v2, though work great in v3 making it a neater solution.

Please try it like this:

[ISAPI_Rewrite]

RewriteRule
/(?:misc|administrator|cache|components|editor|tagcal|help|images|includes|language|mambots|media|modules|templates|test|blog)/(.*) $0 [I,L]
RewriteRule (.*/sitemap.*) $1 [I,L]
RewriteRule (.*/googlee098782753e988e3.*) $1 [I,L]
RewriteRule (.*/robots.*) $1 [I,L]
RewriteCond URL (?!.*/component/option,com.*).*
RewriteRule /[^.]+ /index.php [L,U]


__________________
Regards,
Anton
Back to Top
 
tina
Newbie


Joined: 29 August 2011
Location: South Africa
Posts: 7
Posted: 29 August 2011 at 9:33am

Thx Anton, but no luck. Still not working.

Rgds,
Tina
Back to Top
 
Anton
Admin Group


Joined: 30 January 2007
Location: Ukraine
Posts: 10519
Posted: 29 August 2011 at 9:52am

Could you try putting this testing rule at the top of your config

RewriteRule /test http\://www.google.com [I,RP]

Then request yoursite.com/test and report results.

__________________
Regards,
Anton
Back to Top
 
tina
Newbie


Joined: 29 August 2011
Location: South Africa
Posts: 7
Posted: 29 August 2011 at 10:05am

(Just to add a little more detail; on previous attempt the urls look 100%,
but they throw a "Page not found"-error)

I added the rule at the top of the httpd.ini file (Is this correct?), but just
got another "Page not found".

Which is weird because from what I can tell it should be redirecting to
Google.

I'm building the site in a subdirectory www.site.com/test, if that gives you
some useful info.

Thank you,
Tina
Back to Top
 
Anton
Admin Group


Joined: 30 January 2007
Location: Ukraine
Posts: 10519
Posted: 30 August 2011 at 2:29am

Could I have a remote connection to your machine in order to try figure it out quicker?
If yes, please send access credentials to [email protected] with reference to this forum topic.

__________________
Regards,
Anton
Back to Top
 
tina
Newbie


Joined: 29 August 2011
Location: South Africa
Posts: 7
Posted: 30 August 2011 at 4:41am

Unfortunately the company who's site I'm working won't allow this. There's
just to much info on there.

Regards,
Tina
Back to Top
 
Anton
Admin Group


Joined: 30 January 2007
Location: Ukraine
Posts: 10519
Posted: 30 August 2011 at 7:22am

Ok, will try to do without.

Please check that you have ISAPI_Rewrite filter registered in IIS -> Web Sites -> Properties -> ISAPI Filters.
And make sure it's not registered in IIS -> Web Site -> Properties -> ISAPI Filters

Also please specify what IIS version you are on.

__________________
Regards,
Anton
Back to Top
 
tina
Newbie


Joined: 29 August 2011
Location: South Africa
Posts: 7
Posted: 02 September 2011 at 2:54pm

Hi Anton,

Sorry for the long delay in my reply, had to wait for my hosting company to
get back to me among other things.

They have confirmed that ISAPI is in the correct folder and that it is ISAPI
v2.8 FULL VERSION.

Kind Regards,
Tina
Back to Top
 
Anton
Admin Group


Joined: 30 January 2007
Location: Ukraine
Posts: 10519
Posted: 05 September 2011 at 2:43am

Are you on the shared hosting? That makes it more difficult to debug the situation.
I'd like to ask you the following: install ISAPI_Rewrite and Joomla locally on your machine and try to make them working together.
Then report the results.
If it still refuses to work, I believe it would be easier to have remote connection to your local PC to work it out.

__________________
Regards,
Anton
Back to Top
 
tina
Newbie


Joined: 29 August 2011
Location: South Africa
Posts: 7
Posted: 05 September 2011 at 3:13am

Ok, Thank you, going to give it a bash.
Back to Top
 

Sorry, you can NOT post a reply.
This forum has been locked by a forum administrator.

Printable version Printable version
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot delete your posts in this forum
You cannot edit your posts in this forum
You cannot create polls in this forum
You cannot vote in polls in this forum