This forum has been moved here:
Helicon Tech Community Forum

ISAPI_Rewrite 3.0 (Forum Locked Forum Locked)
 Helicon Tech : ISAPI_Rewrite 3.0
Subject Topic: Hebrew encoding broblem
Author
Message |
dushy_d
Newbie


Joined: 06 June 2010
Posts: 8
Posted: 23 August 2011 at 10:34am

I have Helicon ISAPI_Rewrite Version 3.1.0.48
on 2 servers.
i call this URL:http://www.shteeble.com/פיתוח_תוכנה.html
with Hebrew characters.
on one server it works properly
on the second one it doesn't work
what is the problem?

this is my .htaccess code:
RewriteEngine On
# if:
# there is no file with that name
RewriteCond %{REQUEST_FILENAME} !-f
# there is no directory with that name
RewriteCond %{REQUEST_FILENAME} !-d
Back to Top
 
dushy_d
Newbie


Joined: 06 June 2010
Posts: 8
Posted: 24 August 2011 at 11:41am

the code is:

RewriteEngine On

# if:
# there is no file with that name
RewriteCond %{REQUEST_FILENAME} !-f
# there is no directory with that name
RewriteCond %{REQUEST_FILENAME} !-d

# then:
RewriteRule (.*) /index.asp?rewrite_url=$1 [QSA,L]



please help !!!
Back to Top
 
Guests
Guest


Joined: 01 October 2003
Online Status: Online
Posts: -160
Posted: 25 August 2011 at 3:32am

Hello,

Please, stop duplicating the issue across inbox/forum/helpdesk. They are all server with the same schedule. Due to a timezone shift there might be a certain delay in answering.

Regarding your issue: please, update to the latest build. It's free. You can find suitable installation file here. Build 86 has a lot of issues fixed, including the encoding issues.

Regards
Andrew
Back to Top
 
dushy_d
Newbie


Joined: 06 June 2010
Posts: 8
Posted: 25 August 2011 at 3:44am

Hi Andrew,
I installed the latest version and it still not working.
I purchased this product it is not a free one.

what can be the problem?
Back to Top
 
Guests
Guest


Joined: 01 October 2003
Online Status: Online
Posts: -160
Posted: 25 August 2011 at 5:13am

It can be your OS system language settings. It must be hebrew localization.
It can be you httpd.conf settings.
Try using NE,NS flags, described in documentation
You can also provide us with the rewrite.log for the testing request.

Regards
Andrew
Back to Top
 
dushy_d
Newbie


Joined: 06 June 2010
Posts: 8
Posted: 25 August 2011 at 5:45am

Hi Andrew,The language settings is Hebrew localizationyou can see the httpd.conf settings and the log file here:

the rewrite.log is empty i don't know y.now i see it is not working for Spanish and French characters alsostill not working for Hebrewwe are moving from a server to a new
virtual serverand we can't open our sites so it is an emergencywhat do you think?

Edited by AndrushkaUS - 25 August 2011 at 8:27am
Back to Top
 
Guests
Guest


Joined: 01 October 2003
Online Status: Online
Posts: -160
Posted: 25 August 2011 at 8:28am

Is it a system localization or user localization?
Back to Top
 
dushy_d
Newbie


Joined: 06 June 2010
Posts: 8
Posted: 25 August 2011 at 8:40am

Hi Andrew,

we managed to fix the problem
we added: NU for the RewriteRule

so the code is like this:

RewriteEngine On
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule (.*) /index.asp?rewrite_url=$1 [QSA,L,NU]

now it's working

thank you.
Back to Top
 

Sorry, you can NOT post a reply.
This forum has been locked by a forum administrator.

Printable version Printable version