This forum has been moved here:
Helicon Tech Community Forum

Helicon Ape (Forum Locked Forum Locked)
 Helicon Tech : Helicon Ape
Subject Topic: How to use mod_auth_basic with SEO url
Author
Message |
rohit
Newbie


Joined: 05 May 2011
Posts: 2
Posted: 05 May 2011 at 8:23am

Hello,

I have to apply username/password restriction to a SEO url as explained below.

when user open http://www.domain.com/testpage

it actually opens http://www.domain.com/index.php/testpage (but this is not visible to user due to SEO)

now I want to apply username/password restirction to only http://www.domain.com/testpage

rest of the site like http://www.domain.com/ or http://www.domain.com/newpage should work without username/password

Please note we don't have physical folder testpage on server.

How to achieve this using any tool from Helicon or something else.

This is really urgent.

Thanks in advance

---------------------------------------------------------

One thing more,

right now if i put following code in .htaccess in root then it ask for username/password for complete site

<LocationMatch "/testpage/">
AuthType basic 
AuthName "private area"  
AuthBasicProvider file  
AuthUserFile c:\inetpub\wwwroot\.htpasswds  
Require valid-user
</LocationMatch>



Edited by rohit - 05 May 2011 at 8:28am
Back to Top
 
Vyacheslav
Admin Group


Joined: 02 July 2008
Location: Ukraine
Posts: 1542
Posted: 05 May 2011 at 1:01pm

Hello.
“Location” directive should be used in httpd.conf file only. Please try and put the following code to httpd.conf:
Code:
<Location /testpage/>
AuthType basic
AuthName "private area"   
AuthBasicProvider file   
AuthUserFile c:\inetpub\wwwroot\.htpasswds   
Require valid-user
</Location>


__________________
Slavik Shynkarenko,
Helicon Tech.
Back to Top Visit Vyacheslav's Homepage
 
rohit
Newbie


Joined: 05 May 2011
Posts: 2
Posted: 10 May 2011 at 1:15am

Thanks for reply.

I tried to use following code as suggested by you in httpd.conf

<Location /testpage/>
AuthType basic
AuthName "private area"   
AuthBasicProvider file   
AuthUserFile c:\inetpub\wwwroot\.htpasswds   
Require valid-user
</Location>

but its not working, can you please let me know how to make it working.

We are using IIS7 and Windows Server 2008
Back to Top
 
Vyacheslav
Admin Group


Joined: 02 July 2008
Location: Ukraine
Posts: 1542
Posted: 10 May 2011 at 2:28am

Hello.
Please add “LogLevel debug” line into httpd.conf. That enables logging to error.log file.
Use this code:
Code:
<Location /testpage>
AuthType basic
AuthName "private area"    
AuthBasicProvider file    
AuthUserFile c:\inetpub\wwwroot\.htpasswds    
Require valid-user
</Location>


Make a few attempts and send us error.log file to [email protected]

Please also clarify how you perform URL rewriting. Is there any other configuration code?

Thank you.

__________________
Slavik Shynkarenko,
Helicon Tech.
Back to Top Visit Vyacheslav's Homepage
 

Sorry, you can NOT post a reply.
This forum has been locked by a forum administrator.

Printable version Printable version