This forum has been moved here:
Helicon Tech Community Forum

Helicon Ape (Forum Locked Forum Locked)
 Helicon Tech : Helicon Ape
Subject Topic: mod_proxy for https
Author
Message |
Stephan
Newbie


Joined: 19 April 2011
Location: Germany
Posts: 3
Posted: 19 April 2011 at 9:27am

Hello,

i've got a Werbserver with 1 IP but i need 2 SSL-Certificates. One https goes to "Default Web Site" (https://owa.mydomain.com) and the other on a Sharepoint-Site named https://team.mydomain.com

Now, requests on both Sites go to the Default Web Site. But i want to redirect the request for the Sharepoint-Site with Helicon Ape to the virtual directory of the Sharepoint-Site.

I wrote the following Code on the "Default Web Site"

Code:
ProxyPass /wss/VirtualDirectories/19590 https://team.mydomain.com/
ProxyPassReverse /wss/VirtualDirectories/19590 https://team.mydomain.com/


But it doesn't work...

Thanks Stephan
Back to Top
 
Vyacheslav
Admin Group


Joined: 02 July 2008
Location: Ukraine
Posts: 1542
Posted: 19 April 2011 at 9:46am

Hello.
Please try the following code:
Code:
RewriteEngine on
RewriteProxy ^wss/VirtualDirectories/19590(.*)$ https://team.mydomain.com$1 [NC,L]


__________________
Slavik Shynkarenko,
Helicon Tech.
Back to Top Visit Vyacheslav's Homepage
 
Stephan
Newbie


Joined: 19 April 2011
Location: Germany
Posts: 3
Posted: 19 April 2011 at 10:08am

No, it didn't work.

Do i use the right folder???
The Default Web Site is in C:\inetpub\wwwroot
and the Sharepoint Site in C:\inetpub\wwwroot\wss\VirtualDirectories\19590

Helicon Ape works, i tested it with

Code:

RewriteEngine
on
RewriteProxy
(.*) http://www.google.com/$1 [L]

Stephan
Back to Top
 
Vyacheslav
Admin Group


Joined: 02 July 2008
Location: Ukraine
Posts: 1542
Posted: 20 April 2011 at 6:09am

Hello.
Could you please give me an example of initial request as it should be and hidden request to the back-end.
Thank you.

__________________
Slavik Shynkarenko,
Helicon Tech.
Back to Top Visit Vyacheslav's Homepage
 
Stephan
Newbie


Joined: 19 April 2011
Location: Germany
Posts: 3
Posted: 20 April 2011 at 7:39am

Hello,

 

it’s a bit difficult to explain that in english, but i will try…

I own 2 Subdomains:

1.      https://owa.mydomain.com

2.      https://team.mydomain.com

 

I’ve got 1 static IP. My Router forwards public Port 443 to private port 443 on a Webserver with Sharepoint and Exchange.

If i request https://team.mydomain.com there’s no problem. Everything is fine, i request and get the Sharepoint-Site with SSL. The Binding of the SSL-Certificate for it, is on Server’s local IP 192.168.0.3.

But if i request https://owa.mydomain.com i get the Sharepoint-Site too, with a warning of a false Certificate. Because, the Binding on the Server’s local  IP is with the SSL-Certificate for team.mydomain.com

Now, i need a solution, which gets the request and can filter it. Means, if it’s a request for https://team.mydomain.com or if it’s a request for https://owa.mydomain.com Then the solution forward the request for https://team.mydomain.com to the virtual host from the Sharepoint-Site and a request for https://owa.mydomain.com to the virtual host of the IIS Default Web Site.

That’s my need.

Thanks, Stephan



Edited by Stephan - 24 April 2011 at 2:05pm
Back to Top
 
Vyacheslav
Admin Group


Joined: 02 July 2008
Location: Ukraine
Posts: 1542
Posted: 22 April 2011 at 9:19am

Hello.
Browser checks certificate depending on current domain. You should try and bind the certificate to https:/owa.mydomain.com.

__________________
Slavik Shynkarenko,
Helicon Tech.
Back to Top Visit Vyacheslav's Homepage
 

Sorry, you can NOT post a reply.
This forum has been locked by a forum administrator.

Printable version Printable version