This forum has been moved here:
Helicon Tech Community Forum

Helicon Ape (Forum Locked Forum Locked)
 Helicon Tech : Helicon Ape
Subject Topic: Mod Linkfreeze fails when 2 x asp? in url
Message |

Joined: 13 December 2010
Posts: 11
Posted: 04 March 2011 at 1:10am


Until recently I have been using Linkfreeze on Windows 2003 but recently migrated to 2008 R2 so have been trying Ape with Mod_LinkFreeze.

My setting is simple and in general works without problem:

SetEnv mod_linkfreeze
LinkFreezeRule --- "asp=htm" [ AbsLinks,MoveExt ]

But I have a problem with the following type of url:

With Mod_Linkfreeze on, it converts the link to:

But the link fails and browser reports a 404 error.

In LinkFreeze I simply disabled the relevant page file using the relevant HTTP header, but this does not seems to work for Ape (unless I am doing something wrong? I am not very familiar with IIS 7 but think I tried in the correct place).

The question is, how can I disable certain pages, similar to using HTTP headers?

Or, is there a way to write the rules so that a url similar to that above will work properly?

Thank you.

Back to Top
Admin Group

Joined: 02 July 2008
Location: Ukraine
Posts: 1542
Posted: 04 March 2011 at 8:26am

Please make sure you have the latest version of Ape.
You can disable mod_linkfreeze for certain folders if you put the following code into .htaccess file in such folder:
LinkFreezeEngine Off
UnSetEnv mod_linkfreeze

Alternatively, mod_setenvif can be used to build complex expressions as follows:
SetEnvIf %{REQUEST_URI} ^/admin.*$ !mod_linkfreeze

This code disables mod_linkfreeze for /admin folder.

Slavik Shynkarenko,
Helicon Tech.
Back to Top Visit Vyacheslav's Homepage

Sorry, you can NOT post a reply.
This forum has been locked by a forum administrator.

Printable version Printable version