This forum has been moved here:
Helicon Tech Community Forum

  Active TopicsActive Topics  Display List of Forum MembersMemberlist  HelpHelp   RegisterRegister  LoginLogin
ISAPI_Rewrite 2.x (Forum Locked Forum Locked)
 Helicon Tech : ISAPI_Rewrite 2.x
Subject Topic: Moved hosting and ISAPI doesn’t work
Author
Message |
webman44
Newbie


Joined: 03 March 2011
Location: United States
Posts: 4
Posted: 03 March 2011 at 10:21am

I moved my site to aspnix.com's trial hosting last year. At first my ISAPI rewrite rules didn't work. Their tech support was able to fix it in minutes.

I have now moved my site to their paid hosting account and the ISAPI rewites aren't working anymore. Unfortunately their tech support is not as helpful as the previous guy last year.

Can someone tell me what I need to do? I am willing to pay since this should be an easy job for someone that is familiar with this.
Here are some example URLs:
http://bestvaletparking.com/Amenity-Parking-Solutions.html
http://bestvaletparking.com/Alabama-valet-parking-1.html

Thank you

Back to Top Visit webman44's Homepage
 
Anton
Admin Group


Joined: 30 January 2007
Location: Ukraine
Posts: 10519
Posted: 04 March 2011 at 3:37am

Sure, we'll help.
But could you please give some more details...
Where should these rules point?
What rules are you currently using?
Also please confirm it's v2 you are on.

__________________
Regards,
Anton
Back to Top
 
webman44
Newbie


Joined: 03 March 2011
Location: United States
Posts: 4
Posted: 15 March 2011 at 12:35am

Actually it looks like the new hosting account has Helicon Ape so I guess I need to update my rules since they were for ISAPI rewrite 3?

Here are my rules:

#[ISAPI_Rewrite]

#RewriteRule /valetparking/(\d+)/? /results.asp\?id=$1 [I,L]

[ISAPI_Rewrite]

#TEST
RewriteRule ^/((.+["/"])*.+["."]html)/? /rule.asp\?url=$1 [L]


Please let me know what I need to do in order to make it work.

You might also want to move this post to Helicon Ape category.
Thanks

Back to Top Visit webman44's Homepage
 
Anton
Admin Group


Joined: 30 January 2007
Location: Ukraine
Posts: 10519
Posted: 15 March 2011 at 4:11am

Please try to use the following rules for Helicon Ape:

RewriteEngine On
RewriteBase /
RewriteCond %{REQUEST_FILENAME} !-f
RewriteRule ^(.+)\.html$ /rule.asp\?url=$1 [NC,L]

__________________
Regards,
Anton
Back to Top
 
webman44
Newbie


Joined: 03 March 2011
Location: United States
Posts: 4
Posted: 16 March 2011 at 12:18am

Anton,
I have updated the file name "httpd" with your suggested values but it is still not working:
http://bestvaletparking.com/Amenity-Parking-Solutions.html

Is there anything else that I need to do?

Back to Top Visit webman44's Homepage
 
Anton
Admin Group


Joined: 30 January 2007
Location: Ukraine
Posts: 10519
Posted: 16 March 2011 at 6:41am

Please enable logging in httpd.conf as follows:

RewriteLogLevel 9

And provide rewrite.log records for the request in question.

__________________
Regards,
Anton
Back to Top
 
webman44
Newbie


Joined: 03 March 2011
Location: United States
Posts: 4
Posted: 10 May 2011 at 1:19am

My site is hosted on a windows server.
I have added 'RewriteLogLevel 9' to my httpd.ini file as requested by you but I am not able to find rewite.log file under my logs folder.
All I see there are my daily log files.
What am I missing?
Back to Top Visit webman44's Homepage
 
Anton
Admin Group


Joined: 30 January 2007
Location: Ukraine
Posts: 10519
Posted: 10 May 2011 at 2:22am

If you are using Helicon Ape, your config file should be httpd.conf not httpd.ini.
You can open it in Helicon Ape Manager by clicking on the root of the site tree.

__________________
Regards,
Anton
Back to Top
 

Sorry, you can NOT post a reply.
This forum has been locked by a forum administrator.

Printable version Printable version
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot delete your posts in this forum
You cannot edit your posts in this forum
You cannot create polls in this forum
You cannot vote in polls in this forum