This forum has been moved here:
Helicon Tech Community Forum

Helicon Ape (Forum Locked Forum Locked)
 Helicon Tech : Helicon Ape
Subject Topic: APE/mod_linkfreeze not rewriting HTML out
Author
Message |
minektur
Newbie


Joined: 08 February 2011
Location: United States
Posts: 2
Posted: 15 February 2011 at 2:48pm

In short: I have windows server 2008 R2 - 64 bit, with IIS7. I have APE installed and mod linkfreeze configured like this (global .htaccess)

--
SetEnv mod_linkfreeze
LinkFreezeRule --- "asp=htm" "/(?!admin|CSS|Scripts).*" [MoveExt]
--

incoming links in the form:

http://speedhut.com/foo-xxx.htm

get properly routed to the actual asp code like this:

http://speedhut.com/foo.asp?id=xxx



but the HTML generated by my asp code does not have it's embedded links get re-written to be in the frozen form.



Navigate to

http://speedhut.com/bezel_gauge_trim_list.asp and look at any of the links on the page and you'll see that the URLs are not properly written to be frozen.


What have I tried so far?  I have added this to my web.config as instructed by helicon support:

<system.webServer>
<urlCompression doStaticCompression="false" doDynamicCompression="false" />
</system.webServer>



Any ideas on what to check?

Fred



Back to Top
 
minektur
Newbie


Joined: 08 February 2011
Location: United States
Posts: 2
Posted: 16 February 2011 at 2:08pm

Turns out to be a problem with my linkfreeze exception regex not matching some relative links generated by the site asp code.

Thanks helicon support!

Fred
Back to Top
 

Sorry, you can NOT post a reply.
This forum has been locked by a forum administrator.

Printable version Printable version