This forum has been moved here:
Helicon Tech Community Forum

Helicon Ape (Forum Locked Forum Locked)
 Helicon Tech : Helicon Ape
Subject Topic: Issue with "::" in address
Author
Message |
GrZeCh
Newbie


Joined: 27 March 2009
Posts: 18
Posted: 09 February 2011 at 6:04am

Hello,

I have client which reports bad request error when he tries to open this URL:

http://CLIENTDOMAIN/gallery3/admin/maintenance/start/gallery_task::rebuild_dirty_images?csrf=007d4a1214289aea09b9759ae1324e96

Error generated by IIS:

HTTP Error 400.0 - Bad Request

ASP.NET detected invalid characters in the URL.

<>Detailed Error Information
ModuleHelicon.Ape
NotificationBeginRequest
HandlerStaticFile
Error Code0x00000000
Requested URLhttp://CLIENTDOMAIN/gallery3/admin/maintenance/start/gallery_task::rebuild_dirty_images?csrf=007d4a1214289aea09b9759ae1324e96
Physical PathPATH\gallery3\admin\maintenance\start\gallery_task::rebuild_dirty_images
Logon MethodNot yet determined
Logon UserNot yet determined

I've tried to look on this forum for this issue but enabling allow double escaping (http://www.helicontech.com/forum/15921-HTTP_Error_400__invalid_characters.html) didn't solved my problem.

Any ideas?

Regards



Edited by GrZeCh - 09 February 2011 at 6:08am
Back to Top
 
Vyacheslav
Admin Group


Joined: 02 July 2008
Location: Ukraine
Posts: 1542
Posted: 09 February 2011 at 8:46am

Hello.
Please try the following solutions:

Add “AllowRestrictedChars = 1” key: http://support.microsoft.com/kb/820129

Set the following registry key to enable the fix:
“DWORD HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\ASP.NET VerificationCompatibility = 1”:
http://support.microsoft.com/default.aspx?scid=kb;EN-US;826437

__________________
Slavik Shynkarenko,
Helicon Tech.
Back to Top Visit Vyacheslav's Homepage
 
GrZeCh
Newbie


Joined: 27 March 2009
Posts: 18
Posted: 09 February 2011 at 10:16am

As far I can see in first and the second articles issues are with .NET Framework 1.1 and Windows 2003. Does this problem affects also Windows 2008 R2 with Integrated Pipeline application pool enabled (32bit compatibility)?
Back to Top
 
Vyacheslav
Admin Group


Joined: 02 July 2008
Location: Ukraine
Posts: 1542
Posted: 10 February 2011 at 4:25am

Hello.
Still it may help. Please try.

__________________
Slavik Shynkarenko,
Helicon Tech.
Back to Top Visit Vyacheslav's Homepage
 

Sorry, you can NOT post a reply.
This forum has been locked by a forum administrator.

Printable version Printable version