This forum has been moved here:
Helicon Tech Community Forum

Helicon Ape (Forum Locked Forum Locked)
 Helicon Tech : Helicon Ape
Subject Topic: APE Rewrite Proxy
Author
Message |
levensok
Newbie


Joined: 02 June 2009
Posts: 3
Posted: 28 January 2011 at 2:31pm

I intalled APE on IIS7.5.  The httpd.conf, applicationHost.config and web.config are all default from the APE install.

My .htaccess for the directory I want to reverse proxy looks like this:

RewriteEngine On
RewriteBase /
RewriteProxy ^mydirectory/(.*)$ http://www.google.com/$1

When I access the page, I get a 403.14 error.  When I enable Directory Browsing, then I just get a page listing:

[To Parent Directory]

1/28/2011 12:09 PM 190 .htaccess
1/28/2011 12:30 PM 168 web.config
How do I get APE to execute?

 

 

Back to Top
 
Anton
Admin Group


Joined: 30 January 2007
Location: Ukraine
Posts: 10519
Posted: 31 January 2011 at 7:07am

Well, 403 error is usually caused by insufficient permissions, so first, I suggest you to check NTFS permissions for the target folder, paying
specific attention to List Folder Content permissions.

Also, it's worth checking if Ape is working for you at all. You can use simple

RewriteRule /test http://www.google.com/ [NC,R=301,L]

to see if it leads you to Google page or Not Found one.

__________________
Regards,
Anton
Back to Top
 

Sorry, you can NOT post a reply.
This forum has been locked by a forum administrator.

Printable version Printable version