This forum has been moved here:
Helicon Tech Community Forum

Helicon Ape (Forum Locked Forum Locked)
 Helicon Tech : Helicon Ape
Subject Topic: ProxyPass
Author
Message |
pkrug
Newbie


Joined: 24 January 2011
Posts: 4
Posted: 24 January 2011 at 11:38am

I have ISAPI_Rewrite (3.1.0.78) and APE (3.0.0.59) installed.   I have an Apache server that is proxying but I can not seem to get it working on my IIS6 server.

The entry I am using is :  ProxyPass /hlp/ http://wlr/

 

Any ideas?

 

 

Back to Top
 
Vyacheslav
Admin Group


Joined: 02 July 2008
Location: Ukraine
Posts: 1542
Posted: 25 January 2011 at 7:55am

Hello.
Please provide us with more details. Where do you have that code? What type of requests you’re trying to handle? What results do you see?

You may also check the following resources:
Helicon Ape Troubleshooting.
Load balancing with Helicon Ape mod_proxy.
mod_proxy documentation.

__________________
Slavik Shynkarenko,
Helicon Tech.
Back to Top Visit Vyacheslav's Homepage
 
pkrug
Newbie


Joined: 24 January 2011
Posts: 4
Posted: 25 January 2011 at 9:22am

I entered the "code" in the APE manager at the website level that I am trying to enter in the Proxy configuration.  

What type of requests am I trying to handle?   I am trying to do the same type of configuration that I would do in APACHE in APE.  In APACHE in order to proxy requests from the original server I use "proxypass".    I copied the same line from APACHE that works into APE Manager, and saved the configuration.

What results do I see?   It does not proxy anything.   It works like it did before the addition of proxypass.   If I use the APE Manager I see the configuration for ISAPI_Rewrite and APE.  If I go into the ISAPI_Rewrite tab in IIS and try to save the settings it does not like the updated information put in by APE. 

I have modified the httpd.conf in the APE installation directory to point to a different Access file (AccessFileName ape.htaccess).   I have also turned on debugging.   When I open up the APE Manager I see the entries that I put in the httpd.conf file (debugging, pointing to ape.htaccess) but when I click on the website it brings up the ISAPI Rewrite 3 .htaccess file not the .htaccess file listed in th configuration file.

Any ideas?

Back to Top
 
Vyacheslav
Admin Group


Joined: 02 July 2008
Location: Ukraine
Posts: 1542
Posted: 26 January 2011 at 8:26am

Hello.
First of all you shouldn’t use both ISAPI_Rewrite and Helicon Ape. Since Helicon Ape covers all the features of ISAPI_Rewrite, the software “thinks” it’s alone.
Anyway, ProxyPass directive on directory level should be used without location specified:
Code:
ProxyPass http://wlr/


Please put that code to .htaccess of /hlp directory. Alternatively you can put ProxyPass /hlp/ http://wlr/ to httpd.conf.

__________________
Slavik Shynkarenko,
Helicon Tech.
Back to Top Visit Vyacheslav's Homepage
 
pkrug
Newbie


Joined: 24 January 2011
Posts: 4
Posted: 27 January 2011 at 4:27pm

Ok I have been working on this off and on trying to get it working.   I decided to look for another tool and found http://iirf.codeplex.com/.   I installed it and within 15 minutes it is up and running proxying my requests...

 

Back to Top
 
Vyacheslav
Admin Group


Joined: 02 July 2008
Location: Ukraine
Posts: 1542
Posted: 28 January 2011 at 4:45am

Hello.
Fair enough. Although IIRF doesn’t provide even a half of Helicon Ape’s features. There is no official support either.
I’m sure the solution would be simple.

Please let me know if you need any further assistance.
Thank you.

__________________
Slavik Shynkarenko,
Helicon Tech.
Back to Top Visit Vyacheslav's Homepage
 

Sorry, you can NOT post a reply.
This forum has been locked by a forum administrator.

Printable version Printable version