This forum has been moved here:
Helicon Tech Community Forum

Helicon Ape (Forum Locked Forum Locked)
 Helicon Tech : Helicon Ape
Subject Topic: bad request not using .htaccess!
Author
Message |
ronaldk
Newbie


Joined: 07 April 2010
Location: Netherlands
Posts: 9
Posted: 26 November 2010 at 8:18am

We have a client that uses ms rewrite (web.config) and has no .htaccess file. He gets bad request message when he is in integrated mode. Switching to classic everything works fine. When using request tracing on integrated mode we see that the bad request comes from APE. How is this possible because he is not using APE or .htaccess.

IIS7&APE 3.0.0.57
Back to Top Visit ronaldk's Homepage
 
Vyacheslav
Admin Group


Joined: 02 July 2008
Location: Ukraine
Posts: 1542
Posted: 26 November 2010 at 8:47am

Hello.
Could you please provide us with the data which pointed to Ape causing “bad request” errors. Please also clarify whether you use proxy features of Ape.
Thanks.

__________________
Slavik Shynkarenko,
Helicon Tech.
Back to Top Visit Vyacheslav's Homepage
 
ronaldk
Newbie


Joined: 07 April 2010
Location: Netherlands
Posts: 9
Posted: 26 November 2010 at 9:10am

Vyacheslav wrote:
Hello.
Could you please provide us with the data which pointed to Ape causing “bad request” errors. Please also clarify whether you use proxy features of Ape.
Thanks.


Hello yes all modules are active.
Url with error: http://www.gordijnshop.nl/assortiment/overgordijnen/type=op=opruiming&dessin=all&stofmaat=all&prijsklasse=all&kleur=all

Request trace:
100. view trace Warning -SET_RESPONSE_ERROR_DESCRIPTION 
ErrorDescriptionASP.NET detected invalid characters in the URL.

101. view trace Warning -MODULE_SET_RESPONSE_ERROR_STATUS 
ModuleNameHelicon.Ape
Notification1
HttpStatus400
HttpReasonBad Request
HttpSubStatus0
ErrorCode0
ConfigExceptionInfo
Notification BEGIN_REQUEST
ErrorCode The operation completed successfully. (0x0)























Edited by ronaldk - 26 November 2010 at 9:12am
Back to Top Visit ronaldk's Homepage
 
Vyacheslav
Admin Group


Joined: 02 July 2008
Location: Ukraine
Posts: 1542
Posted: 27 November 2010 at 2:44am

Hello.
Please use “Zip and Save” feature of Helicon Ape manager (http://www.helicontech.com/articles/zip-and-save-option-in-ape-manager/) and send us generated archive to [email protected]
Thanks.

__________________
Slavik Shynkarenko,
Helicon Tech.
Back to Top Visit Vyacheslav's Homepage
 
ronaldk
Newbie


Joined: 07 April 2010
Location: Netherlands
Posts: 9
Posted: 07 December 2010 at 8:22am

Hello.
Thanks for the files.
We have to test, I’m not sure why it’s happening. The web.config is full of many settings, there are several other modules. Helicon Ape is set for the whole server. I mean it’s installed globally. Even though you have no .htaccess—IIS still runs Ape on every request.
As we test, you can simply disable Helicon Ape for that website. Run Helicon Ape manager, select the website in the tree and in the context menu choose “Disable Helicon Ape”.

__________________
Slavik Shynkarenko,
Helicon Tech.


I will have a problem if this is not resolved. Now we have to disable ape manually for each site this reseller will create. Also when this customer want to use password protected files/directories we need to enable ape for this. Can you point us in the right direction maybe? We have enable all modules from ape but may not need them all. Could this be related to a ape module witch we can disable?

Back to Top Visit ronaldk's Homepage
 
Vyacheslav
Admin Group


Joined: 02 July 2008
Location: Ukraine
Posts: 1542
Posted: 07 December 2010 at 8:56am

Hello.
I’m sorry for delay. Is it possible to have terminal access to the server?
Thanks.

__________________
Slavik Shynkarenko,
Helicon Tech.
Back to Top Visit Vyacheslav's Homepage
 

Sorry, you can NOT post a reply.
This forum has been locked by a forum administrator.

Printable version Printable version