This forum has been moved here:
Helicon Tech Community Forum

  Active TopicsActive Topics  Display List of Forum MembersMemberlist  HelpHelp   RegisterRegister  LoginLogin
ISAPI_Rewrite 2.x (Forum Locked Forum Locked)
 Helicon Tech : ISAPI_Rewrite 2.x
Subject Topic: removing file name from url
Author
Message |
kapkurt
Newbie


Joined: 11 August 2010
Posts: 17
Posted: 24 November 2010 at 2:10pm

i need to do the following: 

http://www.mywebsite.com/index.cfm

needs to be rewritten as

http://www.mywebsite.com/
Back to Top
 
Anton
Admin Group


Joined: 30 January 2007
Location: Ukraine
Posts: 10519
Posted: 25 November 2010 at 2:40am

Please try to use the following:

[ISAPI_Rewrite]
RewriteRule / /index.cfm [I,L]

__________________
Regards,
Anton
Back to Top
 
kapkurt
Newbie


Joined: 11 August 2010
Posts: 17
Posted: 30 November 2010 at 1:06pm

I tried adding the code above and it sent the site into a continuous loop when i typed in the website address  and the index.cfm
Back to Top
 
Anton
Admin Group


Joined: 30 January 2007
Location: Ukraine
Posts: 10519
Posted: 01 December 2010 at 2:13am

Maybe that's due to Default Document settings you have in IIS.
It may redirect / to /index.cfm before ISAPI_Rewrite and then the above rule will cause a loop.
Please check these settings.
And also please clarify whether you need /index.cfm request to look like like / or vice versa.

__________________
Regards,
Anton
Back to Top
 
kapkurt
Newbie


Joined: 11 August 2010
Posts: 17
Posted: 01 December 2010 at 9:22am

Can i do a 301 redirect for www.mywebsite.com/index.cfm to www.mywebsite.com?  I have to have that default doc in my iis
Back to Top
 
Anton
Admin Group


Joined: 30 January 2007
Location: Ukraine
Posts: 10519
Posted: 02 December 2010 at 3:52am

Sure, you can:

RewriteRule /index\.cfm / [I,RP]

__________________
Regards,
Anton
Back to Top
 
kapkurt
Newbie


Joined: 11 August 2010
Posts: 17
Posted: 02 December 2010 at 9:07am

This does not do anything it just remains at

http://www.mywebsite.com/index.cfm
Back to Top
 
kapkurt
Newbie


Joined: 11 August 2010
Posts: 17
Posted: 02 December 2010 at 9:13am

Got it thanks for the help
Back to Top
 

Sorry, you can NOT post a reply.
This forum has been locked by a forum administrator.

Printable version Printable version
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot delete your posts in this forum
You cannot edit your posts in this forum
You cannot create polls in this forum
You cannot vote in polls in this forum