This forum has been moved here:
Helicon Tech Community Forum

Helicon Ape (Forum Locked Forum Locked)
 Helicon Tech : Helicon Ape
Subject Topic: Bad Rewrites
Author
Message |
Mikobiko
Newbie


Joined: 17 November 2010
Posts: 2
Posted: 17 November 2010 at 1:08am

Currently having an issue in a migration i am doing. Ape
doesn't seem to enjoy wiki FURL's. Rewrite is as follows:


# Helicon Ape version 3.0.0.54

RewriteEngine On
RewriteRule ^wiki/(.*)$ /w/index.php?title=$1 [PT,L,QSA]
RewriteRule ^wiki/*$ /w/index.php [L,QSA]
RewriteRule ^/*$ /w/index.php [L,QSA]

#SetEnv mod_developer secure-key-482474570

It works great until you hit a url with a ":" in it.

Any ideas? Rule worked perfect in apache.
Back to Top
 
Guests
Guest


Joined: 01 October 2003
Online Status: Online
Posts: -160
Posted: 17 November 2010 at 5:28am

HEllo,

that's the issue of IIS, and not Helicon Ape.

You may find the cure in the following articles:
- http://support.microsoft.com/kb/820129 - add AllowRestrictedChars = 1
- http://support.microsoft.com/default.aspx?scid=kb;EN-US;826437 - set the following registry key to enable the fix:
DWORD HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\ASP.NET VerificationCompatibility = 1

Regards
Andrew
Back to Top
 
Mikobiko
Newbie


Joined: 17 November 2010
Posts: 2
Posted: 17 November 2010 at 12:53pm

Still erroring out:

http://pastebin.com/mnbdrpg6
Back to Top
 
Guests
Guest


Joined: 01 October 2003
Online Status: Online
Posts: -160
Posted: 18 November 2010 at 3:15am

What OS do you have? What IIS is that?
Have you rebooted the system for the changes to take effect?

Regards
Andrew
Back to Top
 

Sorry, you can NOT post a reply.
This forum has been locked by a forum administrator.

Printable version Printable version