This forum has been moved here:
Helicon Tech Community Forum

Helicon Ape (Forum Locked Forum Locked)
 Helicon Tech : Helicon Ape
Subject Topic: Rewrite: all pages go to home page
Author
Message |
tdennis
Newbie


Joined: 14 October 2010
Location: United States
Posts: 14
Posted: 14 October 2010 at 11:11am

I had my system admin install the lite version of Helicon
Ape to our server. I set up my htaccess file by your
example on the blog for wordpress. The URL's are pretty but
all pages, post, etc... link back to the home page. Any
idea why this is happening? I've looked through the forum
for about an hour now and no luck with finding a solution.

Thanks and Appreciate the help.


My htaccess file
# Helicon Ape version 3.0.0.52

RewriteEngine On
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule ^$ index.php [NC,L]

ExpiresActive On
ExpiresByType image/jpeg "access plus 1 days"
ExpiresByType image/gif "access plus 1 days"
ExpiresByType text/css   "access plus 1 days"
ExpiresByType application/x-javascript "access plus 1 days"

mod_gzip_on yes
mod_gzip_item_include Mime ^text/.*

<Files index.php>
ExpiresByType "text/html; charset=UTF-8" A30
CacheEnable mem
CacheVaryByHeaders Original-Url
</Files>

Header set Server "Apache/2.2.9 (Unix)"

Edited by tdennis - 14 October 2010 at 1:47pm
Back to Top
 
Vyacheslav
Admin Group


Joined: 02 July 2008
Location: Ukraine
Posts: 1542
Posted: 15 October 2010 at 5:42am

Hello,
Please try and add the following code to index.php:
Code:
if (isset($_SERVER['HTTP_X_REWRITE_URL']))
{
$_SERVER['REQUEST_URI'] = $_SERVER['HTTP_X_REWRITE_URL'];
}

Thanks.

__________________
Slavik Shynkarenko,
Helicon Tech.
Back to Top Visit Vyacheslav's Homepage
 
tdennis
Newbie


Joined: 14 October 2010
Location: United States
Posts: 14
Posted: 15 October 2010 at 9:04am

Added the code to the index.php file and no luck. When I
switch back to default permalinks the pages work
completely fine. Switch back to custom and they don't
work.

Which index.php file am I placing the code in. I have the
theme index.php, wp-content index.php, and wordpress
index.php

At this time I have it in the wordpress index.php file

I also have this in the web.config file
Code:
<rule name="wordpress" patternSyntax="Wildcard">
<match url="*" /> <conditions> <add
input="{REQUEST_FILENAME}" matchType="IsFile"
negate="true" /> <add input="{REQUEST_FILENAME}"
matchType="IsDirectory" negate="true" /> </conditions>
<action type="Rewrite" url="index.php" /> </rule>


Back to Top
 
Vyacheslav
Admin Group


Joined: 02 July 2008
Location: Ukraine
Posts: 1542
Posted: 15 October 2010 at 9:57am

Please remove that code from web.config. Otherwise you have two different rewrite engines doing the same job.
Please also let me know what permalinks format you use.
Thanks.

__________________
Slavik Shynkarenko,
Helicon Tech.
Back to Top Visit Vyacheslav's Homepage
 
tdennis
Newbie


Joined: 14 October 2010
Location: United States
Posts: 14
Posted: 15 October 2010 at 10:21am

I'm using /%category%/%postname%/ but get an

500 - Internal server error.
There is a problem with the resource you are looking for,
and it cannot be displayed.

when I remove the code from web.config file.
Back to Top
 
Vyacheslav
Admin Group


Joined: 02 July 2008
Location: Ukraine
Posts: 1542
Posted: 20 October 2010 at 1:34am

Hello.
I’m sorry for delay. Could you please remove URL Rewriter code from web.config, make several requests and provide me with error.log file.
Thanks.

__________________
Slavik Shynkarenko,
Helicon Tech.
Back to Top Visit Vyacheslav's Homepage
 
tdennis
Newbie


Joined: 14 October 2010
Location: United States
Posts: 14
Posted: 28 October 2010 at 4:04pm

Sorry but where can I get the error.log file from? I'm in
my IIS Manager but unable to find the error.log for you.
Back to Top
 
Vyacheslav
Admin Group


Joined: 02 July 2008
Location: Ukraine
Posts: 1542
Posted: 28 October 2010 at 8:21pm

Hello.
I’m sorry for the vagueness.
The file resides in the installation folder, which normally is C:\Program Files\Helicon\Ape.

Please also turn on the full verbosity level by writing “LogLevel debug” in httpd.conf file (it’s also in the installation folder).

Thanks.

__________________
Slavik Shynkarenko,
Helicon Tech.
Back to Top Visit Vyacheslav's Homepage
 
tdennis
Newbie


Joined: 14 October 2010
Location: United States
Posts: 14
Posted: 29 October 2010 at 8:16am

Let me know if you need me to email the entire error.log
file. I only copied the past few days b/c of the length.

[10/25/2010 9:07:24 AM] [cache_module] items stored in the
cache: 0; bytes available for the cache: 754974720,
physical memory limit: 98%
[10/25/2010 12:44:39 PM] [LicenseManager] Site with id=1 is
working with free license
[10/25/2010 12:44:39 PM] [cache_module] items stored in the
cache: 0; bytes available for the cache: 754974720,
physical memory limit: 98%
[10/25/2010 5:31:17 PM] [LicenseManager] Site with id=1 is
working with free license
[10/25/2010 5:31:17 PM] [cache_module] items stored in the
cache: 0; bytes available for the cache: 754974720,
physical memory limit: 98%
[10/26/2010 8:58:08 AM] [LicenseManager] Site with id=1 is
working with free license
[10/26/2010 8:58:08 AM] [cache_module] items stored in the
cache: 0; bytes available for the cache: 754974720,
physical memory limit: 98%
[10/26/2010 9:41:04 AM] [LicenseManager] Site with id=1 is
working with free license
[10/26/2010 9:41:04 AM] [cache_module] items stored in the
cache: 0; bytes available for the cache: 754974720,
physical memory limit: 98%
[10/26/2010 10:37:41 AM] [LicenseManager] Site with id=1 is
working with free license
[10/26/2010 10:37:41 AM] [cache_module] items stored in the
cache: 0; bytes available for the cache: 754974720,
physical memory limit: 98%
[10/26/2010 12:44:20 PM] [LicenseManager] Site with id=1 is
working with free license
[10/26/2010 12:44:20 PM] [cache_module] items stored in the
cache: 0; bytes available for the cache: 754974720,
physical memory limit: 98%
[10/26/2010 2:08:36 PM] [LicenseManager] Site with id=1 is
working with free license
[10/26/2010 2:08:36 PM] [cache_module] items stored in the
cache: 0; bytes available for the cache: 754974720,
physical memory limit: 98%
[10/28/2010 8:28:16 AM] [LicenseManager] Site with id=1 is
working with free license
[10/28/2010 8:28:16 AM] [cache_module] items stored in the
cache: 0; bytes available for the cache: 754974720,
physical memory limit: 98%
[10/28/2010 10:14:21 AM] [LicenseManager] Site with id=1 is
working with free license
[10/28/2010 10:14:21 AM] [cache_module] items stored in the
cache: 0; bytes available for the cache: 754974720,
physical memory limit: 98%
[10/28/2010 11:19:18 AM] [LicenseManager] Site with id=1 is
working with free license
[10/28/2010 11:19:18 AM] [cache_module] items stored in the
cache: 0; bytes available for the cache: 754974720,
physical memory limit: 98%
[10/28/2010 1:43:35 PM] [LicenseManager] Site with id=1 is
working with free license
[10/28/2010 1:43:35 PM] [cache_module] items stored in the
cache: 0; bytes available for the cache: 754974720,
physical memory limit: 98%
Back to Top
 
tdennis
Newbie


Joined: 14 October 2010
Location: United States
Posts: 14
Posted: 29 October 2010 at 9:05am

I've deleted the web.config file and my .htaccess file is
located in the wwwwroot folder.

My .htaccess file includes this in which I got from
Helicon's blog "Turning Wordpress"
# Helicon Ape version 3.0.0.52

RewriteEngine On
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . index.php [NC,L]

ExpiresActive On
ExpiresByType image/jpeg "access plus 1 days"
ExpiresByType image/gif "access plus 1 days"
ExpiresByType text/css   "access plus 1 days"
ExpiresByType application/x-javascript "access plus 1
days"

mod_gzip_on yes
mod_gzip_item_include Mime ^text/.*

<Files index.php>
ExpiresByType "text/html; charset=UTF-8" A30
CacheEnable mem
CacheVaryByHeaders Original-Url
</Files>

Header set Server "Apache/2.2.9 (Unix)"

I'm using /%category%/%postname%/ for my permalinks and
I'm getting the 404 File or Directory Not Found.

All of the LoadModule within httpd.conf are enable and
I've enable the LogLevel debug as well.

Just wanted to give you an update on what I have up in
running.

Thanks,
Ty
Back to Top
 
Vyacheslav
Admin Group


Joined: 02 July 2008
Location: Ukraine
Posts: 1542
Posted: 31 October 2010 at 11:20am

Hello.
Thanks for the log and .htaccess. I can see you’re using free version. It has limit of 3 websites. You should run Helicon Ape manager and select “Help” → “License Manager”. Please check whether the free license is enabled for that website.
Thanks.

Edited by Vyacheslav - 31 October 2010 at 11:21am


__________________
Slavik Shynkarenko,
Helicon Tech.
Back to Top Visit Vyacheslav's Homepage
 
tdennis
Newbie


Joined: 14 October 2010
Location: United States
Posts: 14
Posted: 01 November 2010 at 8:30am

License was enable. Let me ask to be clear. Where should
the .htaccess file go? Does it go in the Intepub folder or
the wwwroot folder?
Back to Top
 
tdennis
Newbie


Joined: 14 October 2010
Location: United States
Posts: 14
Posted: 01 November 2010 at 9:02am

Got everything working now. Deleted everything and started
from the beginning and she up in running. Let's hope
nothing happens, so we are good for now.

Thanks and Appreciate the help,

Ty
Back to Top
 
Vyacheslav
Admin Group


Joined: 02 July 2008
Location: Ukraine
Posts: 1542
Posted: 01 November 2010 at 10:19am

Hello.
I’m glad you’ve got it working.
.htaccess basically goes to website’s root folder (it’s C:\inetpub\wwwroot for the default website). But you may also use subfolders.

__________________
Slavik Shynkarenko,
Helicon Tech.
Back to Top Visit Vyacheslav's Homepage
 
tdennis
Newbie


Joined: 14 October 2010
Location: United States
Posts: 14
Posted: 17 February 2011 at 4:56pm

My Helicon Ape just stopped working and I believe I have
checked every possible solution there is. The home page
works fine but all sub pages are:

Server Error
404 - File or directory not found
The resource you are looking for might have been removed,
had its named changed, or is temporarily unavailable.


I deleted everything and started over again. I've moved
.htaccess files and then put back. Enable and Disabled
the licenses on the website. I'm using the free version.
Commented and Uncommented the httpd.conf file a number of
times.

Is there anything that I could be missing. I've even
check to see if PHP was running. Any help would really be
appreciated.

Ty
Back to Top
 
Vyacheslav
Admin Group


Joined: 02 July 2008
Location: Ukraine
Posts: 1542
Posted: 17 February 2011 at 7:58pm

Hello.
Probably you didn’t specify which websites should use free license therefore some of them actually worked in trial mode. Please open Helicon Ape manager and go to “Help” → “License Manager”. There you’ll be able to specify 3 websites to be working under free license.

__________________
Slavik Shynkarenko,
Helicon Tech.
Back to Top Visit Vyacheslav's Homepage
 
tdennis
Newbie


Joined: 14 October 2010
Location: United States
Posts: 14
Posted: 18 February 2011 at 8:44am

I've done that a number of times by disabling and enabling
them again.
Back to Top
 
Vyacheslav
Admin Group


Joined: 02 July 2008
Location: Ukraine
Posts: 1542
Posted: 21 February 2011 at 2:47am

Hello.
Please provide error.log file. Try to remember what’s changed on the server recently.

__________________
Slavik Shynkarenko,
Helicon Tech.
Back to Top Visit Vyacheslav's Homepage
 
tdennis
Newbie


Joined: 14 October 2010
Location: United States
Posts: 14
Posted: 22 February 2011 at 9:01am

We switched our intranet from port 8080 to port 80 a couple
of days ago. This issue started a day before we made the
switch. Everything is running okay but the permalinks. All
WordPress pages and post are working. Database is working
as it should.

I have the error log file but unable to open it to copy the
information for you. So I .zip it up and .
you can
download it by click here
Back to Top
 
Vyacheslav
Admin Group


Joined: 02 July 2008
Location: Ukraine
Posts: 1542
Posted: 24 February 2011 at 6:45pm

Hello.
Please check NTFS permissions for licenses.conf file in Helicon Ape installation folder. Application pool identities should be able to read the file. According to the log there is license issue.

__________________
Slavik Shynkarenko,
Helicon Tech.
Back to Top Visit Vyacheslav's Homepage
 

Page of 2 Next >>
 
Printable version Printable version