This forum has been moved here:
Helicon Tech Community Forum

  Active TopicsActive Topics  Display List of Forum MembersMemberlist  HelpHelp   RegisterRegister  LoginLogin
ISAPI_Rewrite 2.x (Forum Locked Forum Locked)
 Helicon Tech : ISAPI_Rewrite 2.x
Subject Topic: Using IsapiRewrite with another site
Author
Message |
elaborative
Newbie


Joined: 12 October 2010
Posts: 3
Posted: 12 October 2010 at 2:16pm

I am moving a large web application from a Win2K server using isapiRewrite 2 to a Win2003 server that already has a copy of isapiRewrite 2 installed and working on another website that resides on that machine. 

I have moved all the files to the new machine and the site is coming up in test mode (the home page).  I copied all of the rules into the httpd.ini file (added it to the exisiting rules for the other site) and added the reference to the IIS entry in as well.

I get page not found errors from every link that uses the rewrite and I cannot figure out why. Do I need to do something else to activate the rewrite on the new web application I am adding?

Any help would be greatly appreciated
Back to Top
 
Anton
Admin Group


Joined: 30 January 2007
Location: Ukraine
Posts: 10519
Posted: 13 October 2010 at 5:04am

Please clarify the following:

- "I copied all of the rules into the httpd.ini file (added it to the exisiting rules for the other site)"
Do you have global httpd.ini with the rules for all sites?

- "that already has a copy of isapiRewrite 2 installed"
Please confirm it's Full not Lite version

- tell where did the rules for existing site reside

- show the rules for the existing sites and the rules for the new site.

__________________
Regards,
Anton
Back to Top
 
elaborative
Newbie


Joined: 12 October 2010
Posts: 3
Posted: 13 October 2010 at 12:35pm

Thanks for the reply Anton: Here are my answers1. I have used the httpd.ini editing tool in the IsapiRewite program option to edit that file and
add all  of the rules for the new site to existing rules for the site already using it on that server...so ALL the rules for both websites are now
in that file.2. Yes this is the full version 3. The rules for the existing site are in the httpd.ini file4. There are Many rules for the sites
shown below. The BANANASMUSIC RULES are the new ones we just added.  The SALONEMPLOMENT RULES  are the ones that are used for the site that is
currently live on the server.
Let me know if you can help troubleshoot this Mike


Edited by Anton - 15 October 2010 at 12:54am
Back to Top
 
Anton
Admin Group


Joined: 30 January 2007
Location: Ukraine
Posts: 10519
Posted: 14 October 2010 at 7:15am

Ok, thanks for providing details.
I suggest you the following:

- remove DisableRewrite and EnableRewrite directives as they are not supported in ISAPI_Rewrite.

- create httpd.ini in the root of BANANASMUSIC site and put proper rules into it

- create httpd.ini in the root of SALONEMPLOYMENTsite and put proper rules into it

- retry your tests and report the results.

__________________
Regards,
Anton
Back to Top
 
elaborative
Newbie


Joined: 12 October 2010
Posts: 3
Posted: 14 October 2010 at 1:13pm

Anton,
Thank you for this information we made the changes you suggested and everything appears to be working properly now.  I appreciate your prompt responses!

I also noticed you are a moderator for the forums....I would request that you delete the actual rewrite rules I placed in the form from the posting if you could. 

Mike
Back to Top
 

Sorry, you can NOT post a reply.
This forum has been locked by a forum administrator.

Printable version Printable version
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot delete your posts in this forum
You cannot edit your posts in this forum
You cannot create polls in this forum
You cannot vote in polls in this forum