This forum has been moved here:
Helicon Tech Community Forum

Helicon Ape (Forum Locked Forum Locked)
 Helicon Tech : Helicon Ape
Subject Topic: DotNetPanel conflict with Helicon Ape
Author
Message |
ecbmarketing
Newbie


Joined: 04 August 2010
Posts: 4
Posted: 22 September 2010 at 2:12am

I have tried to install Helicon Ape on a DotNetPanel IIS server. If i use the standard htaccess files i get "Error AuthName directive not found.". So i changed the file to use ape.ini rather than .htaccess. Now i just get a 500 error. Error log shows that my credentials are valid but nothing else.
Back to Top
 
Anton
Admin Group


Joined: 30 January 2007
Location: Ukraine
Posts: 10519
Posted: 22 September 2010 at 5:21am

This may happen due to your using 'Secure Folders' feature in DotNetPanel. In this case the .htaccess created is incompatible with Ape.
Could you please outline your DotNetPanel settings more explicitly.
Also please show the Ape config you are trying to get working.

__________________
Regards,
Anton
Back to Top
 
ecbmarketing
Newbie


Joined: 04 August 2010
Posts: 4
Posted: 22 September 2010 at 4:57pm

Secure folders are disabled in DotNetPanel. Since im using shared hosting i have used the manual install, so i have the Helicon Folder (with standard httpd with addition to check for ape.ini), Bin folder and the web.config file:

<system.webServer>
  <modules>
   <add name="Ape" type="Helicon.Ape.ApeModule" />
  </modules>
  <handlers>
  <add name="Ape" path="*.apeproxy" verb="*" type="Helicon.Ape.Mod.ProxyHandler"
   resourceType="Unspecified" preCondition="integratedMode" />
  <add name="PHP via FastCGI (*.php)" path="*.php" verb="GET,HEAD,POST,DEBUG" modules="FastCgiModule"    scriptProcessor="C:\Program Files (x86)\PHP\php-cgi.exe" resourceType="File" />
  </handlers>
        <defaultDocument>
            <files>
                <clear />
                <add value="index.php" />
            </files>
        </defaultDocument>
 </system.webServer>

Back to Top
 
Anton
Admin Group


Joined: 30 January 2007
Location: Ukraine
Posts: 10519
Posted: 23 September 2010 at 5:01am

Could you please specify the version of Windows you are on.
And please provide complete Ape configuration you are trying to use.

__________________
Regards,
Anton
Back to Top
 

Sorry, you can NOT post a reply.
This forum has been locked by a forum administrator.

Printable version Printable version