This forum has been moved here:
Helicon Tech Community Forum

Helicon Ape (Forum Locked Forum Locked)
 Helicon Tech : Helicon Ape
Subject Topic: Confused about upgrade from ISAPI_Rewrite
Author
Message |
Taomyn
Groupie


Joined: 04 September 2003
Location: Luxembourg
Posts: 65
Posted: 31 August 2010 at 9:43am

Hi,

I thought whilst I was waiting for "share-it!" to process my order (something about reviewing my PayPal payment ) that I would install the 45 day trial version on my Win2k8 R2 server running ISAPI_Rewrite v3.

I ran the installer and there was no mention of IR, either about migrating it or removing it. No big deal, I just thought it would do something. What did annoy me though was that the installer initially wanted me to install APE to "C:\Program Files (x86)" instead of "C:\Program Files". I tried to force it by changing the folder myself, but it still placed it into x86 folder - so I have removed it for now and will wait.

Is there a "guide" or FAQ for the upgrade from IR to APE? I don't want or need to be running both.
Back to Top
 
Vyacheslav
Admin Group


Joined: 02 July 2008
Location: Ukraine
Posts: 1542
Posted: 31 August 2010 at 10:45am

Hello,
I’m sorry for the inconvenience.
Normally you don’t need both tools installed on the same server.
“C:\Program Files (x86)” is a default location, and there is no problem to have Helicon Ape installed there.

Upgrade actions are very simple:
    1. Uninstall ISAPI_Rewrite, preserving existent configuration.

    2. Install Helicon Ape.

    3. Open Helicon Ape Manager and make sure it’s able to see your websites and detects .htaccess files.

    4. Make sure “RewriteEngine on” directive is written in every .htaccess file. In Helicon Ape it’s a must.


Please let me know if you have any questions/problems setting up Helicon Ape.

Thank you.

__________________
Slavik Shynkarenko,
Helicon Tech.
Back to Top Visit Vyacheslav's Homepage
 
Taomyn
Groupie


Joined: 04 September 2003
Location: Luxembourg
Posts: 65
Posted: 31 August 2010 at 10:49am

Thanks for the quick response, but I am not happy to install to (x86) when ISAPI_Rewrite had no issues installing to the correct folder for x64 system. I will wait until you fix the installer as it should be obeying my request to choose another folder.

What about my settings/rules in httpd.conf for ISAPI_Rewrite? Are they imported into Ape when I install it or do I have to do this manually somehow?
Back to Top
 
Vyacheslav
Admin Group


Joined: 02 July 2008
Location: Ukraine
Posts: 1542
Posted: 31 August 2010 at 10:57am

Hello,
I’ll discuss the installer issue with developers and let you know.

There is no automatic converter from ISAPI_Rewrite to Helicon Ape. Syntax is almost compatible. httpd.conf bears a little bit different meaning in Helicon Ape. The software is more powerful than ISAPI_Rewrite which was implemented as only one module among many others—mod_rewrite.

I can help you to adapt your ISAPI_Rewrite configuration for Helicon Ape. Please simply send httpd.conf and .htaccess’es to [email protected]

Thank you.

__________________
Slavik Shynkarenko,
Helicon Tech.
Back to Top Visit Vyacheslav's Homepage
 
Taomyn
Groupie


Joined: 04 September 2003
Location: Luxembourg
Posts: 65
Posted: 01 September 2010 at 10:00am

Hi,

My httpd.conf, which is cut down as some lines are very long looks like:

RewriteEngine On
#RewriteCompatibility2 On
RepeatLimit 200
RewriteBase

# A-L
RewriteCond %{HTTP:User-Agent} (192.comAgent||lwp-trivial) [NC]
RewriteRule .? /block/block.php?AgentFound=%1 [NC,L]

# M-Z
RewriteCond %{HTTP:User-Agent} (Mass|Zeus) [NC]
RewriteRule .? /block/block.php?AgentFound=%1 [NC,L]

I don't have many .htaccess files but one that is no longer working is:

# Helicon ISAPI_Rewrite configuration file
# Version 3.1.0.68

RewriteBase /
RewriteProxy (.*) http://localhost:8080/$1 [CR]

I think if you can help me fix these two, the rest I can hopefully do myself.
Back to Top
 
Taomyn
Groupie


Joined: 04 September 2003
Location: Luxembourg
Posts: 65
Posted: 01 September 2010 at 1:45pm

Tell me, is RewriteProxy in Ape meant to be 100% compatible with the same command in ISAPI_Rewrite?

I made my rule:

RewriteEngine on
RewriteBase /sabnzbd
RewriteProxy (.*) http://localhost:8080/$1 [CR]

Although it initially loads the other service, any links in the page try to take me to http://localhost:8080 rather than the original URL and therefore fails.

Also, the help text says that the flag for RewriteProxy is C, it's not. Only CR works.

Looks like I might need to revert back to ISAPI_Rewrite


Back to Top
 
Vyacheslav
Admin Group


Joined: 02 July 2008
Location: Ukraine
Posts: 1542
Posted: 01 September 2010 at 3:57pm

Hello,
Please don’t worry we can help you to configure Helicon Ape as you wish.

Please uncomment “RewriteLogLevel 9” in httpd.conf and make a few non-working requests. You’ll have several records in the rewrite.log file.
Please provide the file here.

Thank you.

__________________
Slavik Shynkarenko,
Helicon Tech.
Back to Top Visit Vyacheslav's Homepage
 
Taomyn
Groupie


Joined: 04 September 2003
Location: Luxembourg
Posts: 65
Posted: 02 September 2010 at 2:51am

Vyacheslav wrote:
Hello,
Please don’t worry we can help you to configure Helicon Ape as you wish.

Please uncomment “RewriteLogLevel 9” in httpd.conf and make a few non-working requests. You’ll have several records in the rewrite.log file.
Please provide the file here.

Thank you.


I'm sure you can help, you have always been very good in the past.

I did try the logging just before I posted, but it doesn't show anything useful as far as I can tell:


192.168.1.11 192.168.1.11  [01/Sep/2010:20:09:59] [www.mydomain.com/sid#2][rid#59498027/initial] (1) [perdir d:\websites\mydomain.com\sabnzbd\] init rewrite engine with /sabnzbd/
192.168.1.11 192.168.1.11  [01/Sep/2010:20:09:59] [www.mydomain.com/sid#2][rid#59498027/initial] (5) [perdir d:\websites\mydomain.com\sabnzbd\] strip matching prefix: /sabnzbd/ ->
192.168.1.11 192.168.1.11  [01/Sep/2010:20:09:59] [www.mydomain.com/sid#2][rid#59498027/initial] (3) [perdir d:\websites\mydomain.com\sabnzbd\] applying pattern (.*) to uri
192.168.1.11 192.168.1.11  [01/Sep/2010:20:09:59] [www.mydomain.com/sid#2][rid#59498027/initial] (1) [perdir d:\websites\mydomain.com\sabnzbd\] go-ahead with proxy request http://localhost:8080/ [OK]

192.168.1.11 192.168.1.11  [01/Sep/2010:20:09:59] [www.mydomain.com/sid#2][rid#17152151/initial] (1) [perdir d:\websites\mydomain.com\sabnzbd\] init rewrite engine with /sabnzbd/static/stylesheets/plush-default.css
192.168.1.11 192.168.1.11  [01/Sep/2010:20:09:59] [www.mydomain.com/sid#2][rid#17152151/initial] (5) [perdir d:\websites\mydomain.com\sabnzbd\] strip matching prefix: /sabnzbd/static/stylesheets/plush-default.css -> static/stylesheets/plush-default.css
192.168.1.11 192.168.1.11  [01/Sep/2010:20:09:59] [www.mydomain.com/sid#2][rid#17152151/initial] (3) [perdir d:\websites\mydomain.com\sabnzbd\] applying pattern (.*) to uri static/stylesheets/plush-default.css
192.168.1.11 192.168.1.11  [01/Sep/2010:20:09:59] [www.mydomain.com/sid#2][rid#17152151/initial] (1) [perdir d:\websites\mydomain.com\sabnzbd\] go-ahead with proxy request http://localhost:8080/static/stylesheets/plush-default.css?0.5.4 [OK]

192.168.1.11 192.168.1.11  [01/Sep/2010:20:09:59] [www.mydomain.com/sid#2][rid#7831673/initial] (1) [perdir d:\websites\mydomain.com\sabnzbd\] init rewrite engine with /sabnzbd/static/javascripts/plush.js
192.168.1.11 192.168.1.11  [01/Sep/2010:20:09:59] [www.mydomain.com/sid#2][rid#7831673/initial] (5) [perdir d:\websites\mydomain.com\sabnzbd\] strip matching prefix: /sabnzbd/static/javascripts/plush.js -> static/javascripts/plush.js
192.168.1.11 192.168.1.11  [01/Sep/2010:20:09:59] [www.mydomain.com/sid#2][rid#7831673/initial] (3) [perdir d:\websites\mydomain.com\sabnzbd\] applying pattern (.*) to uri static/javascripts/plush.js
192.168.1.11 192.168.1.11  [01/Sep/2010:20:09:59] [www.mydomain.com/sid#2][rid#7831673/initial] (1) [perdir d:\websites\mydomain.com\sabnzbd\] go-ahead with proxy request http://localhost:8080/static/javascripts/plush.js?0.5.4 [OK]

192.168.1.11 192.168.1.11  [01/Sep/2010:20:09:59] [www.mydomain.com/sid#2][rid#45331437/initial] (1) [perdir d:\websites\mydomain.com\sabnzbd\] init rewrite engine with /sabnzbd/rss
192.168.1.11 192.168.1.11  [01/Sep/2010:20:09:59] [www.mydomain.com/sid#2][rid#45331437/initial] (5) [perdir d:\websites\mydomain.com\sabnzbd\] strip matching prefix: /sabnzbd/rss -> rss
192.168.1.11 192.168.1.11  [01/Sep/2010:20:09:59] [www.mydomain.com/sid#2][rid#45331437/initial] (3) [perdir d:\websites\mydomain.com\sabnzbd\] applying pattern (.*) to uri rss
192.168.1.11 192.168.1.11  [01/Sep/2010:20:09:59] [www.mydomain.com/sid#2][rid#45331437/initial] (1) [perdir d:\websites\mydomain.com\sabnzbd\] go-ahead with proxy request http://localhost:8080/rss?mode=history [OK]

192.168.1.11 192.168.1.11  [01/Sep/2010:20:09:59] [www.mydomain.com/sid#2][rid#47967795/initial] (1) [perdir d:\websites\mydomain.com\sabnzbd\] init rewrite engine with /sabnzbd/queue/
192.168.1.11 192.168.1.11  [01/Sep/2010:20:09:59] [www.mydomain.com/sid#2][rid#47967795/initial] (5) [perdir d:\websites\mydomain.com\sabnzbd\] strip matching prefix: /sabnzbd/queue/ -> queue/
192.168.1.11 192.168.1.11  [01/Sep/2010:20:09:59] [www.mydomain.com/sid#2][rid#47967795/initial] (3) [perdir d:\websites\mydomain.com\sabnzbd\] applying pattern (.*) to uri queue/
192.168.1.11 192.168.1.11  [01/Sep/2010:20:09:59] [www.mydomain.com/sid#2][rid#47967795/initial] (1) [perdir d:\websites\mydomain.com\sabnzbd\] go-ahead with proxy request http://localhost:8080/queue/ [OK]

192.168.1.11 192.168.1.11  [01/Sep/2010:20:09:59] [www.mydomain.com/sid#2][rid#19586269/initial] (1) [perdir d:\websites\mydomain.com\sabnzbd\] init rewrite engine with /sabnzbd/history/
192.168.1.11 192.168.1.11  [01/Sep/2010:20:09:59] [www.mydomain.com/sid#2][rid#19586269/initial] (5) [perdir d:\websites\mydomain.com\sabnzbd\] strip matching prefix: /sabnzbd/history/ -> history/
192.168.1.11 192.168.1.11  [01/Sep/2010:20:09:59] [www.mydomain.com/sid#2][rid#19586269/initial] (3) [perdir d:\websites\mydomain.com\sabnzbd\] applying pattern (.*) to uri history/
192.168.1.11 192.168.1.11  [01/Sep/2010:20:09:59] [www.mydomain.com/sid#2][rid#19586269/initial] (1) [perdir d:\websites\mydomain.com\sabnzbd\] go-ahead with proxy request http://localhost:8080/history/ [OK]

192.168.1.11 192.168.1.11  [01/Sep/2010:20:09:01] [www.mydomain.com/sid#2][rid#51646239/initial] (1) [perdir d:\websites\mydomain.com\sabnzbd\] init rewrite engine with /sabnzbd/queue/
192.168.1.11 192.168.1.11  [01/Sep/2010:20:09:01] [www.mydomain.com/sid#2][rid#51646239/initial] (5) [perdir d:\websites\mydomain.com\sabnzbd\] strip matching prefix: /sabnzbd/queue/ -> queue/
192.168.1.11 192.168.1.11  [01/Sep/2010:20:09:01] [www.mydomain.com/sid#2][rid#51646239/initial] (3) [perdir d:\websites\mydomain.com\sabnzbd\] applying pattern (.*) to uri queue/
192.168.1.11 192.168.1.11  [01/Sep/2010:20:09:01] [www.mydomain.com/sid#2][rid#51646239/initial] (1) [perdir d:\websites\mydomain.com\sabnzbd\] go-ahead with proxy request http://localhost:8080/queue/ [OK]

192.168.1.11 192.168.1.11  [01/Sep/2010:20:09:01] [www.mydomain.com/sid#2][rid#60186182/initial] (1) [perdir d:\websites\mydomain.com\sabnzbd\] init rewrite engine with /sabnzbd/history/
192.168.1.11 192.168.1.11  [01/Sep/2010:20:09:01] [www.mydomain.com/sid#2][rid#60186182/initial] (5) [perdir d:\websites\mydomain.com\sabnzbd\] strip matching prefix: /sabnzbd/history/ -> history/
192.168.1.11 192.168.1.11  [01/Sep/2010:20:09:01] [www.mydomain.com/sid#2][rid#60186182/initial] (3) [perdir d:\websites\mydomain.com\sabnzbd\] applying pattern (.*) to uri history/
192.168.1.11 192.168.1.11  [01/Sep/2010:20:09:01] [www.mydomain.com/sid#2][rid#60186182/initial] (1) [perdir d:\websites\mydomain.com\sabnzbd\] go-ahead with proxy request http://localhost:8080/history/ [OK]

192.168.1.11 192.168.1.11  [01/Sep/2010:20:09:03] [www.mydomain.com/sid#2][rid#20819944/initial] (1) [perdir d:\websites\mydomain.com\sabnzbd\] init rewrite engine with /sabnzbd/queue/
192.168.1.11 192.168.1.11  [01/Sep/2010:20:09:03] [www.mydomain.com/sid#2][rid#20819944/initial] (5) [perdir d:\websites\mydomain.com\sabnzbd\] strip matching prefix: /sabnzbd/queue/ -> queue/
192.168.1.11 192.168.1.11  [01/Sep/2010:20:09:03] [www.mydomain.com/sid#2][rid#20819944/initial] (3) [perdir d:\websites\mydomain.com\sabnzbd\] applying pattern (.*) to uri queue/
192.168.1.11 192.168.1.11  [01/Sep/2010:20:09:03] [www.mydomain.com/sid#2][rid#20819944/initial] (1) [perdir d:\websites\mydomain.com\sabnzbd\] go-ahead with proxy request http://localhost:8080/queue/ [OK]

192.168.1.11 192.168.1.11  [01/Sep/2010:20:09:03] [www.mydomain.com/sid#2][rid#38370912/initial] (1) [perdir d:\websites\mydomain.com\sabnzbd\] init rewrite engine with /sabnzbd/history/
192.168.1.11 192.168.1.11  [01/Sep/2010:20:09:03] [www.mydomain.com/sid#2][rid#38370912/initial] (5) [perdir d:\websites\mydomain.com\sabnzbd\] strip matching prefix: /sabnzbd/history/ -> history/
192.168.1.11 192.168.1.11  [01/Sep/2010:20:09:03] [www.mydomain.com/sid#2][rid#38370912/initial] (3) [perdir d:\websites\mydomain.com\sabnzbd\] applying pattern (.*) to uri history/
192.168.1.11 192.168.1.11  [01/Sep/2010:20:09:03] [www.mydomain.com/sid#2][rid#38370912/initial] (1) [perdir d:\websites\mydomain.com\sabnzbd\] go-ahead with proxy request http://localhost:8080/history/ [OK]

192.168.1.11 192.168.1.11  [01/Sep/2010:20:09:04] [www.mydomain.com/sid#2][rid#4088196/initial] (1) [perdir d:\websites\mydomain.com\sabnzbd\] init rewrite engine with /sabnzbd/connections
192.168.1.11 192.168.1.11  [01/Sep/2010:20:09:04] [www.mydomain.com/sid#2][rid#4088196/initial] (5) [perdir d:\websites\mydomain.com\sabnzbd\] strip matching prefix: /sabnzbd/connections -> connections
192.168.1.11 192.168.1.11  [01/Sep/2010:20:09:04] [www.mydomain.com/sid#2][rid#4088196/initial] (3) [perdir d:\websites\mydomain.com\sabnzbd\] applying pattern (.*) to uri connections
192.168.1.11 192.168.1.11  [01/Sep/2010:20:09:04] [www.mydomain.com/sid#2][rid#4088196/initial] (1) [perdir d:\websites\mydomain.com\sabnzbd\] go-ahead with proxy request http://localhost:8080/connections [OK]

192.168.1.11 192.168.1.11  [01/Sep/2010:20:09:05] [www.mydomain.com/sid#2][rid#11725031/initial] (1) [perdir d:\websites\mydomain.com\sabnzbd\] init rewrite engine with /sabnzbd/queue/
192.168.1.11 192.168.1.11  [01/Sep/2010:20:09:05] [www.mydomain.com/sid#2][rid#11725031/initial] (5) [perdir d:\websites\mydomain.com\sabnzbd\] strip matching prefix: /sabnzbd/queue/ -> queue/
192.168.1.11 192.168.1.11  [01/Sep/2010:20:09:05] [www.mydomain.com/sid#2][rid#11725031/initial] (3) [perdir d:\websites\mydomain.com\sabnzbd\] applying pattern (.*) to uri queue/
192.168.1.11 192.168.1.11  [01/Sep/2010:20:09:05] [www.mydomain.com/sid#2][rid#11725031/initial] (1) [perdir d:\websites\mydomain.com\sabnzbd\] go-ahead with proxy request http://localhost:8080/queue/ [OK]

192.168.1.11 192.168.1.11  [01/Sep/2010:20:09:05] [www.mydomain.com/sid#2][rid#61010740/initial] (1) [perdir d:\websites\mydomain.com\sabnzbd\] init rewrite engine with /sabnzbd/history/
192.168.1.11 192.168.1.11  [01/Sep/2010:20:09:05] [www.mydomain.com/sid#2][rid#61010740/initial] (5) [perdir d:\websites\mydomain.com\sabnzbd\] strip matching prefix: /sabnzbd/history/ -> history/
192.168.1.11 192.168.1.11  [01/Sep/2010:20:09:05] [www.mydomain.com/sid#2][rid#61010740/initial] (3) [perdir d:\websites\mydomain.com\sabnzbd\] applying pattern (.*) to uri history/
192.168.1.11 192.168.1.11  [01/Sep/2010:20:09:05] [www.mydomain.com/sid#2][rid#61010740/initial] (1) [perdir d:\websites\mydomain.com\sabnzbd\] go-ahead with proxy request http://localhost:8080/history/ [OK]


I've tried with both Firefox and Internet Explorer and both browsers behave the same. The main page from the service appears, but then any links on the page are changed to http://localhost:8080 which obviously will not work from outside the network.
Back to Top
 
Taomyn
Groupie


Joined: 04 September 2003
Location: Luxembourg
Posts: 65
Posted: 02 September 2010 at 4:12am

Additional info.

I looked a bit closer and it does seem the page has the correct links, well almost.

I get the main page ok with: https://www.mydomain.com/sabnzbd

When I look at a link I get for example: https://www.mydomain.com/sabnzbd/connections

If I enter on my laptop https://www.mydomain.com/sabnzbd/connections I get the error. If I enter https://www.mydomain.com/sabnzbd/connections/ i.e. with the trailing slash, it works.

However, on the server itself http://localhost:8080/connections and http://localhost:8080/connections/ both work fine.

Hope that makes sense, though still not sure why it's not working
Back to Top
 
Vyacheslav
Admin Group


Joined: 02 July 2008
Location: Ukraine
Posts: 1542
Posted: 02 September 2010 at 8:24am

Hello,
I’ve replied in another ticket of yours.
Thanks.

__________________
Slavik Shynkarenko,
Helicon Tech.
Back to Top Visit Vyacheslav's Homepage
 

Sorry, you can NOT post a reply.
This forum has been locked by a forum administrator.

Printable version Printable version