This forum has been moved here:
Helicon Tech Community Forum

Helicon Ape (Forum Locked Forum Locked)
 Helicon Tech : Helicon Ape
Subject Topic: How do I get HTTP_X_REWRITE_URL using ape
Author
Message |
joegass
Newbie


Joined: 02 May 2008
Posts: 8
Posted: 26 August 2010 at 11:49am

I'm testing ape as I can't get isapi rewrite to work on
windows server 2008 r2
The rewrite works but I can't access the server variable
HTTP_X_REWRITE_URL as I did with isapi rewite.

Is there a way to enable this?

Thanks a lot
Back to Top Visit joegass's Homepage
 
Vyacheslav
Admin Group


Joined: 02 July 2008
Location: Ukraine
Posts: 1542
Posted: 26 August 2010 at 1:28pm

Hello,
Please enable mod_setenvif in httpd.conf and try this code:
Code:
SetEnvIf %{REQUEST_URI} (.*) HTTP_X_REWRITE_URL=$1


__________________
Slavik Shynkarenko,
Helicon Tech.
Back to Top Visit Vyacheslav's Homepage
 
joegass
Newbie


Joined: 02 May 2008
Posts: 8
Posted: 27 August 2010 at 6:45am

Thanks for your reply.

I've added that line to be bottom of httpd.conf

and mod_setenvif is being loaded using LoadModule

Then restarted the webserver.

When looking at the server variables collection it still
isn't there.

Any ideas why this isn't working?

Thanks
Back to Top Visit joegass's Homepage
 
Vyacheslav
Admin Group


Joined: 02 July 2008
Location: Ukraine
Posts: 1542
Posted: 27 August 2010 at 9:10am

Hello,
Please make sure application pool isn’t run in classic pipeline.
Thanks.

__________________
Slavik Shynkarenko,
Helicon Tech.
Back to Top Visit Vyacheslav's Homepage
 
joegass
Newbie


Joined: 02 May 2008
Posts: 8
Posted: 31 August 2010 at 6:30am

The app is running in classic mode, so that was the
problem.
Couldn't get the app to run in integrated, so we're
reverted to isapi-rewrite.
Thanks
Back to Top Visit joegass's Homepage
 
Kurisotofa
Newbie


Joined: 06 September 2010
Location: Belgium
Posts: 5
Posted: 20 September 2010 at 6:01am

I have the same problem after having installed APE with IIS6 on our Win 2003 server!
Any ideas to solve this?

I have setenvif_module enabled, and added the rule "SetEnvIf %{REQUEST_URI} (.*) HTTP_X_REWRITE_URL=$1" to our httpd.conf file.

Since we're using IIS6, I have no way to specify my application pool in integrated or classic mode.
Back to Top Visit Kurisotofa's Homepage
 
jaygreasley
Newbie


Joined: 07 December 2010
Posts: 7
Posted: 07 December 2010 at 7:49am

Did you ever solve this?
Back to Top
 
joegass
Newbie


Joined: 02 May 2008
Posts: 8
Posted: 07 December 2010 at 7:52am

no, we reverted to isapi rewrite
Back to Top Visit joegass's Homepage
 
jaygreasley
Newbie


Joined: 07 December 2010
Posts: 7
Posted: 07 December 2010 at 8:17am

thanks. I may need to do the same.

Back to Top
 
Vyacheslav
Admin Group


Joined: 02 July 2008
Location: Ukraine
Posts: 1542
Posted: 07 December 2010 at 8:35am

Hello.
This problem is only related to Classic pipeline and IIS6. 100% of Ape’s features work in IIS7/IIS7.5 running Integrated pipeline.

Thanks.

__________________
Slavik Shynkarenko,
Helicon Tech.
Back to Top Visit Vyacheslav's Homepage
 
joegass
Newbie


Joined: 02 May 2008
Posts: 8
Posted: 07 December 2010 at 8:46am

Thanks for the info.
We were migrating from iis6 to iis7 and had to run some
sites in classic - which is where the issue lies.

Back to Top Visit joegass's Homepage
 

Sorry, you can NOT post a reply.
This forum has been locked by a forum administrator.

Printable version Printable version