This forum has been moved here:
Helicon Tech Community Forum

  Active TopicsActive Topics  Display List of Forum MembersMemberlist  HelpHelp   RegisterRegister  LoginLogin
ISAPI_Rewrite 2.x (Forum Locked Forum Locked)
 Helicon Tech : ISAPI_Rewrite 2.x
Subject Topic: "
Author
Message |
bhellman1
Newbie


Joined: 17 May 2007
Posts: 20
Posted: 20 August 2010 at 6:15pm

I need to force HTTPS, I'm doing that int he HTTPD.INI but having an
issue..

Here is my rewrite rule:
RewriteCond %HTTPS (?!on).*
RewriteCond Host: (.*)
RewriteRule (.*) https\://$1$2 [I,RP]

IIS keeps spitting out the following when the Url is HTTP, if it's https it
doesn't error:

-cache
Content-Type: text/html
Content-Length: 161
Location: https://blahblah.mainblah.com/

<html><body>The requested resource was moved. It could be found
here: <a href="https://blahblah.mainblah.com/">https://dev-
notebox.intuit.com/</a></body></html>



Any ideas?
Back to Top Visit bhellman1's Homepage
 
Vyacheslav
Admin Group


Joined: 02 July 2008
Location: Ukraine
Posts: 1542
Posted: 23 August 2010 at 6:15am

Hello,
Please make sure there is no custom error setting for 301 response code.
Please also get raw response and provide it here. You may use WFetch.
Thanks.

__________________
Slavik Shynkarenko,
Helicon Tech.
Back to Top Visit Vyacheslav's Homepage
 

Sorry, you can NOT post a reply.
This forum has been locked by a forum administrator.

Printable version Printable version
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot delete your posts in this forum
You cannot edit your posts in this forum
You cannot create polls in this forum
You cannot vote in polls in this forum