This forum has been moved here:
Helicon Tech Community Forum

Helicon Ape (Forum Locked Forum Locked)
 Helicon Tech : Helicon Ape
Subject Topic: IIS7.5 Ape installation
Author
Message |
demazter
Newbie


Joined: 19 August 2010
Location: United Kingdom
Posts: 4
Posted: 19 August 2010 at 6:44am

Hi All,

I have recently had a website developed and it is designed for Apache and therefore uses a .htaccess file.

I downloaded and installed Ape on my Windows 2008 R2 server with IIS7.5

I am at a loss as to what I need to configure from now to make the website work?  Can anyone point me in the right direction?

Thanks



__________________
demazter
Back to Top
 
Vyacheslav
Admin Group


Joined: 02 July 2008
Location: Ukraine
Posts: 1542
Posted: 19 August 2010 at 7:29am

Hello,
Please run Helicon Ape manager and select the website in the tree. You will see your .htaccess. Actually it should be already processed, but maybe something has to be configured.
Please provide me with the .htaccess file.
Thanks.

__________________
Slavik Shynkarenko,
Helicon Tech.
Back to Top Visit Vyacheslav's Homepage
 
demazter
Newbie


Joined: 19 August 2010
Location: United Kingdom
Posts: 4
Posted: 19 August 2010 at 7:55am

Hi Slava,

Yes the .htaccess file appears in the list.

 

The contents of the file are:

Options +FollowSymLinks
RewriteEngine on

RewriteRule _News/(.+)/$ index.php?News=$1&pageid=News [L]
RewriteRule _Gallery/(.+)/$ index.php?Album=$1 [L]
RewriteRule _Blog/(.+)/$ index.php?Blog=$1 [L]

RewriteRule (.+)/$ /index.php?pageid=$1
RewriteRule (.+)/(.+)/$ /index.php?pageid=$2
RewriteRule (.+)/(.+)/(.+)/$ /index.php?pageid=$3

Thanks

Glen

 



__________________
demazter
Back to Top
 
Vyacheslav
Admin Group


Joined: 02 July 2008
Location: Ukraine
Posts: 1542
Posted: 19 August 2010 at 10:36am

Hello,
Please comment out all the rules and try this:
Code:
RewriteEngine on
RewriteRule .? - [G]


You should see “Gone” response on every request. Otherwise Ape wasn’t installed properly.

__________________
Slavik Shynkarenko,
Helicon Tech.
Back to Top Visit Vyacheslav's Homepage
 
demazter
Newbie


Joined: 19 August 2010
Location: United Kingdom
Posts: 4
Posted: 19 August 2010 at 12:43pm

Hi Slava,

Where should I see "Gone"?

All I get when I try the tabs on the website are the IIS File or Directory not found.

Thanks

Glen 



__________________
demazter
Back to Top
 
Vyacheslav
Admin Group


Joined: 02 July 2008
Location: Ukraine
Posts: 1542
Posted: 19 August 2010 at 2:04pm

Hello,
You should see this response on every request. If you don’t please open Helicon Ape manager, select the site in the tree and click right mouse button. Select “Zip and Save...”. This action will create an archive with relevant data. Please send the archive to [email protected]

Thanks.

__________________
Slavik Shynkarenko,
Helicon Tech.
Back to Top Visit Vyacheslav's Homepage
 
demazter
Newbie


Joined: 19 August 2010
Location: United Kingdom
Posts: 4
Posted: 20 August 2010 at 7:11am

Hi Slave,

I have sent the requested file.

Regards

Glen



__________________
demazter
Back to Top
 

Sorry, you can NOT post a reply.
This forum has been locked by a forum administrator.

Printable version Printable version