This forum has been moved here:
Helicon Tech Community Forum

  Active TopicsActive Topics  Display List of Forum MembersMemberlist  HelpHelp   RegisterRegister  LoginLogin
ISAPI_Rewrite 2.x (Forum Locked Forum Locked)
 Helicon Tech : ISAPI_Rewrite 2.x
Subject Topic: Strange problem
Author
Message |
freakystreak
Newbie


Joined: 09 July 2010
Location: United Kingdom
Posts: 4
Posted: 09 July 2010 at 11:29am

I'm not sure that this is a ISAPI problem but it's the
place I'm going to start with. I am not an ASP guy, more
PHP but this problem was left for me when a colleage left
and I need some help.

Over the last few days we've noticed on our website that
some re-written URLs both new and some old, established
URLs no longer display the page but display 'Page could
not be found'.

I have checked the script which generates the .httpd.ini
and it seems fine, an ASP script, and within the
.httpd.ini I can see the re-written URLs there. However
they do not go to the correct page when viewed through a
browser.

Can anyone help? Btw we are using ISAPI Rewrite 2.8 on
our server. I don't really understand how it all works
and our server host doesn't support third-party-software
so that's why I came here.

Cheers.
Back to Top
 
freakystreak
Newbie


Joined: 09 July 2010
Location: United Kingdom
Posts: 4
Posted: 12 July 2010 at 5:02am

Is there a limit on how many URLs are re-written? If there
is a limit, would that automatically cause previous urls to
stop working in order for the new urls to work?
Back to Top
 
Anton
Admin Group


Joined: 30 January 2007
Location: Ukraine
Posts: 10519
Posted: 12 July 2010 at 8:42am

"Is there a limit on how many URLs are re-written?"
- well, the limit is only theoretical. We do not recommend to have more than 100-150 rules in config. How many do you have?

"would that automatically cause previous urls to stop working in order for the new urls to work?"
- no, it will still work but slowly.

"Over the last few days we've noticed on our website that
some re-written URLs both new and some old, established
URLs no longer display the page but display 'Page could
not be found'."
- So the site was working fine before? Or you were not responsible for that before?

Please check httpd.parse.errors file in ISAPI_Rewrite installation folder for possible error messages.


__________________
Regards,
Anton
Back to Top
 
freakystreak
Newbie


Joined: 09 July 2010
Location: United Kingdom
Posts: 4
Posted: 12 July 2010 at 9:15am

The site was working fine before. This has only happened
a few days ago and it would appear than newer URLs are
appearing as they should. We have URLs that have been
listed by Google and cached but now no longer work. I'm
not saying it's a problem with ISAPI but it was the first
place I thought to ask. I have never used this software
before so have no idea how it works.

The config contains hardly any rules. The previous person
who wrote the site set up a script that runs every night
and this writes urls to the httpd.ini file held in the
root of the site. I can see the URL, rewritten within
this file.

I have checked the httpd.parse.errors file within the
ISAPI folder and it's empty.

Thanks for the reply.
Back to Top
 
freakystreak
Newbie


Joined: 09 July 2010
Location: United Kingdom
Posts: 4
Posted: 30 July 2010 at 4:14am

I have since upgraded to version 3 because of the limit
in version 2 of the http.ini file. Upgrade was successful
and our non working urls are now working.

However..since the upgrade was carried out, we have since
added new products and these are now not working. Our re-
write script has rewritten the urls but the new urls are
going to 'this page cannot be displayed' page.

Can anyone help?

Here is some example of the rules which we are using:

this url works:
/office-products/copier-paper/ /prod2.asp\?
CID=40&PID=2074 [I,L]

this url does not:
/office-products/adhesives/ /prod2.asp\?CID=40&PID=4736
[I,L]

as you can see there is no difference in the way the url
is re-written. Any help would be greatly appreciated.
Back to Top
 
Anton
Admin Group


Joined: 30 January 2007
Location: Ukraine
Posts: 10519
Posted: 30 July 2010 at 6:30am

Please provide rewrite.log records for the working and non-working request.

__________________
Regards,
Anton
Back to Top
 

Sorry, you can NOT post a reply.
This forum has been locked by a forum administrator.

Printable version Printable version
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot delete your posts in this forum
You cannot edit your posts in this forum
You cannot create polls in this forum
You cannot vote in polls in this forum