This forum has been moved here:
Helicon Tech Community Forum

Helicon Ape (Forum Locked Forum Locked)
 Helicon Tech : Helicon Ape
Subject Topic: Ape + IIS6 Problems
Author
Message |
yellow
Newbie


Joined: 07 July 2010
Posts: 4
Posted: 07 July 2010 at 10:14am

Hello,

We have helicon ape enabled on a virtual site in which we have wordpress. The problem is we can't get mod rewrite working, we just get a 404. We have tried the test rule RewriteRule . � [F] in the .htaccess but this doesn't even show. We are running IIS6 and we have the wildcard map done as well. Here is our web.config

<?xml version="1.0" encoding="utf-8"?>
<configuration>
    <system.web>
        <httpHandlers>
            <remove path="*.apehandler" verb="*" />
            <add path="*.apehandler" verb="*" type="Helicon.Ape.Handler, Helicon.Ape, Version=3.0.0.42, Culture=neutral, PublicKeyToken=95bfbfd1a38437eb"
                validate="false" />
        </httpHandlers>
        <httpModules>
            <remove name="Helicon.Ape" />
            <add name="Helicon.Ape" type="Helicon.Ape.ApeModule, Helicon.Ape, Version=3.0.0.42, Culture=neutral, PublicKeyToken=95bfbfd1a38437eb" />
        </httpModules>
    </system.web>
</configuration>

Here is our .htaccess with test disabled, ignore the strange character please.

# Helicon Ape version 3.0.0.42

#RewriteRule . � [F]

# BEGIN WordPress
<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /index.php [L]
</IfModule>
# END WordPress

Here is the error Error log

[07/07/2010 16:19:20] [LicenseManager] Site with id=1 is working with free license
[07/07/2010 16:19:20] [mod_core_context] (8) [/1/hello-world] ConfigFactory.LoadHtaccess: c:\intranet\.htaccess
[07/07/2010 16:19:24] [mod_core_context] (8) [/wp-content/themes/twentyten/style.css] ConfigFactory.LoadHtaccess:
[07/07/2010 16:19:24] [mod_core_context] (8) [/wp-content/themes/twentyten/style.css] ConfigFactory.LoadHtaccess:
[07/07/2010 16:19:24] [mod_core_context] (8) [/wp-content/themes/twentyten/style.css] ConfigFactory.LoadHtaccess:
[07/07/2010 16:19:24] [mod_core_context] (8) [/wp-content/themes/twentyten/images/headers/path.jpg] ConfigFactory.LoadHtaccess:
[07/07/2010 16:19:24] [mod_core_context] (8) [/wp-content/themes/twentyten/images/headers/path.jpg] ConfigFactory.LoadHtaccess:



Edited by yellow - 07 July 2010 at 10:47am
Back to Top
 
Vyacheslav
Admin Group


Joined: 02 July 2008
Location: Ukraine
Posts: 1542
Posted: 07 July 2010 at 2:39pm

Hello,
Please make sure that ASP.NET 2.0 enabled for this website, and aspnet_isapi.dll version 2.0 is mapped on the wild-card.

__________________
Slavik Shynkarenko,
Helicon Tech.
Back to Top Visit Vyacheslav's Homepage
 
yellow
Newbie


Joined: 07 July 2010
Posts: 4
Posted: 07 July 2010 at 3:04pm

Hello, we have ASP.NET 2.0 enabled on this site and aspnet_isapi.dll mapped on the wildcard. We have spent a day and a half trying to get this to work we need it.

Thanks

Back to Top
 
yellow
Newbie


Joined: 07 July 2010
Posts: 4
Posted: 08 July 2010 at 4:44am

We've tried to use isapi_rewrite and it works ok but we would still like to use helicon ape. We have the paid for version on another similar server.

Thanks



Edited by yellow - 08 July 2010 at 5:19am
Back to Top
 
Vyacheslav
Admin Group


Joined: 02 July 2008
Location: Ukraine
Posts: 1542
Posted: 08 July 2010 at 5:30am

Hello,
Would you like me to assist you through remote desktop connection? You may send login credentials over E-Mail to [email protected]

P.S.: If there are no plans to use anything but mod_rewrite, you may consider ISAPI_Rewrite 3 as Helicon Ape isn’t totally suitable for IIS6. I can convert your license.

__________________
Slavik Shynkarenko,
Helicon Tech.
Back to Top Visit Vyacheslav's Homepage
 
yellow
Newbie


Joined: 07 July 2010
Posts: 4
Posted: 08 July 2010 at 5:36am

Hello, we have decided to use ISAPI_Rewrite on this server as mod_rewrite is all we are using here. On our other server where we have the paid for version we have not fully installed/tried this out so we will get back if we have problems. Thanks for your assistance.
Back to Top
 

Sorry, you can NOT post a reply.
This forum has been locked by a forum administrator.

Printable version Printable version