This forum has been moved here:
Helicon Tech Community Forum

Helicon Ape (Forum Locked Forum Locked)
 Helicon Tech : Helicon Ape
Subject Topic: AuthType Basic inheritance on subfolders
Author
Message |
Vyacheslav
Admin Group


Joined: 02 July 2008
Location: Ukraine
Posts: 1542
Posted: 20 July 2010 at 1:06am

Hello,
I still hope to have a live meeting session with you in order to see all those issues and find a solution. The case is really interesting and maybe we have to fix something in Ape. So if you agree, please let me know the most suitable way for you.

The license isn’t bound to hardware, however 1 license allows you to use 1 copy of Helicon Ape on any physical or virtual server. You can transfer your license, but you shouldn’t use 1 license to attend 2 or more machines.

Thanks.

__________________
Slavik Shynkarenko,
Helicon Tech.
Back to Top Visit Vyacheslav's Homepage
 
linliao123
Newbie


Joined: 17 August 2010
Posts: 3
Posted: 17 August 2010 at 3:42am

Hello,
Thank you for the files
Back to Top
 
ecunningham
Newbie


Joined: 12 January 2012
Posts: 1
Posted: 12 January 2012 at 12:13pm

pardon the necromancy, but I am having the same problem
as the original poster. root website has an htaccess file
that requires basic authentication, which is working
properly. one of the subfolders has been converted to an
application, which i wish to remove authentication from.
Additionally, his workaround of inserting bad entries
into the .htacess file do not work for me, even after
doing so the subfolder still prompts for a login.

I have verified that the .htacess file in the subfolder I
wish to remove protection from has read permission set
for IUSR, IIS_WPG, IIS_IUSRS, the applicationpoolidentity
account, and a few more accounts for good measure.

Windows 2008 R2 / IIS 7.5
Helicon Ape 3.0.0.71

here is the htaccess file of the root site:

AuthType Basic
AuthName "Preview Server"

AuthBasicProvider file
AuthUserFile c:\inetpub\.htpasswds
Require valid-user

and the htaccess file of the application:

AuthName "test"

Satisfy Any
Order Allow,Deny
Allow from all

The popup window for the subsite displays 'Preview Site',
instead of 'test', indicating that it is not using the
subfolder's htaccess file. Can you provide any direction?
Back to Top
 
mattross
Newbie


Joined: 29 June 2010
Posts: 17
Posted: 13 January 2012 at 2:51am

See the other thread I created more recently where this is working correctly.

Edited by mattross - 13 January 2012 at 2:52am
Back to Top
 

Sorry, you can NOT post a reply.
This forum has been locked by a forum administrator.

<< Prev Page of 2
 
Printable version Printable version