This forum has been moved here:
Helicon Tech Community Forum

Helicon Ape (Forum Locked Forum Locked)
 Helicon Tech : Helicon Ape
Subject Topic: Ape rewrite not working at all
Author
Message |
dcit
Newbie


Joined: 09 June 2010
Posts: 3
Posted: 09 June 2010 at 2:23am

We're migrating a site from iis6 to iis7. We've been using isapi rewrite version 2 and we want to get Helicon Ape running on it but we're having difficulties.  We can't get Ape to do any rewrite at all.
We've even tried:

RewriteEngine On
RewriteRule . - [F]

But it doesn't have any effect.
The site is running in Integrated Mode.  Ape is enabled for the site. The httpd.conf file has the "LoadModule rewrite_module" line uncommented.

What are we missing?
Thanks in advance for the help.
Back to Top
 
Vyacheslav
Admin Group


Joined: 02 July 2008
Location: Ukraine
Posts: 1542
Posted: 09 June 2010 at 2:44am

Hello,
Please provide me with error.log records. You may find the file near httpd.conf.
Thanks.

__________________
Slavik Shynkarenko,
Helicon Tech.
Back to Top Visit Vyacheslav's Homepage
 
dcit
Newbie


Joined: 09 June 2010
Posts: 3
Posted: 09 June 2010 at 3:19am

I'm not actually at the machine right now, i'm doing some testing at home on a VM and I'm getting the same results as on the machine at
work. I first tried testing some rules that I have ready to use, but they weren't working and I noticed the syntax error in the log so
erased everything and just left in "RewriteRule . - [F]". Also I later commented out the other modules in httpd.conf to see if that would
have any affect.

Here's the error.log from my VM. I'll post the error log from the actual machine in the morning, but I think they're pretty much identical.
Thanks again for your time.
error.log:

[6/9/2010 12:16:11 AM] [LicenseManager] Site with id=1 is working with free license
[6/9/2010 12:16:11 AM] [cache_module] items stored in the cache: 0; bytes available for the cache: 578964602, physical memory limit: 96%
[6/9/2010 12:16:12 AM] [ConfigLoader] (4) [/www.domain.com/images/dcmain.jpg] c:\dc\.htaccess(45): Error in the rewrite_module.
Line: RewriteRule (/cellular/pn/_[^/_]$ http\:/p/$1 [NC,L,QSA,R=301]
Error in the rewrite_module.
Line: RewriteRule (/cellular/pn/_[^/_]$ http\:/p/$1 [NC,L,QSA,R=301]
Incorrect syntax rewriterule (/cellular/pn/_[^/_]$ http\:/p/$1 [NC,L,QSA,R=301]
[6/9/2010 12:16:13 AM] [ConfigLoader] (4) [/www.domain.com/Default.htm] c:\dc\.htaccess(45): Error in the rewrite_module.
Line: RewriteRule (/cellular/pn/_[^/_]$ http\:/p/$1 [NC,L,QSA,R=301]
Error in the rewrite_module.
Line: RewriteRule (/cellular/pn/_[^/_]$ http\:/p/$1 [NC,L,QSA,R=301]
Incorrect syntax rewriterule (/cellular/pn/_[^/_]$ http\:/p/$1 [NC,L,QSA,R=301]
[6/9/2010 12:17:21 AM] [ConfigLoader] (4) [/www.domain.com/Default.htm] c:\dc\.htaccess(45): Error in the rewrite_module.
Line: RewriteRule (/cellular/pn/_[^/_]$ http\:/p/$1 [NC,L,QSA,R=301]
Error in the rewrite_module.
Line: RewriteRule (/cellular/pn/_[^/_]$ http\:/p/$1 [NC,L,QSA,R=301]
Incorrect syntax rewriterule (/cellular/pn/_[^/_]$ http\:/p/$1 [NC,L,QSA,R=301]
[6/9/2010 12:21:01 AM] [LicenseManager] Site with id=1 is working with free license
[6/9/2010 12:21:01 AM] [cache_module] items stored in the cache: 0; bytes available for the cache: 578964602, physical memory limit: 96%
[6/9/2010 12:23:31 AM] [LicenseManager] Site with id=1 is working with free license
[6/9/2010 12:23:31 AM] [cache_module] items stored in the cache: 0; bytes available for the cache: 578964602, physical memory limit: 96%
[6/9/2010 12:25:24 AM] [LicenseManager] Site with id=1 is working with free license
[6/9/2010 12:25:24 AM] [cache_module] items stored in the cache: 0; bytes available for the cache: 578964602, physical memory limit: 96%
[6/9/2010 12:40:50 AM] [LicenseManager] Site with id=1 is working with free license
[6/9/2010 12:44:19 AM] [LicenseManager] Site with id=1 is working with free license
[6/9/2010 1:12:03 AM] [LicenseManager] Site with id=1 is working with free license
Back to Top
 
Vyacheslav
Admin Group


Joined: 02 July 2008
Location: Ukraine
Posts: 1542
Posted: 09 June 2010 at 4:37am

Hello,
Thanks for the log. I believe the error is in regular expression. Parentheses aren’t complete. Please try this:
Code:
RewriteRule (/cellular/pn/_[^/_]+) http://p$1 [NC,L,QSA,R=301]


Though maybe it’s not what you want. Please let me know your aim and I’ll try and design a new rule for you.
Thanks.

__________________
Slavik Shynkarenko,
Helicon Tech.
Back to Top Visit Vyacheslav's Homepage
 
dcit
Newbie


Joined: 09 June 2010
Posts: 3
Posted: 09 June 2010 at 1:57pm

Right, that should fix the syntax error, but my main
problem is that even if the only rewrite I have in the
.htaccess file is:

RewriteEngine On
RewriteRule . - [F]

it doesn't have any effect. It's like i'm still missing
some setting to turn on rewriting for the site.
Back to Top
 
Vyacheslav
Admin Group


Joined: 02 July 2008
Location: Ukraine
Posts: 1542
Posted: 10 June 2010 at 1:27am

Hello,
Please open Helicon Ape Manager and in the tree on the left select the website. Click right mouse button and in the context menu select “Zip and Save configuration”. It will collect all the relevant configuration files in an archive. Please send the archive to [email protected]
I’ll analyze it and let you know what to do.
Thanks.

__________________
Slavik Shynkarenko,
Helicon Tech.
Back to Top Visit Vyacheslav's Homepage
 

Sorry, you can NOT post a reply.
This forum has been locked by a forum administrator.

Printable version Printable version