This forum has been moved here:
Helicon Tech Community Forum

  Active TopicsActive Topics  Display List of Forum MembersMemberlist  HelpHelp   RegisterRegister  LoginLogin
Common Questions (Forum Locked Forum Locked)
 Helicon Tech : Common Questions
Subject Topic: HTTPS to HTTP Redirect Issues
Author
Message |
dtnsemprog
Newbie


Joined: 10 March 2010
Location: United States
Posts: 19
Posted: 21 May 2010 at 1:07pm

I am using ISAPI_Rewrite 3.1.0.63 on IIS 7.0.  I do not have access to the logs.

I have tried several ways to redirect all HTTPS requests to HTTP because the site I am working on is on a shared IP.  When I got to the HTTP site it's fine but if I go to HTTPS it redirects the site to another site that shares this same IP.

I have tried rules that caused errors and I have tried the rules below which do not cause an error but also do not work:

RewriteCond %{HTTPS} (?:on).*
RewriteCond %{HTTP:Host} (.*)
RewriteRule (.*) http\://$1$2 [NC,R=301]

RewriteCond %{HTTPS} on
RewriteCond %{HTTP_HOST} ^(?:www\.)?site\.com$
RewriteRule (.*) http://www.site.com/$1 [NC,R=301,L]

RewriteCond %{HTTPS} off
RewriteCond %{HTTP_HOST} ^site\.com$
RewriteRule (.*) http://www.site.com/$1 [NC,R=301,L]

Anyone know how I could make this work?

Thanks in advance,

Jon
Back to Top
 
dtnsemprog
Newbie


Joined: 10 March 2010
Location: United States
Posts: 19
Posted: 21 May 2010 at 6:07pm

One more thing...the site https request redirects to (the one sharing the IP) does have an ssl cert and a secure area for purchases.  The one I am working on does not.
Back to Top
 
Guests
Guest


Joined: 01 October 2003
Online Status: Online
Posts: -160
Posted: 25 May 2010 at 5:02am

Hello Jon,
please, provide the .htaccess as it is, if possible.
Are other rules working?
Have you tried the testing rules as described in FAQ?

Regards
Andrew
Back to Top
 
dtnsemprog
Newbie


Joined: 10 March 2010
Location: United States
Posts: 19
Posted: 25 May 2010 at 10:44am

Andrew,

I am using an isapi_mod_rewrite.ini file on IIS 7.0.  Can't really paste all the rules here because the file is 172 lines long. However, all other rules are working fine.  In fact, the rules above have worked for me at other times.  I was thinking this had something to do with the fact that the site is on a shared IP and the other site has an ssl cert where this one does not.

Jon
Back to Top
 
Guests
Guest


Joined: 01 October 2003
Online Status: Online
Posts: -160
Posted: 26 May 2010 at 3:41am

Jon, please, send the file via helpdesk marking the letter "To ANdrushkaUS".
We'll take a look.

Regards
Andrew
Back to Top
 

Sorry, you can NOT post a reply.
This forum has been locked by a forum administrator.

Printable version Printable version
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot delete your posts in this forum
You cannot edit your posts in this forum
You cannot create polls in this forum
You cannot vote in polls in this forum