This forum has been moved here:
Helicon Tech Community Forum

  Active TopicsActive Topics  Display List of Forum MembersMemberlist  HelpHelp   RegisterRegister  LoginLogin
LinkFreeze (Forum Locked Forum Locked)
 Helicon Tech : LinkFreeze
Subject Topic: how to Exclude directory? (Topic Closed Topic Closed)
Author
Message |
jitesh_83
Newbie


Joined: 24 March 2009
Posts: 10
Posted: 24 March 2009 at 10:21am  

How do i exclude a sub directory?

I've tried entering the following but it doesn't work:

@/(?!dirname).*

Thanks.

Back to Top
 
Sergey
Admin Group


Joined: 11 March 2005
Posts: 750
Posted: 24 March 2009 at 10:42am  

Please show exact content of LinkFreeze config.
And please explain what do you mean under "Exclude"
-for freezing
-for defreezing
-or both

It must look like:

@/(?!dirname).* --- .asp [MoveExt]
Back to Top
 
jitesh_83
Newbie


Joined: 24 March 2009
Posts: 10
Posted: 24 March 2009 at 10:49am  

I would like to apply link freeze to all parts of my website apart from pages in the admin folder.

here is the config:

#################################################
# LinkFreeze Configuration file
# Version 2, 2, 0, 81


LogRewrite=False
NotifyOrder=MEDIUM


@/(?!mkpct/admin).*  ~~~ .asp  [MoveExt]
/mkpct  ~~~ .asp  [MoveExt]

LinkFreeze is still being applied to all pages/links in the admin folder which i do not want.

Your help is much appreciated.

 

Back to Top
 
Sergey
Admin Group


Joined: 11 March 2005
Posts: 750
Posted: 24 March 2009 at 11:05am  

Please remove last rule and try this one

@/(?!mkpct/admin).* ~~~ .asp @(?!mkpct/admin).* [MoveExt]
Back to Top
 
jitesh_83
Newbie


Joined: 24 March 2009
Posts: 10
Posted: 25 March 2009 at 8:16am  

Hi.

That does exlude the mkpct/admin directory.

But now linkfreeze is being applied to all of my other websites in iis.

please help.

Back to Top
 
Sergey
Admin Group


Joined: 11 March 2005
Posts: 750
Posted: 25 March 2009 at 9:34am  

By default LinkFreeze is configured only for one IIS site and configuration file can't spread on other sites.

Did you enable LinkFreeze by Snap-in or manualy?
Back to Top
 
jitesh_83
Newbie


Joined: 24 March 2009
Posts: 10
Posted: 25 March 2009 at 10:16am  

I enabled it by snap in.

I think the problem is I have many virtual directories within the default web site folder and thus its being applied to all directories.

I imagine this is common setup for many people.

I have got around this by doing the following:

@/(?!dir1|dir2).* ~~~  [MoveExt]

where dir1 and dir2 are the virtual directories i want to exclude.

Would you say this is the right/best way to do it?

Back to Top
 
Sergey
Admin Group


Joined: 11 March 2005
Posts: 750
Posted: 25 March 2009 at 10:34am  

Yes this method is absolutely correct.
Back to Top
 

Sorry, you can NOT post a reply.
This forum has been locked by a forum administrator.

Printable version Printable version
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot delete your posts in this forum
You cannot edit your posts in this forum
You cannot create polls in this forum
You cannot vote in polls in this forum