This forum has been moved here:
Helicon Tech Community Forum

  Active TopicsActive Topics  Display List of Forum MembersMemberlist  HelpHelp   RegisterRegister  LoginLogin
LinkFreeze (Forum Locked Forum Locked)
 Helicon Tech : LinkFreeze
Subject Topic: 404 errors (Topic Closed Topic Closed)
Author
Message |
Rodrigo333
Newbie


Joined: 26 August 2007
Location: United States
Posts: 13
Posted: 07 December 2008 at 10:16pm  

Please give us a helping hand here.

HTTP Error 404 - File or directory not found.
Internet Information Services (IIS)

http://www.pickyhomes.com/Real_Estate_Listings_US.asp?state=New+Mexico&city=Bernalillo&code=0010

http://www.pickyhomes.com/Real_Estate_Listings_US-state-New+Mexico-city-Bernalillo-code-0010.htm

To reproduce errors:
First, we do not have many Home Listings (Home Advertisements) in the web site. We do have Home Listings in New Mexico.
We get the error when we select any listing in 1. main page Highlights.
2. Fast Search of New Mexico, then select the Listings that appear.
3. State Links at the bottom of every page, New Mexico, then Bernalillo, then Albuquerque, then select the links to try to view Home Listing.

All these Homes listings have codes, for example: 0010 these codes can be inputted by selecting the button on the left column of the web site named "Search by Ad Code". Simply type in 0010 in the Search by Ad Code area to see the listing without Linkfreeze.

#################################################
# LinkFreeze Configuration file
# Version 2, 2, 0, 76

LogRewrite=True
NotifyOrder=HIGH

@/(?!images|css|script).*  --- .asp  [MoveExt,AbsLinks]

Settings:
Replace ?, &, = with -
Checked<<<Move File extension to the end of URL
Replace  asp  file extension with htm
Checked<<<Log modified URLs

Advanced settings:
Checked<<<Decode incoming requests
Unchecked<<<Redirect old style requests
Checked<<<Transforms links on pages
Checked<<<Transforms absolute links
Unchecked<<<Lower case
HTML link filter>>>Blank

ISAPI Filters:
LinkFreeze  Priority High (Green Arrow Up)

Regards,

Rodrigo

Back to Top Visit Rodrigo333's Homepage
 
Anton
Admin Group


Joined: 30 January 2007
Location: Ukraine
Posts: 10519
Posted: 09 December 2008 at 8:03am  

Firstly, please add Redirect flag to your rule.
And please update to the latest 81st build of LinkFreeze.

__________________
Regards,
Anton
Back to Top
 
Rodrigo333
Newbie


Joined: 26 August 2007
Location: United States
Posts: 13
Posted: 09 December 2008 at 3:53pm  

Hello Anton! Thanks for answering so promptly.

I understand about the update to the 81st build -my hosting house can do the upload and installation so, no problem there; However, I do not know how to 'Redirect flag to my rule'. Is there some kind of literature or thread that can explain how to do this procedure?

Regards,

Rodrigo

 

Back to Top Visit Rodrigo333's Homepage
 
Rodrigo333
Newbie


Joined: 26 August 2007
Location: United States
Posts: 13
Posted: 09 December 2008 at 10:00pm  

Hello again Anton,

I figured out what the 'Redirect flag to my rule' was.
No effect on Version 76.

I did manage to download version 81 and upload/install 81 to the server with no problems. I didn't know that that it would wipe out my current LinkFreeze settings, register info and license. Luckily, I had that info readily available.

After re-configuring LinkFreeze on the new 81 version, I set the settings exactly as you describe and adding
'Redirect flag to my rule', Everything worked fine! No more 404 errors! You Da Man Anton! You get an "Atta-Boy"!

However, when I go into the listings and select on one of the Pictures to make it bigger, it gave me an error:
Bad Request (Invalid URL).

So, I took off the 'Redirect flag to my rule' and Everything functioned fine. So, you are still the Man!

# LinkFreeze Configuration file
# Version 2, 2, 0, 81
LogRewrite=True
NotifyOrder=MEDIUM
@/(?!images|css|script).*        ---    .asp        [MoveExt,AbsLinks]

I guess if it works, it works me.
Thanks.

Regards,
Rodrigo

Back to Top Visit Rodrigo333's Homepage
 
Anton
Admin Group


Joined: 30 January 2007
Location: Ukraine
Posts: 10519
Posted: 10 December 2008 at 3:57am  

Actually your site can perfectly work without Redirect flag, but it (Redirect flag) makes search engines redirect old indexed links to new
ones. So we advise to use it.

You could get Bad Request error if you have URLScan installed. If you do have it, please consider changing your picture urls so that they
don't contain "https://www.pickyhomes.com" in querystring:
http://www.pickyhomes.com/picture.asp?path=https://www.pickyhomes.com/files/ads/0010/0010-01.jpg&picture=0010-
01.jpg&caption=<b>Picture%201</b><b>:%20</b>379%20camino%20del%20puebl

Also can you please describe the way you updated LinkFreeze, so we could investigate why you've lost settings.

__________________
Regards,
Anton
Back to Top
 
Rodrigo333
Newbie


Joined: 26 August 2007
Location: United States
Posts: 13
Posted: 11 December 2008 at 7:48pm  

Hello Anton,

We changed the "https://www.pickyhomes.com" in the query string and it did not have a favorable affect - Same Bad Request. I left Redirect "On" in the server for you to see.

#################################################
# LinkFreeze Configuration file
# Version 2, 2, 0, 81
LogRewrite=True
NotifyOrder=MEDIUM
@/(?!images|css|script).*        ---    .asp        [MoveExt,AbsLinks,Redirect]

Any idea what we could do to over come this?


As for the information concerning the installation of LinkFreeze V81 on our Server, all I did was download the automatic package to the server and install it. The wizard went through all the uploading. After it was installed, a message came up for 45 day trial period and a link to type in the 'Business' and 'Key', I typed in the name and the key from Version 67, it accepted and then ended. When I went into LinkFreeze all the data was gone. So I typed it in.
However, version 67 was installed by the server peopl using the manual option.
That is it.

Regards,
Rodrigo
Back to Top Visit Rodrigo333's Homepage
 
Rodrigo333
Newbie


Joined: 26 August 2007
Location: United States
Posts: 13
Posted: 11 December 2008 at 8:54pm  

Anton,
By-the-way, the ISAPI Filter Executables for Ver. 81 are: C:\Program Files\Helicon\LinkFreeze\Filters\LinkFreeze212041783.dll with a priority of 'Unknown'. Is this correct?

Regards,
Rodrigo
Back to Top Visit Rodrigo333's Homepage
 
Rodrigo333
Newbie


Joined: 26 August 2007
Location: United States
Posts: 13
Posted: 11 December 2008 at 10:01pm  

Hi Anton,
Another 'By-the-Way: I just received work back from the Hosting Service Engineers of our Server, We do not have URLScan installed on the server.
Regards,
Rodrigo
Back to Top Visit Rodrigo333's Homepage
 
Anton
Admin Group


Joined: 30 January 2007
Location: Ukraine
Posts: 10519
Posted: 12 December 2008 at 7:33am  

Can you please make sure you don't have LinkFreeze filter registered twice. Check it in ISAPI filters tab for Web Sites and each Web site.
Also please specify what other ISAPI filters are you using (if any).
And send the copy of your metabase to [email protected]

"Unknown" filter priority is normal for IIS6, it will change to normal after first request and snap-in restart.

__________________
Regards,
Anton
Back to Top
 
Rodrigo333
Newbie


Joined: 26 August 2007
Location: United States
Posts: 13
Posted: 16 December 2008 at 12:52pm  

Hello Anton,

We have only 1 (Linkfreeze) Filter being use on pickyhomes.com of the 3 websites on our deticated server. There is another filter being used by all 3 websites; however, the filter is for 'FrontPage'. I will be sending the filter configuration to: [email protected]

For numerous security reasons, we cannot send you a copy of your complete metabase, however, we will send a security trimmed version of our individual website configuration, which should give you the information you need about our website setup. It will be sent in the same email to [email protected]. Thanks.

Regards,

Rodrigo

 

Back to Top Visit Rodrigo333's Homepage
 
Anton
Admin Group


Joined: 30 January 2007
Location: Ukraine
Posts: 10519
Posted: 17 December 2008 at 7:11am  

Some parameters in your url (e.g. below) contain dashes (-) and you adjusted LinkFreeze to change "&" etc to dash, and when LinkFreeze attempts
to unfreeze the link it does not know which dashes are inside parameter and which separate parameters.

http://www.pickyhomes.com/picture.asp?path=https://www.pickyhomes.com/files/ads/0010/0010-01.jpg&picture=0010-
01.jpg&caption=<b>Picture%201</b><b>:%20</b>379%20camino%20del%20puebl

Solution:
you should either remove dashes from your parameters or set replacement character in LinkFreeze to ~ for example.

__________________
Regards,
Anton
Back to Top
 
Rodrigo333
Newbie


Joined: 26 August 2007
Location: United States
Posts: 13
Posted: 17 December 2008 at 7:13pm  

Hi Anton,
I set replacement character in LinkFreeze to ~. I am still getting a Bad Request Error in IE.
Any ideas?

Regards,
Rodrigo

Back to Top Visit Rodrigo333's Homepage
 
Anton
Admin Group


Joined: 30 January 2007
Location: Ukraine
Posts: 10519
Posted: 18 December 2008 at 4:13am  

Please provide IIS log records for the failing request.

__________________
Regards,
Anton
Back to Top
 
Rodrigo333
Newbie


Joined: 26 August 2007
Location: United States
Posts: 13
Posted: 26 December 2008 at 7:17pm  

Anton,

FYI (For Your Information),
This did work for us.

Regards,
Rodrigo
---------------------------

In URLs like this
/picture.asp?path=https://www.pickyhomes.com/files/ads/0010/0010-01.jpg&picture=0010-01.jpg&caption=<b>Picture%201</b><b>:%20</b>379%20camino%20del%20puebl

please replace < to %26lt; and > to %26gt;
because IIS6 doesn't allow <> symbols in file names.


--------
Best regards,
 Vyacheslav Shinkarenko, Helicon Tech
Back to Top Visit Rodrigo333's Homepage
 

Sorry, you can NOT post a reply.
This forum has been locked by a forum administrator.

Printable version Printable version
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot delete your posts in this forum
You cannot edit your posts in this forum
You cannot create polls in this forum
You cannot vote in polls in this forum