This forum has been moved here:
Helicon Tech Community Forum

  Active TopicsActive Topics  Display List of Forum MembersMemberlist  HelpHelp   RegisterRegister  LoginLogin
HotlinkBlocker (Forum Locked Forum Locked)
 Helicon Tech : HotlinkBlocker
Subject Topic: Cannot self sign automaticall in wml file (Topic Closed Topic Closed)
Author
Message |
liujia
Newbie


Joined: 27 August 2008
Posts: 5
Posted: 01 September 2008 at 6:25am  

Using Link protection type.

can't not sign automatically in wml file.

can Signing links manually, for example, via asp script. but in some situation, CMS software filtered asp code, for example:

filtered before:
Code:
<IMG src="/images/<%=Request.ServerVariables("HTTP_X_HOTLINKBLOCKER_SIGNATURE")%>/picture.gif"/>


filtered:
Code:
<IMG src="/images/%3C%=Request.ServerVariables(%22HTTP_X_HOTLINKBLOCKER_SIGNATURE%22)%%3E/picture.gif"/>


Back to Top
 
Anton
Admin Group


Joined: 30 January 2007
Location: Ukraine
Posts: 10519
Posted: 03 September 2008 at 4:46am  

Please tell what CMS are you using.
Does asp work for you at all? In which "situations" do you encounter problems?


__________________
Regards,
Anton
Back to Top
 
liujia
Newbie


Joined: 27 August 2008
Posts: 5
Posted: 03 September 2008 at 5:06am  

1.) Using A WAP(create WML files) CMS software. But it's interface is not English, I'm not sure you can read it. It works like Wap Portal Server(http://www.sakic.net/wps/)

2.) Some CMS just can used BBCode(like Forum Codes here), can't attach script, like I can't
Code:
<% Response.Write("Hello World!") %>
in this topic content.

<% Response.Write("Hello World!") %>
Back to Top
 
Anton
Admin Group


Joined: 30 January 2007
Location: Ukraine
Posts: 10519
Posted: 03 September 2008 at 8:08am  

Does the above code show you "Hello World!"?
Or what result do you get?

__________________
Regards,
Anton
Back to Top
 
liujia
Newbie


Joined: 27 August 2008
Posts: 5
Posted: 03 September 2008 at 8:30am  

got
Code:
</table>in this topic content.<br><br>&lt;%  Response.Write("<em>Hello World</em>!") %&gt;<br>


not
Code:
Hello World!


like got
Code:
<IMG
src="/images/%3C%=Request.ServerVariables(%22HTTP_X_HOTLINKBLOCKER_SIGNATURE%22)%%3E/picture.gif"/>


not
Code:
<IMG
src="/images/xsomexxxletterx/picture.gif"/>


Back to Top
 
Anton
Admin Group


Joined: 30 January 2007
Location: Ukraine
Posts: 10519
Posted: 04 September 2008 at 7:43am  

It seems that ASP is not working for you.
I would advise you to try using the following url
structure, that will work even without working ASP:

<IMG src="/images/xxxxxxxxxxxxxxxx/picture.gif"/>

__________________
Regards,
Anton
Back to Top
 
liujia
Newbie


Joined: 27 August 2008
Posts: 5
Posted: 04 September 2008 at 9:09am  

No, can't auto sign by wml or asp files.
Back to Top
 
Anton
Admin Group


Joined: 30 January 2007
Location: Ukraine
Posts: 10519
Posted: 05 September 2008 at 6:05am  

Is it possible to see your problem online?
And can you please provide more explicit explanation of your problem.

__________________
Regards,
Anton
Back to Top
 

Sorry, you can NOT post a reply.
This forum has been locked by a forum administrator.

Printable version Printable version
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot delete your posts in this forum
You cannot edit your posts in this forum
You cannot create polls in this forum
You cannot vote in polls in this forum